广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把摩擦阻力支撑点公式计算改为顺通个人信用的

  • 牛股公式
  • 2020-09-10 13:47
  • 牛股网
广告管理-720PX*80PX

撰写标准:n:3 0 100

nn:30 0 111

pp:55 1 111

{if datacountref(h,1),1,if(h

for i=datacount-1 downto 2 do begin

if llpH then pH:=hh;

if tk=1 and pL=ll[i-1]then tk:=0;

end;

DRAWTEXT(tk=1,l-(l-ref(h,1))/2,'未补'),COLORmagenta,ALIGN1;

DRAWTEXT(tk=-1,h (ref(l,1)-h)/2,'未补'),COLORgreen,ALIGN1 ;

DRAWSL(tk=1,REF(h,1),0,0,0)COLORRED;

DRAWSL(tk=1,l,0,0,0)COLORRED;

DRAWSL(tk=-1,REF(l,1),0,0,0)COLORCYAN;

DRAWSL(tk=-1,h,0,0,0)COLORCYAN;}

C3:=REF(C,1);

股票涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(股票涨停,OPEN,CLOSE,7,0),COLORRED;

STICKLINE(股票涨停,h,h,80,0),COLORRED,shift4;

股票跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);

STICKLINE(股票跌停,OPEN,CLOSE,7,0),COLORGREEN;

lnn:=BARSLAST((VOL=HHV(VOL,nn)));

K:=lnn=0;

K1:=SUMBARS(K,1);

STICKLINE(K1<=30,REF(h,K1-1)*1,REF(h,K1-1),pp,0),COLORyellow,shift3;

STICKLINE(K1<=30,REF(LOW,K1-1)*1,REF(LOW,K1-1),pp,0),COLORgreen,shift3;

STICKLINE(K1<=1,REF(OPEN,K1-1)*1,REF(CLOSE,K1-1),4,0),COLORyellow;

STICKLINE(K1ref(h,1));

顶:partline(坡屋顶,h),coloryellow,linethick2;

厚底:=l=ref(l,1) or (l=ref(l,2) and l

底:partline(厚底,l),coloryellow,linethick2;

总市值:=CLOSE*CAPITAL*VOLUNIT/100000000;

总股本:=FINANCE(1)/10000;

商品流通:=FINANCE(7)/10000;

公司股东数量:=FINANCE(50);

主要经营的业务年增长率:=FINANCE(53);

税后利润年增长率:=FINANCE(54);

纯利润年增长率:=FINANCE(55);

平均持仓:=(FINANCE( 7)/FINANCE(50))*10000;

市净率:=DYNAINFO(39);

市盈率:=CLOSE/FINANCE(34);

F:=COST(5 );J:=COST(95 );

莸利占比:=WINNER(CLOSE )*100;

日股票换手率:=VOL/CAPITAL*100;

DRAWTEXTEX(CLOSE,1,650,50,'莸利占比:'),LINETHICK2,Coloryellow;

DRAWTEXTEX(CLOSE,1,750,50,NUMTOSTR(莸利占比,2) '%'),Coloryellow;

DRAWTEXTEX(CLOSE,1,220,60,'日股票换手率:'),LINETHICK2,ColorAFFF00;

DRAWTEXTEX(CLOSE,1,320,60,NUMTOSTR(日股票换手率,2) '%'),ColorAFFF00;

//n=2,2,100//

c1:="001.c1#week";

o1:="001.o1#week";

h1:="001.h1#week";

l1:="001.l1#week";

t1:=DAY=15 OR DAY=16 OR DAY=17 OR DAY=18 OR DAY=19

OR DAY=20 OR DAY=21 OR DAY=22 OR DAY=23 OR DAY=24;

t2:=FILTER(t1,10);

d:=DAY;

YQ:=IF(DREFX(D,1),DAY,-1);

c2:="001.c1#MONTH";

o2:="001.o1#MONTH";

h2:="001.h1#MONTH";

l2:="001.l1#MONTH";

yj:=(c2>o2 or c2=o2 and c2>REF(c2,DAY));

IF DATACOUNT-2=SYSPARAM(1) then STICKLINE(t2 and yj,h2,c2,10,1)color3F7CFF;

IF DATACOUNT-2=SYSPARAM(1) then STICKLINE(t2 and yj,l2,o2,10,1)color3F7CFF;

IF DATACOUNT-2=SYSPARAM(1) then STICKLINE(t2 and NOT(yj),h2,o2,10,1)ColorF38593;

IF DATACOUNT-2=SYSPARAM(1) then STICKLINE(t2 and NOT(yj),l2,c2,10,1)ColorF38593;

IF DATACOUNT-2=SYSPARAM(1) then PARTLINE(D>REF(D,1)and yj ,c2)color3F7CFF;

IF DATACOUNT-2=SYSPARAM(1) then PARTLINE(D>REF(D,1)and NOT(yj),C2)ColorF38593;

IF DATACOUNT-2=SYSPARAM(1) then PARTLINE(D>REF(D,1)and yj ,O2)color3F7CFF;

IF DATACOUNT-2=SYSPARAM(1) then PARTLINE(D>REF(D,1)and NOT(yj) ,O2)ColorF38593;

IF DATACOUNT-2=SYSPARAM(1) then STICKLINE(YQ>0 and yj,c2,o2,0.5,0)color3F7CFF;

IF DATACOUNT-2=SYSPARAM(1) then STICKLINE(YD>0 and yj,c2,o2,0.5,0)color3F7CFF;

IF DATACOUNT-2=SYSPARAM(1) then STICKLINE(YQ>0 and NOT(yj),c2,o2,0.5,0)ColorF38593;

IF DATACOUNT-2=SYSPARAM(1) then STICKLINE(YD>0 and NOT(yj),c2,o2,0.5,0)ColorF38593;

IF DATACOUNT-2=SYSPARAM(1) then STICKLINE(t2 and yj,c2 (h2-c2)/n,o2-(o2-l2)/n,9.9,0)COLORBLACK;

IF DATACOUNT-2=SYSPARAM(1) then STICKLINE(t2 and NOT(yj),c2-(c2-l2)/n,o2 (h2-o2)/n,9.9,0)COLORBLACK;

Z:=WEEKDAY;

Zd1:=IF(Z>REF(Z,1),WEEKDAY,1);

ZQa:=IF(Zd1

T:=BARSLAST(ZQa) 1;

Zql:=LLV(DATE,T)LINETHICK0;

Zmh:=HHV(DATE,T)LINETHICK0;

ts1:=DATEDIFF(ZQl,Zmh) 1;

ts2:=IF(ts1<7,ts1,1);

ts3:=BARSLAST(ts2

z1:=MIN(ts1,ts3);

ZQa:=IF(Z1REFX(Z1,1),z1,-1);

zj:=(c1>o1 or c1=o1 and c1>REF(c1,z1));

IF DATACOUNT-1=SYSPARAM(1) then PARTLINE(z1>REF(Z1,1)and zj,l1)Color9973FD,linethick1;

IF DATACOUNT-1=SYSPARAM(1) then PARTLINE(Z1>REF(Z1,1)and zj,h1)Color9973FD,linethick1;

IF DATACOUNT-1=SYSPARAM(1) then PARTLINE(Z1>REF(Z1,1)and NOT(zj),h1)Color9DFC48,linethick1;

IF DATACOUNT-1=SYSPARAM(1) then PARTLINE(Z1>REF(Z1,1)and NOT(zj),l1)Color9DFC48,linethick1;

IF DATACOUNT-1=SYSPARAM(1) then STICKLINE(ZQa>0and zj,h1,l1,0.5,0)Color9973FD,linethick1;

IF DATACOUNT-1=SYSPARAM(1) then STICKLINE(ZDa>0and zj,h1,l1,0.5,0)Color9973FD,linethick1;

IF DATACOUNT-1=SYSPARAM(1) then STICKLINE(ZQa>0and NOT(zj),h1,l1,0.5,0)Color9DFC48,linethick1;

IF DATACOUNT-1=SYSPARAM(1) then STICKLINE(ZDa>0and NOT(zj),h1,l1,0.5,0)Color9DFC48,linethick1;

STICKLINE(ISLASTBAR,CLOSE*1.1,CLOSE*1.1,45,1),colorred,shift3;

DRAWNUMBER (ISLASTBAR,CLOSE*1.1,CLOSE*1.1,2),coloryellow,shift1;

DRAWTEXT(ISLASTBAR,CLOSE*1.08,'涨停'),COLORGREEN,shift1;

ma5:EMA(CLOSE,5);

ma10:EMA(CLOSE,17),colorwhite, LINETHICK2;

ma18:EMA(CLOSE,25), coloryellow, LINETHICK2;

ma30:EMA(CLOSE,50),colormagenta,, LINETHICK2;

ma60:=MA(CLOSE,60), LINETHICK2;

半分位:=REF((HIGH+LOW)/2,1),COLORYELLOW;

STICKLINE(半分位,半分位,半分位,4,1),COLORyellow,LINETHICK1;

input:N(3);

J1:=ISLASTBAR;

J2:=REF(HIGH,N)=HHV(HIGH,2*N+1);

J3:=FILTER(J2,N);

J4:=BACKSET(J3,N+1);

J5:=FILTER(J4,N);

J6:=J5 OR J1;

J7:=REF(LOW,N)=LLV(LOW,2*N+1);

J8:=FILTER(J7,N);

J9:=BACKSET(J8,N+1);

JA:=FILTER(J9,N);

JB:=JA AND NOT(J5);

JC:=BACKSET(J6,REF(BARSLAST(JB),1)+1);

JD:=JC>REF(JC,1);

JE:=BACKSET(JD,2);

JF:=JE>REF(JE,1);

J10:=BACKSET(JF AND COUNT(J6,REF(BARSLAST(JB),1)+2)=0,REF(BARSLAST(JB),1)+2);

J11:=J10>REF(J10,1);

J12:=BACKSET(J11 AND COUNT(J6,REF(BARSLAST(JB),1)+2)=0,REF(BARSLAST(JB),1)+2);

J13:=J12>REF(J12,1);

J14:=IF(J6,COUNT(JB,REF(BARSLAST(J6),1)+1),0);

J15:=IF(J14=1 AND J6,BARSLAST(JF),0);

J16:=IF(J6 AND REF(LOW,BARSLAST(JF))>=REF(LOW,BARSLAST(J11)),BARSLAST(J11),BARSLAST(JF));

J17:=IF(J14=2 AND J6,J16,0);

J18:=IF(J14>=3 AND J6,IF(J6 AND REF(LOW,J16)>=REF(LOW,BARSLAST(J13)),BARSLAST(J13),J16),0);

J19:=J15+J17+J18;

J1A:=BACKSET(J6,J19);

J1B:=J1A>REF(J1A,1);

J1C:=BACKSET(J1B,2);

J1D:=J1C>REF(J1C,1);

J1E:=J1D OR J1;

J1F:=BACKSET(J1E,REF(BARSLAST(J6),1)+1);

J20:=J1F>REF(J1F,1);

J21:=BACKSET(J20,2);

J22:=J21>REF(J21,1);

J23:=BACKSET(J22 AND COUNT(J1E,REF(BARSLAST(J6),1)+2)=0,REF(BARSLAST(J6),1)+2);

J24:=J23>REF(J23,1);

J25:=BACKSET(J24 AND COUNT(J1E,REF(BARSLAST(J6),1)+2)=0,REF(BARSLAST(J6),1)+2);

J26:=J25>REF(J25,1);

J27:=IF(J1E,COUNT(J5,REF(BARSLAST(J1E),1)+1),0);

J28:=IF(J27=1 AND J1E,BARSLAST(J22),0);

J29:=IF(J1E AND REF(HIGH,BARSLAST(J22))=3 AND J1E,IF(J1E AND REF(HIGH,J29)REF(J2D,1);

J2F:=BACKSET(J2E,2);

J30:=J2F>REF(J2F,1);

J37:=BACKSET(J1,BARSLAST(J1D)+1);

J38:=J37>REF(J37,1);

J39:=BACKSET(J38,REF(BARSLAST(J1D),1)+2);

J3A:=J39>REF(J39,1);

J3B:=BACKSET(J1,BARSLAST(J30)+1);

J3C:=J3B>REF(J3B,1);

J3D:=BACKSET(J3C,REF(BARSLAST(J30),1)+2);

J3E:=J3D>REF(J3D,1),Coloryellow,POINTDOT;

DRAWLINE(J3A,LOW,J38,LOW,1),Coloryellow,POINTDOT;

DRAWLINE(J3E,HIGH,J3C,HIGH,1),Coloryellow,POINTDOT;

前一低: REF(LOW,BARSLAST(J38)),Colorcyan,POINTDOT,Linethick3;

前二低: REF(LOW,BARSLAST(J3A)),Colormagenta,POINTDOT,Linethick2;

前一高: REF(HIGH,BARSLAST(J3C)),Colorcyan,POINTDOT,Linethick3;

前二高: REF(HIGH,BARSLAST(J3E)),Colormagenta,POINTDOT,Linethick2;

DRAWTEXT(VOL<=REF(LLV(VOL,34),1),LOW*0.99,'★'),COLORyellow

编写方法:{N(1,100,3)}

J1:=ISLASTBAR;

J2:=REF(HIGH,N)=HHV(HIGH,2*N+1);

J3:=FILTER(J2,N);

J4:=BACKSET(J3,N+1);

J5:=FILTER(J4,N);

J6:=J5 OR J1;

J7:=REF(LOW,N)=LLV(LOW,2*N+1);

J8:=FILTER(J7,N);

J9:=BACKSET(J8,N+1);

JA:=FILTER(J9,N);

JB:=JA AND NOT(J5);

JC:=BACKSET(J6,REF(BARSLAST(JB),1)+1);

JD:=JC>REF(JC,1);

JE:=BACKSET(JD,2);

JF:=JE>REF(JE,1);

J10:=BACKSET(JF AND COUNT(J6,REF(BARSLAST(JB),1)+2)=0,REF(BARSLAST(JB),1)+2);

J11:=J10>REF(J10,1);

J12:=BACKSET(J11 AND COUNT(J6,REF(BARSLAST(JB),1)+2)=0,REF(BARSLAST(JB),1)+2);

J13:=J12>REF(J12,1);

J14:=IF(J6,COUNT(JB,REF(BARSLAST(J6),1)+1),0);

J15:=IF(J14=1 AND J6,BARSLAST(JF),0);

J16:=IF(J6 AND REF(LOW,BARSLAST(JF))>=REF(LOW,BARSLAST(J11)),BARSLAST(J11),BARSLAST(JF));

J17:=IF(J14=2 AND J6,J16,0);

J18:=IF(J14>=3 AND J6,IF(J6 AND REF(LOW,J16)>=REF(LOW,BARSLAST(J13)),BARSLAST(J13),J16),0);

J19:=J15+J17+J18;

J1A:=BACKSET(J6,J19);

J1B:=J1A>REF(J1A,1);

J1C:=BACKSET(J1B,2);

J1D:=J1C>REF(J1C,1);

J1E:=J1D OR J1;

J1F:=BACKSET(J1E,REF(BARSLAST(J6),1)+1);

J20:=J1F>REF(J1F,1);

J21:=BACKSET(J20,2);

J22:=J21>REF(J21,1);

J23:=BACKSET(J22 AND COUNT(J1E,REF(BARSLAST(J6),1)+2)=0,REF(BARSLAST(J6),1)+2);

J24:=J23>REF(J23,1);

J25:=BACKSET(J24 AND COUNT(J1E,REF(BARSLAST(J6),1)+2)=0,REF(BARSLAST(J6),1)+2);

J26:=J25>REF(J25,1);

J27:=IF(J1E,COUNT(J5,REF(BARSLAST(J1E),1)+1),0);

J28:=IF(J27=1 AND J1E,BARSLAST(J22),0);

J29:=IF(J1E AND REF(HIGH,BARSLAST(J22))<=REF(HIGH,BARSLAST(J24)),BARSLAST(J24),BARSLAST(J22));

J2A:=IF(J27=2 AND J1E,J29,0);

J2B:=IF(J27>=3 AND J1E,IF(J1E AND REF(HIGH,J29)<=REF(HIGH,BARSLAST(J26)),BARSLAST(J26),J29),0);

J2C:=J28+J2A+J2B;

J2D:=BACKSET(J1E,J2C);

J2E:=J2D>REF(J2D,1);

J2F:=BACKSET(J2E,2);

J30:=J2F>REF(J2F,1);

J37:=BACKSET(J1,BARSLAST(J1D)+1);

J38:=J37>REF(J37,1);

J39:=BACKSET(J38,REF(BARSLAST(J1D),1)+2);

J3A:=J39>REF(J39,1);

J3B:=BACKSET(J1,BARSLAST(J30)+1);

J3C:=J3B>REF(J3B,1);

J3D:=BACKSET(J3C,REF(BARSLAST(J30),1)+2);

J3E:=J3D>REF(J3D,1);

DRAWLINE(J3A,LOW,J38,LOW,1),COLORYELLOW,DOTLINE;

DRAWLINE(J3E,HIGH,J3C,HIGH,1),COLORYELLOW,,DOTLINE;

前一低: REF(LOW,BARSLAST(J38)),COLORCYAN;

前二低: REF(LOW,BARSLAST(J3A)),COLORMAGENTA;

前一高: REF(HIGH,BARSLAST(J3C)),COLORCYAN;

前二高: REF(HIGH,BARSLAST(J3E)),COLORMAGENTA;

DRAWTEXT(VOL<=REF(LLV(VOL,34),1),LOW*0.99,'★'),COLORYELLOW;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号