广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

将135战术改为选股公式,内附战术公式计算

  • 牛股公式
  • 2020-09-10 08:27
  • 牛股网
广告管理-720PX*80PX

撰写标准:求将135战术改为选股公式 将公式计算中的“红杏出墙” 网络黑客点一下 红衣服侠侣 标准改成3个选股公式 谢谢了

公式计算以下

EMA13:EMA(C,13),COLORWHITE,LINETHICK2;

EMA34:EMA(C,34),COLORYELLOW;

EMA55:EMA(C,55),COLORFF00FF;

EMA120:EMA(C,120),COLORFFCC66;

AR1:=EMA55>EMA34 AND EMA34>EMA13;

AR2:=BARSLAST((C-EMA13)/EMA13*100=REF(EMA13,2);

AR4:=COUNT(CROSS(C,EMA13),AR2)=1;

AR5:=AR1 AND AR2 AND AR3 AND AR4;

AR6:=AR5 AND FILTER(AR5,10);

DRAWTEXT(AR6,L-0.09,'红杏出墙'),COLORYELLOW;

{STICKLINE(AR6,H,L,0.5,1),COLORYELLOW;}

{STICKLINE(AR6,O,C,6,1),LINETHICK2,COLORYELLOW;}

BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5;

BR2:=ABS((EMA13-EMA34) (EMA34-EMA55))/CEMA55 AND (REF(C,1)

(C,5)0.5;

CR2:=V>MA(V,5)*0.6;

CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;

CR4:=ABS(EMA34-EMA55)/EMA55<0.03;

CR5:=EMA55=REF(EMA55,1);

CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);

{STICKLINE(CR6,H,L,0.5,1),COLORF00FF0;}

{STICKLINE(CR6,O,C,6,1),LINETHICK2,COLORF00FF0;}

DRAWTEXT(CR6,L-0.09,'红衣侠女'),COLORF00FF0;

DR1:=EMA13>EMA34 AND EMA34C AND CEMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1;

DR6:=C>REF(C,1) ;

DR7:= DR1 AND DR5 AND DR6 ;

DR8:=DR7 AND FILTER(DR7 ,10);

DRAWTEXT(DR8,L-0.09,'网络黑客点一下'),COLORD6BA63;

{STICKLINE(DR8,H,L,0.5,1),COLORD6BA63;}

STICKLINE(DR8,O,C,6,1),LINETHICK2,COLORD6BA63;

ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55);

DRAWTEXT(ER,L-0.09,'移动平均线交换'),COLOR0099FF;

{STICKLINE(ER,H,L,0.5,1),COLOR0099FF;}

{STICKLINE(ER,O,C,6,1),LINETHICK2,COLOR0099FF;}

FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34);

DRAWTEXT(FR,L-0.09,'梅开二度'),COLORWHITE;

STICKLINE(FR,H,L,0.5,1),COLORWHITE;

{STICKLINE(FR,O,C,6,1),LINETHICK2,COLORWHITE;}

GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5) );

GR2:=EMA13>EMA34 AND EMA34>EMA55 AND EMA13>REF(EMA13,1);

GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1);

GR4:=H=HHV(H,GR1);

GR5:="MACD.MACD"(12,26,9)=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND CROSS(C,EMA34) AND CROSS

(C,EMA55){ AND CROSS(C,EMA120)};

DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.09,'三线推动'),COLORFFC8FF;

{STICKLINE(HR2 AND FILTER(HR2,10),H,L,0.5,1),COLORFFC8FF;

STICKLINE(HR2 AND FILTER(HR2,10),O,C,6,1),LINETHICK2,COLORFFC8FF;};

撰写方式:

EMA13:=EMA(C,13);

EMA34:=EMA(C,34);

EMA55:=EMA(C,55);

EMA120:=EMA(C,120);

AR1:=EMA55>EMA34 AND EMA34>EMA13;

AR2:=BARSLAST((C-EMA13)/EMA13*100<-6);

AR3:=EMA13>=REF(EMA13,2);

AR4:=COUNT(CROSS(C,EMA13),AR2)=1;

AR5:=AR1 AND AR2 AND AR3 AND AR4;

AR6:=AR5 AND FILTER(AR5,10);

CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;

CR2:=V>MA(V,5)*0.6;

CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;

CR4:=ABS(EMA34-EMA55)/EMA55<0.03;

CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);

CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);

DR1:=EMA13>EMA34 AND EMA34<EMA55;

DR2:=BARSLAST(CROSS(C,EMA55) );

DR3:=H=HHV(H,DR2);

DR4:=BARSLAST(DR3);

DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1;

DR6:=C>REF(C,1) ;

DR7:= DR1 AND DR5 AND DR6 ;

DR8:=DR7 AND FILTER(DR7 ,10);

AR6 OR CR6 OR DR8 ;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号