广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信公式低轨选股公式加一个限定条件

  • 牛股公式
  • 2020-09-08 09:15
  • 牛股网
广告管理-720PX*80PX

编写条件:请教师加一个低主线视角超过15度的条件。选股公式以下;

HIGHN:=10;

LOWN:=10;

AA:=REF(H,HIGHN)=HHV(H,2*HIGHN 1);

QY:=BACKSET(AA,HIGHN 1);

CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN 1);

DDD:=BARSLAST(CC);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

GDCS1:=CONST(DINGBUTS);

DINGBUTS1:=REF(DINGBUTS,DDD 1);

GDCS2:=CONST(DINGBUTS1);

高压:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1);

AA1:=REF(L,LOWN)=LLV(L,2*LOWN 1);

QY1:=BACKSET(AA1,LOWN 1);

CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN 1);

DD1:=BARSLAST(CC1);

DDTS:=IF(CC1,CURRBARSCOUNT,0);

DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);

DDCS1:=CONST(DDTS1);

DDTS2:=REF(DDTS1,DD1 1);

DDCS2:=CONST(DDTS2);

低支:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1);

C>低支 AND C<高压 ;

编写方式:HIGHN:=10;

LOWN:=10;

AA:=REF(H,HIGHN)=HHV(H,2*HIGHN 1);

QY:=BACKSET(AA,HIGHN 1);

CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN 1);

DDD:=BARSLAST(CC);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

GDCS1:=CONST(DINGBUTS);

DINGBUTS1:=REF(DINGBUTS,DDD 1);

GDCS2:=CONST(DINGBUTS1);

高压:=DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1);

AA1:=REF(L,LOWN)=LLV(L,2*LOWN 1);

QY1:=BACKSET(AA1,LOWN 1);

CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN 1);

DD1:=BARSLAST(CC1);

DDTS:=IF(CC1,CURRBARSCOUNT,0);

DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);

DDCS1:=CONST(DDTS1);

DDTS2:=REF(DDTS1,DD1 1);

DDCS2:=CONST(DDTS2);

低支:=DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1);

视角:=atan((低支/ref(低支,1)-1)*100)*57.3;

C>低支 AND C<高压 and 视角>=15;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号