广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

改成选股公式(买些股票庄家出現时)

  • 牛股公式
  • 2020-09-07 09:32
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式 :网民寻求帮助:

感谢老师及诸位高手!!!

请帮助编写通达信公式〈牛气冲天〉的选股公式

源代码〈牛气冲天〉;

MAV:=(C*2 H L)/4;

SK:=EMA(MAV,13) - EMA(MAV,34);

SD:=EMA(SK,5);

后轴:0;

空放主力 : (-2*(SK-SD))*30.8,COLORLIGREEN;

多方面主力 : (2*(SK-SD))*30.8,COLORMAGENTA;

持仓:IF(多方面主力>REF(多方面主力,1),多方面主力,DRAWNULL),COLORRED,LINETHICK2;

持币:IF(空放主力>REF(空放主力,1),空放主力,DRAWNULL),COLORGREEN,LINETHICK2;

AA05:=MA(C,5);

AA10:=MA(C,10);

BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;

AA30:=MA(C,30);

速率5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);

瞬时速度5:=EMA((速率5-REF(速率5,1)),3);

三拾日乖离率:=(C-AA30)/AA30*100;

买入:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1)

AND 瞬时速度5>REF(瞬时速度5,1) AND 速率5>REF(速率5,1) ,10) ;

DRAWTEXT(买入,0.1,'←买入'),COLORYELLOW;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,2,1);

D:=SMA(K,2,1);

J:=3*K-2*D;

J1:=REVERSE(J);

AA:=REF(MA(C,1),10)>REF(MA(C,60),10);

买些:=CROSS(J,J1) AND AA;

STICKLINE(买些,多方面主力,多方面主力 0.3,6,0),COLORMAGENTA;

STICKLINE(买些,多方面主力,多方面主力 5.5,5.5,5),COLORYELLOW;

STICKLINE(买些,多方面主力,多方面主力 80.8,2,0),COLORYELLOW;

DRAWTEXT(买些,75,'股票庄家'),COLORYELLOW;

VAR1:=C-REF(C,1);

VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);

MA5:=EMA(C,5);

MA13:=EMA(C,13);

UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5)) 1),LLV(L,BARSLAST(CROSS

(MA13,MA5)) 1),H=HHV(H,BARSLAST(CROSS(MA5,MA13)) 1),HHV(H,BARSLAST(CROSS

(MA5,MA13)) 1),0),COLOR0000FF;

DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13)) 1),HHV(H,BARSLAST(CROSS

(MA5,MA13)) 1),L=LLV(L,BARSLAST(CROSS(MA13,MA5)) 1),LLV(L,BARSLAST(CROSS

(MA13,MA5)) 1),0),COLOR00FF00;

BT:(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND

REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);

0,COLORFF00FF;

STICKLINE(UP,0,0.2,3,0),COLOR0000FF;

STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00;

STICKLINE(BT,0,78,2,0),COLOR000088;

STICKLINE(BT,0,78,1,0),COLOR0000CC;

STICKLINE(BT,0,78,0.22,0),COLOR0000FF;

DRAWTEXT(BT,75,'短牛'),COLOR0000FF;

TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;

STICKLINE(TJ1,0,55,3,0),COLOR880088;

STICKLINE(TJ1,0,55,1.5,0),COLORAA00AA;

STICKLINE(TJ1,0,55,0.8,0),COLORCC00CC;

STICKLINE(TJ1,0,55,0.2,0),COLORWHITE;

DRAWTEXT(TJ1,50,'中牛'),COLORWHITE;

HR:=HHV(HIGH,55);

HRY:=LLV(LOW,55);

HRY11:=HR*HRY;

HRY33:=SQRT(HRY11);

TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;

STICKLINE(TJ2,0,33,5,0),COLOR008888;

STICKLINE(TJ2,0,33,2,0),COLOR00AAAA;

STICKLINE(TJ2,0,33,1,0),COLOR00CCCC;

STICKLINE(TJ2,0,33,0.2,0),COLOR00FFFF;

DRAWTEXT(TJ2,20,'大神'),COLOR00FFFF;

ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);

STICKLINE(ST,14,15,5,0),COLOR008800;

STICKLINE(ST,14,15,2,0),COLOR00AA00;

STICKLINE(ST,14,15,1,0),COLOR00CC00;

STICKLINE(ST,14,15,0.2,0),COLOR00FF00;

DRAWTEXT(CURRBARSCOUNT=89,10.3,'★当大神\\中牛\\短牛同一天出現时,

坚决买进!!'),COLOR00FFFF;

Q2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100;

Q3:=SMA(Q2, 9, 1);

Q4:=SMA(Q3, 3, 1);

长发展趋势:3*Q3-2*Q4,COLORWHITE,LINETHICK3;

移动平均线:EMA(Q3, 3),COLORRED,LINETHICK3;

DRAWTEXT(CROSS(移动平均线, 长发展趋势) AND REF(长发展趋势,1)>80, REF(长发展趋势,3), '顶'),COLORRED,LINETHICK5;

逢低买: DRAWTEXT(REF(CROSS(移动平均线,长发展趋势),82) AND 移动平均线>1.3*长发展趋势,长发展趋势,'逢低买'),LINETHICK1;

买: DRAWTEXT(REF(CROSS(长发展趋势,移动平均线),1) AND 长发展趋势>1.3*移动平均线,移动平均线,'买'),COLORRED,LINETHICK1;

VAR3:=PEAKBARS(3,15,1)<10;

VAR5:=IF(VAR3=1,2,0);

顶:= IF(VAR5=2,2,0);

顶A:IF(顶>REF(顶,1),50,0),COLORGREEN;

DRAWTEXT(顶A=50,45,'快逃'),COLOR00FF00;

macd金叉: CROSS(长发展趋势,移动平均线);

DRAWTEXT(macd金叉,移动平均线,'★'),COLORRED;

V1:=EMA(CLOSE,60)-EMA(CLOSE,300);

V2:=EMA(V1,300);

V3:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;

V4:SMA(V3,2,1);

V5:SMA(V4,2,1);

V6:=CLOSE/REF(CLOSE,3)>=1.1;

V7:=BACKSET(V6,3);

买进:IF((V7 AND COUNT(V7,3)=1),30,0),COLORYELLOW,LINETHICK3;

DRAWTEXT(买进,35,'买进 '),COLORYELLOW,LINETHICK3;

改为选股公式(买点庄家出现时)

解释以下:

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,2,1);

D:=SMA(K,2,1);

J:=3*K-2*D;

J1:=REVERSE(J);

AA:=REF(MA(C,1),10)>REF(MA(C,60),10);

买些:CROSS(J,J1) AND AA;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号