广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把MACD柱状总面积形

  • 牛股公式
  • 2020-09-07 09:28
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式 :网民求助:

谢谢原作者阿强教师。

{MACD佛手}

DIF:EMA(CLOSE,6)-EMA(CLOSE,19),,NODRAW;

DEA:EMA(DIF,9),NODRAW;

MACD:2*(DIF-DEA),COLORSTICK;

STICKLINE(MACD>0,MACD,0,0.5,0),COLORRED;

STICKLINE(MACD<0,MACD,0,0.5,0),COLORGREEN;

STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.5,0),COLORWHITE;

STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.5,0),COLORFF00FF;

FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);

FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;

FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);

FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;

FH5:=FH1 AND FH2 AND MACD<0.10;

VV:=CLOSE>OPEN AND MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,30)

AND DIF>DEA AND MACD>REF(MACD,1) AND DIF>0 AND DEA>0 AND

MA(VOL,5)>MA(VOL,34) AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1);

佛手:IF(VV,1,0),NODRAW;

{二次启动}

X0:=BARSLAST((CROSS(MACD,REF(MACD,1)) AND MACD>0) OR CROSS(MACD,0));

X1:=BARSLAST(CROSS(0.5,COUNT(MACD>REF(MACD,1),X0 1)=X0 1));{回}

X2:=COUNT(MACD<REF(MACD,1),X1 1)=X1 1 AND COUNT(MACD<0,X1 1)<=2;

X3:=REF(X2,1) AND MACD>REF(MACD,1) AND C>O AND C>REF(C,1);

STICKLINE(X1=0 AND MACD>0,MACD,0,2,0),COLORDCDC00;{MACD缩头}

STICKLINE(X3,MACD,0,2,0),COLOR0854FF;{二次启动};

DRAWICON(佛手,-0.15,11);

二次走红:(FH3 OR FH4 OR FH5),COLORRED,NODRAW;

低买:CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,NODRAW;

给油:CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,NODRAW;

DRAWICON(二次走红,-0.05,1);

DRAWTEXT(二次走红,-0.15,'↖走红'),COLORRED;

DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,'↖低买'),COLORFF00FF;

DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,'↖给油'),COLORYELLOW;

XG:二次走红 OR 低买 OR 给油,NODRAW;

YLZC:=IF(CLOSE=INDEXC,(INDEXC INDEXH INDEXL INDEXO)/4,AMOUNT/(VOL 0.01)/100);

阻价:=IF(CLOSE=INDEXC,YLZC INDEXC-INDEXL,YLZC (CLOSE-LOW));

支价:=IF(CLOSE=INDEXC,INDEXL INDEXC-YLZC,LOW (CLOSE-YLZC));

今压:REF(阻价,1),LINETHICK0,COLORAA11BB,NODRAW;

今撑:REF(支价,1),LINETHICK0,COLOR009900,NODRAW;

明压:阻价,LINETHICK0,NODRAW;

明撑:支价,LINETHICK0,NODRAW;

DIFF:DIF,COLORRED,LINETHICK2;

DDEA:DEA,COLORYELLOW,LINETHICK2;

解释以下:

{MACD佛手}

DIF:EMA(CLOSE,6)-EMA(CLOSE,19),LINETHICK0;

DEA:EMA(DIF,9),LINETHICK0;

MACD:2*(DIF-DEA),COLORSTICK;

STICKLINE(MACD>0,MACD,0,0.5,0),COLORRED;

STICKLINE(MACD<0,MACD,0,0.5,0),COLORGREEN;

STICKLINE(MACD>0 AND MACD<REF(MACD,1),MACD,0,0.5,0),COLORWHITE;

STICKLINE(MACD<0 AND MACD>REF(MACD,1),MACD,0,0.5,0),COLORFF00FF;

FH1:=REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3)<REF(MACD,4);

FH2:=MACD>=0 AND COUNT(MACD>REF(MACD,1),1)=1;

FH3:=FH1 AND FH2 AND EMA(C,13)>REF(EMA(C,13),1);

FH4:=FH1 AND FH2 AND ABS((DIF-DEA)/C)<0.018;

FH5:=FH1 AND FH2 AND MACD<0.10;

VV:=CLOSE>OPEN AND MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,30)

AND DIF>DEA AND MACD>REF(MACD,1) AND DIF>0 AND DEA>0 AND

MA(VOL,5)>MA(VOL,34) AND MA(CLOSE,30)>=REF(MA(CLOSE,30),1);

佛手:IF(VV,1,0),LINETHICK0;

{二次启动}

X0:=BARSLAST((CROSS(MACD,REF(MACD,1)) AND MACD>0) OR CROSS(MACD,0));

X1:=BARSLAST(CROSS(0.5,COUNT(MACD>REF(MACD,1),X0 1)=X0 1));{回}

X2:=COUNT(MACD<REF(MACD,1),X1 1)=X1 1 AND COUNT(MACD<0,X1 1)<=2;

X3:=REF(X2,1) AND MACD>REF(MACD,1) AND C>O AND C>REF(C,1);

STICKLINE(X1=0 AND MACD>0,MACD,0,2,0),COLORDCDC00;{MACD缩头}

STICKLINE(X3,MACD,0,2,0),COLOR0854FF;{二次启动};

DRAWICON(佛手,-0.15,12);

二次走红:(FH3 OR FH4 OR FH5),COLORRED,LINETHICK0;

低买:CROSS(DIF,DEA) AND DIF<0,COLORFF00FF,LINETHICK0;

给油:CROSS(DIF,DEA) AND DIF>0,COLORYELLOW,LINETHICK0;

DRAWICON(二次走红,-0.05,4);

DRAWTEXT(二次走红,-0.15,'↖走红'),COLORRED;

DRAWTEXT(CROSS(DIF,DEA) AND DIF<0,DEA-0.02,'↖低买'),COLORFF00FF;

DRAWTEXT(CROSS(DIF,DEA) AND DIF>0,DEA-0.05,'↖给油'),COLORYELLOW;

XG:二次走红 OR 低买 OR 给油,LINETHICK0;

YLZC:=IF(CLOSE=INDEXC,(INDEXC INDEXH INDEXL INDEXO)/4,AMOUNT/(VOL 0.01)/100);

阻价:=IF(CLOSE=INDEXC,YLZC INDEXC-INDEXL,YLZC (CLOSE-LOW));

支价:=IF(CLOSE=INDEXC,INDEXL INDEXC-YLZC,LOW (CLOSE-YLZC));

今压:REF(阻价,1),LINETHICK0,COLORAA11BB,LINETHICK0;

今撑:REF(支价,1),LINETHICK0,COLOR009900,LINETHICK0;

明压:阻价,LINETHICK0;

明撑:支价,LINETHICK0;

DIFF:DIF,COLORRED,LINETHICK2;

DDEA:DEA,COLORYELLOW,LINETHICK2;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号