广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

<杀跌>指标值中有未来函数吗?

  • 牛股公式
  • 2020-09-07 09:19
  • 牛股网
广告管理-720PX*80PX

撰写标准:请大神看一下指标值中有未来函数吗?

指标源码以下:

VARTIME:=IF(YEAR>=9999 AND MONTH>=11 AND DAY>=07,0,1);

VARDTIME:=IF(YEAR=9999 AND MONTH=11 AND DAY=06,1,0);

QW1:=(HIGH LOW CLOSE*2)/4*VARTIME;

QW3:=EMA(QW1,10)*VARTIME;

QW4:=STD(QW1,10)*VARTIME;

QW5:=(QW1-QW3)*100/QW4*VARTIME;

QW6:=EMA(QW5,5)*VARTIME;

RK7:=EMA(QW6,10)*VARTIME;

涨:EMA(QW6,10) 100/2-5,LINETHICK1,COLORRED;

跌:EMA(涨,4),LINETHICK1,COLORFFFF34;

多段:IF(CROSS(涨,跌) AND 跌<-10,30,0),LINETHICK1,COLORFF00FF;

空线:IF(CROSS(跌,80),70,100),COLOR0099FF,LINETHICK1;

买1:EMA(跌,4)*VARTIME,COLORWHITE;

买2:EMA(买1,4)*VARTIME,COLORGREEN;

买M3:=EMA(买2,4)*VARTIME,COLORYELLOW;

买M4:=EMA(买M3,4)*VARTIME,COLORCC9900;

-10,POINTDOT,COLOR888888,LINETHICK2;

80,POINTDOT,COLOR888888,LINETHICK2;

STICKLINE(涨

STICKLINE(涨 REF(涨,1),涨,EMA(涨,3),3,0) ,COLOR0099FF;

STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),2,0) ,COLOR00AAFF;

STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),1,0) ,COLOR00BBFF;

DRAWICON(多段,30,1),COLORFF00FF;

DRAWICON(CROSS(跌,80),70,2),COLORGREEN;

DRAWTEXT(CROSS(涨,跌) AND 跌-10,40,'买进'),COLORCCFF99;

DRAWTEXT(多段>0,-20,'上涨'),COLOR0000FF;

VAR822:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL)*VARTIME;

VAR883:=(CLOSE-VAR822)/VAR822*100*VARTIME;

VAR1:=MA(CLOSE,152);

VAR2:=MA(CLOSE,194);

VAR3:=VAR2 2*STD(CLOSE,170);

VAR4:=VAR1 2*STD(CLOSE,170);

顶:(CLOSE>VAR3)*13*10,COLORBLUE,LINETHICK2;

VAR6:=EMA(HHV(HIGH,500),21);

VAR7:=EMA(HHV(HIGH,250),21);

VAR8:=EMA(HHV(HIGH,90),21);

VAR9:=EMA(LLV(LOW,500),21);

VARA:=EMA(LLV(LOW,250),21);

VARB:=EMA(LLV(LOW,90),21);

VARC:=EMA((VAR9*0.96 VARA*0.96 VARB*0.96 VAR6*0.558 VAR7*0.558 VAR8*0.558)/6,21);

VARD:=EMA((VAR9*1.25 VARA*1.23 VARB*1.2 VAR6*0.55 VAR7*0.55 VAR8*0.65)/6,21);

VARE:=EMA((VAR9*1.3 VARA*1.3 VARB*1.3 VAR6*0.68 VAR7*0.68 VAR8*0.68)/6,21);

VARF:=EMA((VARC*3 VARD*2 VARE)/6*1.738,21);

VAR10:=REF(LOW,1);

VAR11:=SMA(ABS(LOW-VAR10),3,1)/SMA(MAX(LOW-VAR10,0),3,1)*100;

VAR12:=EMA(IF(CLOSE*1.35<=VARF,VAR11*10,VAR11/10),3);

VAR13:=LLV(LOW,30);

VAR14:=HHV(VAR12,30);

VAR15:=IF(MA(CLOSE,58),1,0);

VAR16:=EMA(IF(LOW50,50,VAR16)/3.82*6;

VAR18:=HHV(HIGH,30);

VAR19:=LLV(LOW,30);

NL:=EMA((CLOSE-VAR19)/(VAR18-VAR19)*100,5)/8*10,COLORYELLOW,LINETHICK2;

VAR1A:=(EMA(AMOUNT,5)/EMA(VOL,5)/100-EMA(AMOUNT,125)/EMA(VOL,125)/100)/(EMA(AMOUNT,5)/EMA(VOL,5)/100)=1 AND (VAR1E<-99.9 OR VAR1D<15 AND VAR1CREF(CLOSE,1),1,0),0);

VAR26:=SUMBARS(VOL,CAPITAL);

VAR27:=IF(CLOSE>LLV(CLOSE,VAR26),1,-1)*IF(VAR25>LLV(VAR25,VAR26),1,-1);

VAR28:=COUNT(IF(VAR27=-1,1,0)=1,8)>2;

VAR29:=(CLOSE-DMA((3*HIGH LOW OPEN 2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100)))/DMA((3*HIGH LOW OPEN 2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100))*100<-18;

VAR2A:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE=0.02 AND VOL/CAPITAL<=0.2 AND OPEN=1.105;

VAR3D:=VAR2C AND COUNT(VAR2C,5)=1;

VAR2E:=VAR2B OR VAR2C;

VAR2F:=REF(CLOSE,1);

VAR30:=SMA(MAX(CLOSE-VAR2F,0),7,1)/SMA(ABS(CLOSE-VAR2F),7,1)*100;

VAR31:=SMA(MAX(CLOSE-VAR2F,0),13,1)/SMA(ABS(CLOSE-VAR2F),13,1)*100;

VAR32:=VAR30<20 AND VAR31REF(CLOSE,1),VOL,IF(CLOSELLV(CLOSE,VAR26),1,-1);

VAR36:=IF(VAR34>LLV(VAR34,VAR26),1,-1);

VAR37:=VAR35*VAR36;

VAR38:=IF(VAR37=-1,1,0);

VAR3B:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;

VAR3C:=SMA(VAR3B,3,1);

VAR三d:=SMA(VAR3C,3,1);

VAR3E:=SMA(VAR三d,3,1);

VAR3F:=CROSS(VAR三d,VAR3E) AND VAR三d80;

VAR41:=5;

DRAWTEXT(CROSS(VAR41,NL),30,'★做底'),COLORWHITE;

VAR44:=REF(CLOSE,1);

VAR45:=SMA(MAX(CLOSE-VAR44,0),6,1)/SMA(ABS(CLOSE-VAR44),6,1)*100;

STICKLINE(CROSS(84,VAR45),0,VAR2*15 3,3,1),COLORGREEN;

DRAWTEXT(CROSS(84,VAR45),80,'防空警报试鸣'),COLORGREEN ,;

VAR47:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);

VAR48:=(CLOSE-LLV(CLOSE,126))/(HHV(CLOSE,126)-LLV(CLOSE,126))*100;

VAR49:=EMA(CLOSE,2)-EMA(CLOSE,150);

VAR4a:=EMA(VAR49,100);

VAR4B:=2*(VAR49-VAR4a);

VAR5C:=POW(VAR4B,3)*0.1 POW(VAR4B,1);

VAR4D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));

VAR4E:=EMA(VAR4D*0.97,3);

VAR4F:=(HIGH LOW CLOSE)/3;

VAR50:=(VAR4F-MA(VAR4F,14))/(0.015*AVEDEV(VAR4F,14));

VAR51:=IF(VAR4B>0.1,VAR5C,0)*5;

VAR52:=LLV(HIGH,240);

VAR53:=100*(CLOSE-VAR52)/VAR52;

VAR54:=AMOUNT/VOL;

VAR55:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);

VAR56:=INDEXC;

VAR57:=MA(VAR56,5);

VAR58:=MA(VAR56,20);

VAR59:=MA(VAR56,30);

VAR5A:=VAR59>VAR57*1.08 AND VAR58>VAR57*1.055;

VAR5B:=VAR57>VAR56*1.03 AND VAR58>VAR56*1.13;

VAR4C:=VAR5B;

VAR5D:=IF (FILTER(VAR55<6,5)=1,1,0);

VAR5E:=(VAR5D AND VAR53<-2.5 AND VAR47<5 AND VAR48=0)*60;

VAR5F:=VAR55=-15.8 AND VAR64<=-12.2 AND VAR65<=-20.8 AND VAR66<=-27.5 AND VAR68<=11.7 AND VAR6A<=-145)*100;

VAR6C:=VAR48=0;

VAR6D:=VAR48=100;

VAR6E:=LLV(HIGH,240);

VAR6F:=100*(CLOSE-VAR6E)/VAR6E;

VAR70:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;

VAR71:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;

VAR72:=0;

VAR73:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;

VAR74:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;

VAR75:=BARSCOUNT(CLOSE);

VAR76:=VAR73<20 AND VAR7435;

VAR77:=VAR76 AND COUNT(VAR76,1)=1;

VAR78:=EMA(CLOSE,21)-EMA(CLOSE,8);

VAR79:=EMA(VAR78,5);

VAR7A:=TROUGHBARS(3,6,1)LOW+0.04,4,0);

VAR7C:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*1000 AND VAR88<0,200,0);

VAR8A:=IF(VAR860.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);

VAR8B:=IF(VAR88<0 AND VAR8A=-50,100,0);

VAR8C:=MA(CLOSE,3);

VAR8D:=REF(CLOSE,2)*0.865;

VAR8E:=REF(CLOSE,13)*0.772;

VAR8F:=MIN(VAR8D,VAR8E);

VAR90:=100*VOL/CAPITAL;

VAR91:=MA(CLOSE,13);

VAR92:=IF((CLOSE-VAR8F)/CLOSE<0.03 AND SUM(VAR90,5)/50 AND (VAR8A0),100,0);

VAR94:=VAR93;

VAR95:=IF(VAR89>0 AND VAR8B>0 AND SUM(VOL/CAPITAL*100,5)/50 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (VAR89>0 AND VAR8B>0 AND SUM(VOL/CAPITAL*100,5)/50) AND (VAR8A0) AND VAR930 AND VAR8B>0 AND SUM(VOL/CAPITAL*100,5)/50) AND (VAR8A0);

VAR97:=VAR89>0 AND VAR8B>0 AND SUM(VOL/CAPITAL*100,5)/50 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;

VAR98:=VAR96 OR VAR97;

VAR99:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);

VAR9A:=HIGH-REF(HIGH,1);

VAR9B:=REF(LOW,1)-LOW;

VAR9C:=SMA(IF(VAR9A>0 AND VAR9A>VAR9B,VAR9A,0),12,1);

VAR9D:=SMA(IF(VAR9B>0 AND VAR9B>VAR9A,VAR9B,0),12,1);

VAR9E:=VAR9C*100/VAR99;

VAR9F:=VAR9D*100/VAR99;

VARA0:=SMA(ABS(VAR9F-VAR9E)/(VAR9F+VAR9E)*100,12,1);

VARA1:=(VARA0+REF(VARA0,5))/2;

VARA2:=SUM(HIGH-OPEN,12)/SUM(OPEN-LOW,12)*100;

VARA3:=SUM(MAX(0,HIGH-REF(CLOSE,1)),12)/SUM(MAX(0,REF(CLOSE,1)-LOW),12)*100;

VARA4:=AMOUNT/VOL/100;

VARA5:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;

VARA6:=SUM(AMOUNT,5)/VARA4/100;

VARA7:=SUM(AMOUNT,13)/VARA4/100;

VARA8:=SUM(AMOUNT,34)/VARA4/100;

VARA9:=SUM(AMOUNT,209)/VARA4/100;

VARAA:=REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4);

VARAB:=VARAA/CAPITAL;

VARAC:=VOL/CAPITAL*VARA5+VARAB*REF(VARA4,1);

VARAD:=DMA(VARA5,VOL/VARA6);

VARAE:=DMA(VARA5,VOL/VARA7);

VARAF:=DMA(VARA5,VOL/VARA8);

VARB0:=DMA(VARA5,VOL/CAPITAL);

VARB1:=MA(HHV(HIGH,488),18);

VARB2:=MA(HHV(HIGH,220),18);

VARB3:=MA(HHV(HIGH,98),18);

VARB4:=MA(LLV(LOW,488),18);

VARB5:=MA(LLV(LOW,220),18);

VARB6:=MA(LLV(LOW,98),18);

VARB7:=MA((VARB4*0.96+VARB5*0.96+VARB6*0.96+VARB1*0.558+VARB2*0.558+VARB3*0.558)/6,18);

VARB8:=MA((VARB4*1.25+VARB5*1.23+VARB6*1.2+VARB1*0.55+VARB2*0.55+VARB3*0.65)/6,18);

VARB9:=MA((VARB4*1.3+VARB5*1.3+VARB6*1.3+VARB1*0.68+VARB2*0.68+VARB3*0.68)/6,18);

VARBA:=MA((VARB7*3+VARB8*2+VARB9)/6*1.738,18);

VARBB:=IF(DATE<=1021231,VARBA,VARBA*DAY);

VARBC:=LOW;

VARBD:=REF(LOW,1);

VARBE:=SMA(ABS(VARBC-VARBD),3,1)/SMA(MAX(VARBC-VARBD,0),3,1)*100;

VARBF:=MA(IF(CLOSE*1.35<=VARBB,VARBE*10,VARBE/10),3);

VARC0:=LLV(LOW,30);

VARC1:=HHV(VARBF,30);

VARC2:=IF(LOW<=VARC0,(VARBF+VARC1*2)/2,0);

WXBM:(MA(VARC2 AND CLOSE

DRAWTEXT(VAR61 OR VAR98,70,'★大黑马'),COLORYELLOW;

DRAWTEXT(VAR7B>0,60,'★探底'),COLORWHITE;

DRAWTEXT(WXBM,100,'BM'),COLORRED , ;

STICKLINE(VAR61,0,120,3,0),COLORWHITE;

STICKLINE(VAR98,0,90,3,0),COLORYELLOW , ;

X:=C-REF(MA(C,20),11);

LGL:=IF(EMA(C,5)/EMA(EMA(C,9),16)0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,50,0);

编写方法:探底信号“TROUGHBARS(3,16,1)=0 ”就是未来函数

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号