广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

将庄影逃不过指标值中出現鲜红色“买”一部分撰写为选股公式

  • 牛股公式
  • 2020-09-07 09:18
  • 牛股网
广告管理-720PX*80PX

撰写标准:请教师帮助,将图上所显示信息的庄影逃不过指标值中,提醒买进红箭头符号另外显示信息鲜红色“买”字,撰写为选股公式。感谢!

庄影逃不过指标源码以下:

{時间大额设定}

TJ:=FILTER(C,239)>0,NODRAW;

TJJ:=SUM(TJ,0),NODRAW;

TJA:=CONST(TJJ),NODRAW;

C1:=CLOSE;

V1:=TIME;

A1:=COUNT(BARSCOUNT(C)=1 AND TIME<102000 ,0 );

T:=IF(V1150000000,0.3,IF(CAPITAL>20000000,0.5,IF(CAPITAL>10000000,0.8,IF

(CAPITAL<200000,5,IF(CAPITAL<1000000,3,

IF(CAPITAL=DYNAINFO(3),VV2,0);

初负1:=IF(T=1 AND DYNAINFO(4)=大额线 AND T=1,初正1,0),T),NODRAW;

初负:=SUM(IF(初负1>=大额线 AND T=1,初负1,0),T),NODRAW;

初正2:=SUM(初正1,T),NODRAW;

初负2:=SUM(初负1,T),NODRAW;

T00:=IF(C1>REF(C1,1),0.9,-0.9);

T01:=IF(C1

T02:=T00 T01,NODRAW;

TT1:=BARSLAST(CROSS(T02, 1.5)),NODRAW;

TT2:=BARSLAST(CROSS(-1.5,T02)),NODRAW;

TT:=IF(T02=1.8,1,IF(T02=-1.8,-1,0));

正V1:=IF(TT=1 OR (TT=0 AND TT1TT2),成交量,0),NODRAW;

正负极0:=IF(成交量!= 0 AND (正V1=0 AND 负V1=0),成交量,0);

正V0:=IF(正负极0!= 0 AND REF(正V1,1)!= 0 ,正负极0,0);

负V0:=IF(正负极0!= 0 AND REF(负V1,1)!= 0 ,正负极0,0);

正V11:=正V1 正V0,NODRAW;

负V11:=负V1 负V0,NODRAW;

正V:=IF(正V11>=大额线,正V11,0);

负V:=IF(负V11>=大额线,负V11,0);

正V2:=IF(正V11<大额线,正V11,0);

负V2:=IF(负V11<大额线,负V11,0);

正总:=IF(TJJ<2,初正,0) SUM(正V,T),NODRAW,COLOR0000FF;

负总:=IF(TJJ<2,初负,0) SUM(负V,T),NODRAW,COLOR00FF00;

正总1:=IF(TJJ<2,初正2,0) SUM(正V11,T),NODRAW,COLOR0000FF;

负总1:=IF(TJJ0 AND TJA>1,REF((正总-负总),T),0),NODRAW;

TJJJB:=SUM(TJJB,0) IF(TJA>1,(正总-负总),0),NODRAW;

TJJC:=IF(FILTER(T,239)>0 AND TJA>1,REF((正总 负总),T),0),NODRAW;

TJJJC:=SUM(TJJC,0) IF(TJA>1,(正总 负总),0),NODRAW;

N今:TJJJB/10000,NODRAW;

TJJJB/TJJJC*100,NODRAW;

TJJB2:=IF(FILTER(T,239)>0,REF((正总-负总),T),0),NODRAW;

TJJJB2:=SUM(TJJB2,0),NODRAW;

TJJC2:=IF(FILTER(T,239)>0,REF((正总 负总),T),0),NODRAW;

TJJJC2:=SUM(TJJC2,0),NODRAW;

N昨:TJJJB2/10000,NODRAW;

TJJJB2/TJJJC2*100;

KL:=1;

DRAWBAND(12000*KL,RGB(50,50,50),-5000*KL,DRAWNULL);

Q4:=IF(大差%>=0,12000*KL,0),NODRAW;

Q5:=IF(大差%>=0,-5000*KL,0),NODRAW;

DRAWBAND(Q4,RGB(100,100,100),Q5,RGB(50,50,50));

STICKLINE(CROSS(大差%,0),Q4,Q5,10,0),COLOR777777;

STICKLINE(CROSS(0,大差%),Q4,Q5,10,0),COLOR777777;

DIF:=EMA(CLOSE,20)-EMA(CLOSE,5);

DEA:=EMA(DIF,10);

MACD:=300*(DIF-DEA)*2/EMA(C,30);

VARA:=EMA(REF(CLOSE,1),4);

青山:=(SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100);

清山:=青山<3.5,COLORDBDBDB;

红火的:=FILTER(MACDREF(MACD,1) AND 青山<20,5);

太阳光:=CROSS(青山,90),COLOR00FF00;

DRAWBAND(IF((TJA=0,MACD,DRAWNULL)*1.5;

STICKLINE(DD AND DD>REF(DD,1),0,DD*80*KL,4,0),COLOR0000FF;

STICKLINE(DD AND DD

IF(TJA<2,(青山-25)*150*KL,DRAWNULL),COLOR5BE000,LINETHICK6;

DRAWBAND(IF((TJA0,(青山-25)*150*KL,0),RGB

(00,200,50),0,DRAWNULL);

DRAWBAND(0,RGB(00,180,120),IF((TJAO,ZJ2*(H-L),IF(CO,0-ZJ2*(H-C (O-L)),IF(C0 AND 日总流量>=0,日总流量,0,2,0),COLORFF38FF;

STICKLINE(C>0 AND 日总流量<=0,日总流量,0,2,0),COLORFA3300;

AR1:=LLV(LOW,10);

AR2:=HHV(H,25);

AR3:=EMA((C-AR1)/(AR2-AR1)*4,4);

红彤彤天:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)

-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)

-LLV(LOW,27))*100,5,1),3,1),LINETHICK0;

IF((TJA10,-5000*KL,DRAWNULL),CIRCLEDOT,COLORGREEN;

IF(红彤彤天<=10,-5000*KL,DRAWNULL),CIRCLEDOT,COLOR0000CC;

N:=IF(TJA<2 AND PERIOD=0,20,6);

L1:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*200-60;

有意就会有:IF((TJA<2 OR PERIOD!= 0) AND CROSS(红彤彤

天,2),7000*KL,DRAWNULL),CROSSDOT,LINETHICK6,COLORFF77FF;

好运气!:IF((TJA75 OR 太阳光,9800*KL,'ヲ'),COLORDBDBDB;

DRAWTEXT(清山,-3000*KL,'ャ'),COLORDBDBDB;

DRAWTEXT(清山,-3000*KL,'︼'),COLOR688EC1;

IF(PERIOD=0,2500,DRAWNULL),COLORAAAAAA,LINETHICK2;

{蟠龙驸凤}

望喜:IF(PERIOD=0,小差%*100 2500,DRAWNULL),COLOR000000,LINETHICK1;

IF(PERIOD=0 AND TJA>1,小差%*100 2500,DRAWNULL),COLORFFFF00;

蟠龙:IF(PERIOD=0,大差%*100 2500,DRAWNULL),COLOR00FFFF,LINETHICK2;

STICKLINE(PERIOD=0 AND FILTER(T,239)>0,12000*KL,-5000*KL,1,0),COLORWHITE;

A7:=C-REF(C,1);

A8:=IF(((TJA<2 OR PERIOD!= 0) OR PERIOD!= 0),5000*EMA(EMA(A7,11),11)/EMA(EMA(ABS

(A7),11),11),DRAWNULL),LINETHICK2;

SHORT:=3; LONG:=19;

RMA:=EMA(CLOSE,SHORT);

NMA:=EMA(CLOSE,LONG);

UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA,RMA)) 1),LLV(L,BARSLAST(CROSS(NMA,RMA)) 1),H=HHV

(H,BARSLAST(CROSS(RMA,NMA)) 1),HHV(H,BARSLAST(CROSS(RMA,NMA)) 1),0);

DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA,NMA)) 1),HHV(H,BARSLAST(CROSS(RMA,NMA)) 1),L=LLV

(L,BARSLAST(CROSS(NMA,RMA)) 1),LLV(L,BARSLAST(CROSS(NMA,RMA)) 1),0);

买入:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND REF(DOWN,1)REF(DOWN,1);

售出:=(HHV(A8,2)=HHV(A8,7) OR A8=HHV(A8,2)) AND DOWN>REF(UP,1);

DRAW ICON(买进=0,A8*1.1,1);

DRAWICON(买进=1,A8,23);

RV:=((CLOSE-LLV(LOW,5))/(HHV(HIGH,27)-LLV(LOW,27))*200-60)*100*KL;

VAR4:=SMA(RV,3,1);

VAR5:=SMA(VAR4,3,1);

龙K:IF(((TJA<2 OR PERIOD!= 0) OR PERIOD!= 0),SMA(L1,3,1)*100*KL,DRAWNULL),COLORRED;

凤D:IF(((TJA=HHV(X,N1),X,X<=LLV(X,N1),X,1);

TJ1:=X=牛相;

TJ2:=X50 AND X<=80 AND CROSS(X,VAR7R),X,'追'),COLORYELLOW;

DRAWTEXT(CROSS(X,70) AND VAR7R<15,X,'底'),COLORRED;

DRAWTEXT(CROSS(X,85) AND VAR7R<10,X,'涨'),COLORMAGENTA;

DRAWTEXT(VAR7RREF(VAR7R,1),VAR7R,'涨'),COLORRED;

DRAWTEXT(CROSS(X,70) AND VAR7R<20,X,'底'),COLORRED;

DRAWTEXT(ISLASTBAR,X,' 金牛判势'),COLORRED;

编写方法:N1:=7;

LC:=REF(CLOSE,1);

X:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*1000,COLORMAGENTA;

牛相:=DRAWLINE(X>=HHV(X,N1),X,X<=LLV(X,N1),X,1);

TJ1:=X=牛相;

TJ2:=X<REF(X,1);

xg:TJ1 AND TJ2;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号