广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把通达信公式顶与底公式计算划线全自动增加

  • 牛股公式
  • 2020-09-05 17:44
  • 牛股网
广告管理-720PX*80PX

撰写标准:TS:=14;

{顶点H}

A1:=REF(H,TS)=HHV(H,2*TS 1); B1:=FILTER(A1,TS);

C1:=BACKSET(B1,TS 1); HD:=FILTER(C1,TS);

波峰: REF(H,BARSLAST(HD)),POINTDOT,COLOR990099;

{顶点L}

AL1:=REF(L,TS)=LLV(L,2*TS 1); BL1:=FILTER(AL1,TS);

CL1:=BACKSET(BL1,TS 1); LD:=FILTER(CL1,TS);

波谷: REF(L,BARSLAST(LD)),POINTDOT,COLOR009900;

T1:=BARSLAST(HD)BARSLAST(LD) AND NOT(LD);

STICKLINE(T1,波峰,波峰,200,0),COLOR990099;

STICKLINE(T2,波谷,波谷,200,0),COLOR009900;

期待教师能将公式计算画出去的水平线全自动增加,这一公式计算里线过短了 看不见早期的顶与底,自己调节了一下,将STICKLINE(T1,波峰,波峰,200,0),COLOR990099;

STICKLINE(T2,波谷,波谷,200,0),COLOR009900; 里的数据改为200,尽管长了,可是希望划线从k线一直向右画,左侧画的那一部分想要了,不便教师了

撰写方式:{把STICKLINE换为DRAWLINE试一试。}

TS:=14;

{顶点H}

A1:=REF(H,TS)=HHV(H,2*TS 1); B1:=FILTER(A1,TS);

C1:=BACKSET(B1,TS 1); HD:=FILTER(C1,TS);

波峰: REF(H,BARSLAST(HD)),POINTDOT,COLOR990099;

{顶点L}

AL1:=REF(L,TS)=LLV(L,2*TS 1); BL1:=FILTER(AL1,TS);

CL1:=BACKSET(BL1,TS 1); LD:=FILTER(CL1,TS);

波谷: REF(L,BARSLAST(LD)),POINTDOT,COLOR009900;

T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD);

T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);

DRAWLINE(HD,H,REF(HD,1),REF(H,1),1),COLOR00FFFF;

DRAWLINE(LD,L,REF(LD,1),REF(L,1),1),COLORFFFF00;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号