广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

将项下公式计算更改成通达信软件

  • 牛股公式
  • 2020-09-05 17:43
  • 牛股网
广告管理-720PX*80PX

撰写标准:指标公式设定下列标准:(需更改成通达信公式的选股公式)

{1.股票价格上穿10均线

2.股票价格在30日或是120均线以上

3.30日上涨幅度低于10%

4.流通股本>五千万股,0,股票换手率>3%

6.除去ST种类型的股票}

下列为选股公式源代码(不清楚是哪个版本的!),望各界大神改动为通达信公式版本的!

ma10:=ma(close,10);

ZF:=(close-ref(close,1))/ref(close,1)*100;

HSL:=vol/capital*100;

TA:=cross(close,ma10);

TB:=(close>ma(close,30) or close>ma(close,120));

TC:=sum(ZF,30)0.5 and capital/10000000 and HSL>3;

TF:=STRCMP(STRLEFT(STKNAME,4),'G*ST')0 and STRCMP(STRLEFT(STKNAME,3),'GST')0 and STRCMP(STRLEFT(STKNAME,3),'*ST')0 and STRCMP(STRLEFT(STKNAME,2),'ST')0;

下列是安裝到通达信软件里提醒未根据难题:

不正确句 :

TF:=STRCMP(STRLEFT(STKNAME,4),1)0 AND STRCMP(STRLEFT(STKNAME,3),2)0 AND STRCMP(STRLEFT(STKNAME,3),3)0 AND STRCMP(STRLEFT(STKNAME,2),4)0

详细资料 : 您在括弧前写的并不是涵数、公式计算等,

且缺乏必需的运算符!

不正确起止部位 : 234 ; 长短: 7

撰写方式:MA10:=MA(CLOSE,10);

ZF:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

HSL:=VOL/CAPITAL*100;

TA:=CROSS(CLOSE,MA10);

TB:=(CLOSE>MA(CLOSE,30) OR CLOSE>MA(CLOSE,120));

TC:=SUM(ZF,30)<10;

TD:=CAPITAL/1000000>0.5 AND CAPITAL/1000000<3;

TE:=FINANCE(33)>0 AND HSL>3;

TF:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号