广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

(短线高手)为通达信公式能用指标值

  • 牛股公式
  • 2020-09-05 17:42
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式:网民求助:

求助高手将这一飞狐《短线高手》公式计算改成通信达可用的。谢谢了。

这一公式计算放到通信达里。图型缩小了。。看不清。。

RSVK:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSVK,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

MA3:=MA(C,3);

买进1:=CROSS(C,MA3) AND MA3>=REF(MA3,1)*0.99 ;{日收盘价格上穿MA3 }

买进2:=C>MA3 AND (C-MA3)/MA3<0.035 AND MA3>REF(MA3,1)*0.998 ;{收盘价格在MA3上边很近 }

买进3:=C>MA3 AND REF(MA3,1)<REF(MA3,2) AND REF(MA3,2)<REF(MA3,3);{MA3不久往上 }

买进4:= C>MA3 AND J<80 AND CROSS(J,D) ;{KDJ的J值在底位,或是J线早已向上涨,或是J与D将要或不久产生macd金叉}

不买进1:= J>80 OR COUNT( CROSS(D,J),2)>0;{KDJ的J值处在上位,或是J线上位并往下行,或是J与D将要或早已产生均线多头排列}

不买进2:=(C-MA3)/MA3>=0.035;{ 收盘价格高过MA3很远}

不买进3:=O>C*1.02 ;{长大阴线不买}

不买进4:="CCI.CCI">100;{日CCI往上过100}

不买进5:=REF(C,1)>REF(MA3,1) AND REF(C,2)>REF(MA3,2);{股票价格二天占在MA3以上}

不买进6:=COUNT(MA3>REF(MA3,1)*1.0015,4)>=3;{MA3往上数日}

分辨买进:= NOT(不买进1 OR 不买进2 OR 不买进3 OR 不买进4 OR 不买进5 OR 不买进6) AND (买进1 OR 买进2 OR 买进3 OR 买进4);

买进标准:=FILTER(分辨买进,1);

买进: (COUNT( REF(买进标准,1),3)=0 OR CROSS(J,D)) AND COUNT( REF(买进标准,1),1)=0 AND 买进标准,COLORRED;

买进日数:=BARSLAST(买进);

买价:REF(C,买进日数),LINETHICK0;

服务费:=0.003;

赢亏:100*((C-买价)/买价-服务费),LINETHICK0,COLORE66878;

百分之二十5止赢:买价*(1 0.05 服务费),LINETHICK0,COLOR000999;

百分之二十2股票止损:买价*(1-0.025 服务费),COLORGREEN,LINETHICK0;

止赢标准:=H>百分之二十5止赢;

止赢日数:=BARSLAST(止赢标准);

股票止损标准:=C<百分之二十2股票止损;

股票止损日数:=BARSLAST(股票止损标准);

止赢:=买进日数> 止赢日数 AND 止赢日数<股票止损日数;

止赢日数2:=BARSLAST(止赢标准 AND 止赢 AND COUNT(REF(止赢,1),1)=0);

股票止损:=买进日数>股票止损日数 AND 止赢日数>股票止损日数;

股票止损日数2:=BARSLAST(股票止损 AND COUNT(REF(股票止损,1),1)=0);

DRAWTEXT(止赢 AND COUNT(REF(止赢,1),1)=0 AND 买进日数<股票止损日数2,0.8,'止赢');

DRAWICON(止赢 AND COUNT(REF(止赢,1),1)=0 AND 买进日数<股票止损日数2,0.5,1);

DRAWTEXT(股票止损 AND COUNT(REF(股票止损,1),1)=0 AND 买进日数<止赢日数2,-0.4,'股票止损');

DRAWICON(股票止损 AND COUNT(REF(股票止损,1),1)=0 AND 买进日数<止赢日数2,-0.6,2);

-1;

逃跑价:hhv(h,买进日数)*0.905,linethick0;

逃跑标准:=c<逃跑价;

逃跑日数:=barslast(逃跑标准);

逃跑:=买进日数>逃跑日数;

逃跑日数2:=barslast(逃跑 and count(ref(逃跑,1),1)=0);

drawtext(逃跑标准 and 逃跑日数2=0,-0.3,'逃跑');图型缩小了。。看不出。。(

解释以下:

RSVK:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSVK,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

MA3:=MA(C,3);

买进1:=CROSS(C,MA3) AND MA3>=REF(MA3,1)*0.99 ;{日收盘价格上穿MA3 }

买进2:=C>MA3 AND (C-MA3)/MA3<0.035 AND MA3>REF(MA3,1)*0.998 ;{收盘价格在MA3上边很近 }

买进3:=C>MA3 AND REF(MA3,1)<REF(MA3,2) AND REF(MA3,2)<REF(MA3,3);{MA3不久往上 }

买进4:= C>MA3 AND J<80 AND CROSS(J,D) ;{KDJ的J值在底位,或是J线早已向上涨,或是J与D将要或不久产生macd金叉}

不买进1:= J>80 OR COUNT( CROSS(D,J),2)>0;{KDJ的J值处在上位,或是J线上位并往下行,或是J与D将要或早已产生均线多头排列}

不买进2:=(C-MA3)/MA3>=0.035;{ 收盘价格高过MA3很远}

不买进3:=O>C*1.02 ;{长大阴线不买}

不买进4:="CCI.CCI">100;{日CCI往上过100}

不买进5:=REF(C,1)>REF(MA3,1) AND REF(C,2)>REF(MA3,2);{股票价格二天占在MA3以上}

不买进6:=COUNT(MA3>REF(MA3,1)*1.0015,4)>=3;{MA3往上数日}

分辨买进:= NOT(不买进1 OR 不买进2 OR 不买进3 OR 不买进4 OR 不买进5 OR 不买进6) AND (买进1 OR 买进2 OR 买进3 OR 买进4);

买进标准:=FILTER(分辨买进,1);

买进: (COUNT( REF(买进标准,1),3)=0 OR CROSS(J,D)) AND COUNT( REF(买进标准,1),1)=0 AND 买进标准,COLORRED;

买进日数:=BARSLAST(买进);

买价:REF(C,买进日数),NODRAW;

服务费:=0.003;

赢亏:100*((C-买价)/买价-服务费),NODRAW,COLORE66878;

百分之二十5止赢:买价*(1 0.05 服务费),NODRAW,COLOR000999;

百分之二十2股票止损:买价*(1-0.025 服务费),COLORGREEN,NODRAW;

止赢标准:=H>百分之二十5止赢;

止赢日数:=BARSLAST(止赢标准);

股票止损标准:=C<百分之二十2股票止损;

股票止损日数:=BARSLAST(股票止损标准);

止赢:=买进日数> 止赢日数 AND 止赢日数<股票止损日数;

止赢日数2:=BARSLAST(止赢标准 AND 止赢 AND COUNT(REF(止赢,1),1)=0);

股票止损:=买进日数>股票止损日数 AND 止赢日数>股票止损日数;

股票止损日数2:=BARSLAST(股票止损 AND COUNT(REF(股票止损,1),1)=0);

DRAWTEXT(止赢 AND COUNT(REF(止赢,1),1)=0 AND 买进日数<股票止损日数2,0.8,'止赢');

DRAWICON(止赢 AND COUNT(REF(止赢,1),1)=0 AND 买进日数<股票止损日数2,0.5,1);

DRAWTEXT(股票止损 AND COUNT(REF(股票止损,1),1)=0 AND 买进日数<止赢日数2,-0.4,'股票止损');

DRAWICON(股票止损 AND COUNT(REF(股票止损,1),1)=0 AND 买进日数<止赢日数2,-0.6,2);

-1;

逃跑价:HHV(H,买进日数)*0.905,NODRAW;

逃跑标准:=C<逃跑价;

逃跑日数:=BARSLAST(逃跑标准);

逃跑:=买进日数>逃跑日数;

逃跑日数2:=BARSLAST(逃跑 AND COUNT(REF(逃跑,1),1)=0);

DRAWTEXT(逃跑标准 AND 逃跑日数2=0,-0.3,'逃跑');

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号