广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

将K线重心点改成通达信

  • 牛股公式
  • 2020-09-05 17:40
  • 牛股网
广告管理-720PX*80PX

编写标准:不便教师将K线重心点改成通达信的,源代码:

input: N(4,2,400);

{K线}

KLINE(O,H,L,C,0);

ZF:=(C-REF(C,1))/REF(C,1);

TJ:=ZF>=N/100 OR ZF<=-N/100;

AA:=IF(REF(H,BARSLAST(TJ))REF(C,BARSLAST(TJ) 1),REF(C,BARSLAST(TJ) 1),REF(L,BARSLAST(TJ)));

PARTLINE(BARSLAST(TJ),REF(LOW,BARSLAST(TJ))),COLORGREEN;//下限:

PARTLINE(BARSLAST(TJ),REF(LOW,BARSLAST(TJ))),SHIFT1,COLORGREEN;

PARTLINE(BARSLAST(TJ),REF(HIGH,BARSLAST(TJ))),COLORYELLOW;//限制:

PARTLINE(BARSLAST(TJ),REF(HIGH,BARSLAST(TJ))),SHIFT1,COLORYELLOW;

PARTLINE(BARSLAST(TJ),(AA BB)/2),COLORWHITE;//重心点:

PARTLINE(BARSLAST(TJ),(AA BB)/2),SHIFT1,COLORWHITE;

编写方式:{K线 N(4,2,400);}

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

ZF:=(C-REF(C,1))/REF(C,1);

TJ:=ZF>=N/100 OR ZF<=-N/100;

AA:=IF(REF(H,BARSLAST(TJ))<REF(C,BARSLAST(TJ) 1),REF(C,BARSLAST(TJ) 1),REF(H,BARSLAST(TJ)));

BB:=IF(REF(L,BARSLAST(TJ))>REF(C,BARSLAST(TJ) 1),REF(C,BARSLAST(TJ) 1),REF(L,BARSLAST(TJ)));

下限:IF(BARSLAST(TJ),REF(LOW,BARSLAST(TJ)),DRAWNULL),colorgreen;

限制:IF(BARSLAST(TJ),REF(HIGH,BARSLAST(TJ)),DRAWNULL),coloryellow;

重心点:IF(BARSLAST(TJ),(AA BB)/2,DRAWNULL),colorwhite;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号