广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把“战队魔刀”淘宝主图指标值改成同花顺的

  • 牛股公式
  • 2020-09-05 17:26
  • 牛股网
广告管理-720PX*80PX

撰写标准:请教师帮助把熟睡滴鱼教师改写的“战队魔刀”淘宝主图指标值改成同花顺的,感谢!

源代码:

{【战队魔刀--熟睡滴鱼改写】}

MA3:MA(CLOSE,3),COLOR9000F5;

MA18:MA(CLOSE,18),COLOR0099FF,LINETHICK2;

{融胜安全通道}

M10:=EMA(C,10);

融胜:=M10,COLORRED,LINETHICK2;

FF:=ABS((2*CLOSE HIGH LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

DD:=DMA(CLOSE,FF);

高抛:(1 14/100)*DD,DOTLINE,COLORGREEN;

工作压力:(1 7/100)*DD,DOTLINE,COLORFFFF00;

支撑:(1-7/100)*DD,DOTLINE,COLORBLUE;

低吸:(1-14/100)*DD,DOTLINE,COLORRED;

中轨:(工作压力 支撑)/2,DOTLINE,COLORMAGENTA;

DRAWTEXT(CURRBARSCOUNT=1,高抛,'高抛'),COLORGREEN;

DRAWTEXT(CURRBARSCOUNT=1,工作压力,'工作压力'),COLORFFFF00;

DRAWTEXT(CURRBARSCOUNT=1,中轨,'中轨'),COLORMAGENTA;

DRAWTEXT(CURRBARSCOUNT=1,支撑,'支撑'),COLORBLUE;

DRAWTEXT(CURRBARSCOUNT=1,低吸,'低吸'),COLORRED;

IF(MA3>=REF(MA3,1) AND MA3>支撑,MA3,DRAWNULL),COLORRED,LINETHICK4;

{【平均可变成本】}

平均可变成本:((COST(18) COST(8))/2 COST(13))/2,COLORYELLOW,LINETHICK2;{本句带有未来函数COST,自身决策何去何从本句吧}

{【追 加 抛 交货】}

A:=(REF(EMA(CLOSE,5),1));

B:=CROSS(EMA(CLOSE,5),EMA(SLOPE(CLOSE,21)*20 CLOSE,42));

DRAWTEXT(B,LOW*0.995,'追'),COLORFFFF00,LINETHICK2;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

J:=3*K-2*D;

DRAWTEXT(CROSS(J,D),LOW*0.98,'加'),COLOR00FFFF,LINETHICK2;

VAR29:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

VAR2A:=SMA(VAR29,5,1);

VAR2B:=SMA(VAR2A,10,1);

VAR2C:=CROSS(VAR2B,VAR2A);

VAR3D:=VAR2B>80 OR VAR2A>80;

VAR2E:=VAR2C AND VAR3D;

VAR33:=HIGH;

VAR34:=LOW;

抄底逃顶:=STICKLINE(VAR2E,VAR33,VAR34,4,0);

DRAWTEXT(CROSS((REF(HIGH,1) REF(LOW,1))/2,MA(CLOSE,20) 2*STD(CLOSE,20)),HIGH*1.01,'抛'),COLORGREEN;

X6:=REF(CLOSE,1);

X7:=SMA(MAX(CLOSE-X6,0),7,1)/SMA(ABS(CLOSE-X6),7,1)*100;

X8:=CROSS(79,X7);

X9:=FILTER(X8,4);DRAWTEXT(X9,HIGH*1.03,'交货'),COLOR9000F5;

STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"0.01 AND "KDJ.J"0.01 AND "KDJ.J"0.01 AND "KDJ.J"0.01 AND "KDJ.J"0.01 AND "KDJ.J"=2099 AND MONTH>2,0,1);

VAR4s店:=LLV(LOW,5);

VAR5S:=HHV(HIGH,4);

散户:=EMA((VAR2S-VAR4s店)/(VAR5S-VAR4s店)*100,4)*VAR3S;

庄家:=EMA(0.667*REF(散户,1) 0.333*散户,2)*VAR3S;

STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,3.15,0),COLOR770077;

STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,2.45,0),COLOR990099;

STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,1.75,0),COLORBB00BB;

STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,1.05,0),COLORDD00DD;

STICKLINE(CROSS(散户,庄家) AND 散户<30,L,OPEN,0.35,0),COLORFF00FF;

DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L*0.99,'吸'),COLORFF00FF;

撰写方式:ma3:ma(close,3),color9000f5;

ma18:ma(close,18),color0099ff,linethick2;

m10:=ema(c,10); 融胜:=m10;

ff:=abs((2*close high low)/4-ma(close,20))/ma(close,20);

dd:=dma(close,ff);

高抛:(1 14/100)*dd,dotline,colorgreen;

工作压力:(1 7/100)*dd,dotline,colorffff00;

支撑:(1-7/100)*dd,dotline,colorblue;

低吸:(1-14/100)*dd,dotline,colorred;

中轨:(工作压力 支撑)/2,dotline,colormagenta;

drawtext(barstatus=2,高抛,'高抛'),colorgreen;

drawtext(barstatus=2,工作压力,'工作压力'),colorffff00;

drawtext(barstatus=2,中轨,'中轨'),colormagenta;

drawtext(barstatus=2,支撑,'支撑'),colorblue;

drawtext(barstatus=2,低吸,'低吸'),colorred;

partline(ma3,ma3>=ref(ma3,1) and ma3>支撑,rgb(255,0,0)),linethick4;

平均可变成本:((cost(18) cost(8))/2 cost(13))/2,coloryellow,linethick2;{本句带有未来函数cost,自身决策何去何从本句吧}

a:=(ref(ema(close,5),1));

b:=cross(ema(close,5),ema(slope(close,21)*20 close,42));

drawtext(b,low*0.995,'追'),colorffff00,linethick2;

rsv:=(close-llv(low,9))/(hhv(high,9)-llv(low,9))*100;

k:=sma(rsv,3,1); d:=sma(k,3,1); j:=3*k-2*d;

drawtext(cross(j,d),low*0.98,'加'),color00ffff,linethick2;

var29:=(close-llv(low,60))/(hhv(high,60)-llv(low,60))*100;

var2a:=sma(var29,5,1); var2b:=sma(var2a,10,1);

var2c:=cross(var2b,var2a); var2d:=var2b>80 or var2a>80;

var2e:=var2c and var2d; var33:=high; var34:=low;

抄底逃顶:=stickline(var2e,var33,var34,4,0);

drawtext(cross((ref(high,1) ref(low,1))/2,ma(close,20) 2*std(close,20)),high*1.01,'抛'),colorgreen;

x6:=ref(close,1); x7:=sma(max(close-x6,0),7,1)/sma(abs(close-x6),7,1)*100;

x8:=cross(79,x7); x9:=filter(x8,4); drawtext(x9,high*1.03,'交货');

stickline(cross(0.9,1/vol*1000>0.01 and "kdj.j"<0),l,open,3.15,0),color337777;

stickline(cross(0.9,1/vol*1000>0.01 and "kdj.j"<0),l,open,2.45,0),color339999;

stickline(cross(0.9,1/vol*1000>0.01 and "kdj.j"<0),l,open,1.75,0),color33bbbb;

stickline(cross(0.9,1/vol*1000>0.01 and "kdj.j"<0),l,open,1.05,0),color33dddd;

stickline(cross(0.9,1/vol*1000>0.01 and "kdj.j"<0),l,open,0.35,0),color33ffff;

drawtext(cross(0.9,1/vol*1000 >0.01 and "kdj.j"<0),l*0.99,'地量买点'),color33ffff;

drawtext(cross(88,"rsi.rsi1"),(high*1.01),'r背'),color00ff00;

var2s:=(2*close+high+low)/4; var3s:=if(year>=2099 and month>2,0,1);

var4s:=llv(low,5); var5s:=hhv(high,4);

散户:=ema((var2s-var4s)/(var5s-var4s)*100,4)*var3s;

庄家:=ema(0.667*ref(散户,1)+0.333*散户,2)*var3s;

stickline(cross(散户,庄家) and 散户<30,l,open,3.15,0),color770077;

stickline(cross(散户,庄家) and 散户<30,l,open,2.45,0),color990099;

stickline(cross(散户,庄家) and 散户<30,l,open,1.75,0),colorbb00bb;

stickline(cross(散户,庄家) and 散户<30,l,open,1.05,0),colordd00dd;

stickline(cross(散户,庄家) and 散户<30,l,open,0.35,0),colorff00ff;

drawtext(cross(散户,庄家) and 散户<30,l*0.99,'吸'),colorff00ff;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号