广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把通达信公式的量能饱和度改写成大智慧的

  • 牛股公式
  • 2020-09-05 17:23
  • 牛股网
广告管理-720PX*80PX

撰写标准:请教师帮助把通达信公式的量能饱和度改写成大智慧的,先谢谢了

{N(20,1,100);}

量能饱和度:IF((AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100);

STICKLINE(((CLOSE > 0) AND ISLASTBAR),20,121,6,1),COLORFFFFFF;

STICKLINE(((量能饱和度 5) AND (量能饱和度 20) AND (量能饱和度 40) AND ISLASTBAR),21,(20 量能饱和度),5,0),COLOR0000FF;

{SAT:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26);

饱和度:IF(SAT>1,1,SAT)*100,COLORYELLOW;

STICKLINE(C>0 AND ISLASTBAR=1,5,100,10,1),COLORWHITE;

量能≤5:STICKLINE(饱和度5 AND 饱和度80 AND 饱和度=97 AND ISLASTBAR=1,5,饱和度,8,0),COLORGREEN;

DRAWTEXT(ISLASTBAR=1 AND 饱和度,0,'量能饱和度:' 饱和度),COLORFFCCFF;

5,POINTDOT,COLORFFEEBB;

97,POINTDOT,COLORGREEN;};

主要参数 n 最少 1.00 较大 100.00 默认设置 8.96

撰写方式:n:=8.96;

量能饱和度:IF((AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100);

STICKLINE(((CLOSE > 0) AND BARSTATUS=2),20,121,6,1),COLORFFFFFF;

STICKLINE(((量能饱和度 <= 5) AND BARSTATUS=2),21,(20 量能饱和度),5,0),COLORFFFFFF;

STICKLINE((((量能饱和度 > 5) AND (量能饱和度 <= 20)) AND BARSTATUS=2),21,(20 量能饱和度),5,0),COLORCCFF88;

STICKLINE((((量能饱和度 > 20) AND (量能饱和度 <= 40)) AND BARSTATUS=2),21,(20 量能饱和度),5,0),COLORFF00FF;

STICKLINE(((量能饱和度 > 40) AND BARSTATUS=2),21,(20 量能饱和度),5,0),COLOR0000FF;

{SAT:=(AMOUNT/CLOSE)/HHV((AMOUNT/CLOSE),26);

饱和度:IF(SAT>1,1,SAT)*100,COLORYELLOW;

STICKLINE(C>0 AND BARSTATUS=2,5,100,10,1),COLORWHITE;

量能≤5:STICKLINE(饱和度<=5 AND BARSTATUS=2,5,饱和度 20,6,0),COLORRED;

量能5~80:STICKLINE((饱和度>5 AND 饱和度< 80) AND BARSTATUS=2,5,饱和度 8,6,0),COLOR5290FF;

量能80~97:STICKLINE((饱和度>80 AND 饱和度< 97) AND BARSTATUS=2,5,饱和度,6,0),COLORFFCC00;

量能≥97:STICKLINE(饱和度>=97 AND BARSTATUS=2,5,饱和度,8,0),COLORGREEN;

DRAWTEXT(BARSTATUS=2 AND 饱和度,0,'量能饱和度:' 饱和度),COLORFFCCFF;

5,POINTDOT,COLORFFEEBB;

97,POINTDOT,COLORGREEN;};

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号