广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把这个指标值出豪华黄钻的情况下做下条件选股

  • 牛股公式
  • 2020-09-05 17:09
  • 牛股网
广告管理-720PX*80PX

撰写标准:A:=DRAWLINE(LOW<=LLV(LOW,120),LOW,HHV(H,6)REF(VAR0,2),VAR0,DRAWNULL), COLORRED, LINETHICK2;

持币观望区:IF(VAR0

MA0:=MA(C,0)COLORYELLOW ,LINETHICK2;

K:=(C H L)/3;

D:=MA(K,4);

顶端:=HHV(H*0.98,55)COLORYELLOW,LINETHICK2;

Q:=DRAWTEXT(REF(C,1)D AND D0,O ,C ,0.5,0 ),COLORRED;

STICKLINE(角度<0,O ,C,0.5 ,0 ),COLORCYAN;

STICKLINE(角度<0,O,C,3,0),COLORFF6600;{蓝K线持币}

STICKLINE(角度<0,O,C,2,0),COLORFF9900;

STICKLINE(角度<0,O,C,1.2,0),COLORFFCC00;

STICKLINE(角度0,O,C,3,0),COLOR000099;

STICKLINE(角度>0,O,C,2,0),COLOR0000CC;{红K线持仓}

STICKLINE(角度>0,O,C,1.3,0),COLOR0000FF;

STICKLINE(角度>0,O,C,0.3,0),COLORCC66FF;

上位线:EMA(CLOSE,7),LINETHICK1,COLORGREEN;

底位线:EMA(CLOSE,14),LINETHICK1,COLORRED ;

AC1:=MA(CLOSE,N);

AC2:=MA(CLOSE,N1);

AC3:=MA(CLOSE,N2);

AC4:=MA(CLOSE,N3);

股票换手:=V*100/CAPITAL;

主要:=MA(股票换手,4);

种植大户:=MA(股票换手,9);

中户:=MA(股票换手,17);

散户:=MA(股票换手,34);

均量:=(主要 种植大户 中户 散户)/4;

散户动能:=(散户-均量);

VAR1:=EMA(EMA(CLOSE,9),9);

控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;

有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;

强势股:=CLOSE>AC1 AND AC1>AC2 AND AC2>AC3 AND AC3>AC4 AND CLOSE>OPEN AND

散户动能0

AND (ATAN((MA(C,5)/REF(MA(C,5),1)-1)*100)*180/3.14115926)>45;

攻击迫线:=OPEN>REF(HIGH,1) AND CLOSE>REF(HIGH,1) AND LOW>REF(HIGH,1) AND HIGH>CLOSE AND REF(CLOSE,1)/REF(CLOSE,2)>=1.09 AND V>REF(V,1);

第五天:=REF((C-REF(C,1))/REF(C,1)>0.09,4) AND COUNT((C-REF(C,1))/REF(C,1)>0.09,4 1)=1 AND C>EMA(C,14);

六埋伏:=REF((C-REF(C,1))/REF(C,1)>0.09,5) AND COUNT((C-REF(C,1))/REF(C,1)>0.09,5 1)=1 AND C>EMA(C,14);

七攻拳:=REF((C-REF(C,1))/REF(C,1)>0.09,6) AND COUNT((C-REF(C,1))/REF(C,1)>0.09,6 1)=1 AND C>EMA(C,14);

熊牛无败:=CROSS(C,MA(C,250)) AND V>1.5*REF(MA(V,5),1) AND C/(REF(C,1)-1)>1.3 AND CLOSE/REF(CLOSE,1)>=1.9;

搓揉线:=REF(O,1)=REF(L,1) AND REF(H,1)/REF(C,1)>1.03 AND REF(C,1)>REF(C,2) AND H=C AND C/L>1.03 AND H>REF(C,1);

绝地逢生:=OO AND CREF(V,1) AND REF(C,1)/REF(C,2)<0.95 AND REF(V,1)=1.05 AND CLOSE/REF(LOW,1)>=1.05 AND CLOSE>REF(HIGH,1);

抱星长阳:=O1.083*REF(C,1) AND H>REF(H,1);

DRAWTEXT((强势股 = 1),LOW-0.05,'主升!'),LINETHICK2,COLORF00FF0;

DRAWTEXT((攻击迫线 = 1),LOW-0.05,'攻!'),LINETHICK2,COLORRED;

DRAWTEXT((第五天 = 1),LOW-0.05,'五!'),LINETHICK2,COLORGREEN;

DRAWTEXT((六埋伏 = 1),LOW-0.05,'六!'),LINETHICK2,COLORGREEN;

DRAWTEXT((七攻拳 = 1),LOW-0.05,'七!'),LINETHICK2,COLORGREEN;

DRAWTEXT((熊牛无败 = 1),LOW-0.05,'牛!'),LINETHICK2,COLORFF00CC;

DRAWTEXT((搓揉线 = 1),LOW-0.05,'搓!'),LINETHICK2,COLORBLUE;

DRAWTEXT((绝地逢生 = 1),LOW-0.05,'绝!'),LINETHICK2,COLORDB9370;

DRAWTEXT((占领翻转 = 1),LOW-0.05,'吞!'),LINETHICK2,COLORYELLOW;

DRAWTEXT((抱星长阳 = 1),LOW-0.05,'抱!'),LINETHICK2,COLORBLUE;

AA:=VAR1>=REF(VAR1,1);

BB:=VAR1

买入:DRAWICON(CROSS(AA,BB),L,1);

售出:DRAWICON(CROSS(BB,AA),H,2);

STICKLINE(买入,O,(C-O)/2 O,3,0),COLOR335555;

STICKLINE(买入,O,(C-O)/2 O,2.2,0),COLOR338888;

STICKLINE(买入,O,(C-O)/2 O,1.5,0),COLOR33AAAA;

STICKLINE(买入,O,(C-O)/2 O,1,0),COLOR33CCCC;

STICKLINE(买入,O,(C-O)/2 O,0,0),COLOR33EEEE;

STICKLINE(售出,O,(C-O)/2 O,3,0),COLOR550055;

STICKLINE(售出,O,(C-O)/2 O,2.2,0),COLOR880088;

STICKLINE(售出,O,(C-O)/2 O,1.5,0),COLORAA00AA;

STICKLINE(售出,O,(C-O)/2 O,1,0),COLORCC00CC;

STICKLINE(售出,O,(C-O)/2 O,0.5,0),COLOREE00EE;

Q_1:=C-REF(C,1);

Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);

Q_3:=CROSS(EMA(C,19),EMA(C,7));

Q_4:=CROSS(EMA(C,7),EMA(C,19));

Z1:=L=LLV(L,BARSLAST(Q_3) 1);

Z2:=LLV(L,BARSLAST(Q_3) 1);

Z3:=H=HHV(H,BARSLAST(Q_4) 1);

Z4:=HHV(H,BARSLAST(Q_4) 1);

Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0);

Y1:=H=HHV(H,BARSLAST(Q_4) 1);

Y2:=HHV(H,BARSLAST(Q_4) 1);

Y3:=L=LLV(L,BARSLAST(Q_3) 1);

Y4:=LLV(L,BARSLAST(Q_3) 1);

Q_B:=DRAWLINE(Y1,Y2,Y3,Y4,0);

X1:=LLV(Q_2,2)=LLV(Q_2,7) ;

X2:=COUNT(Q_2<0,2);

X3:=CROSS(Q_2,MA(Q_2,2));

X4:=REF(Q_B,1)REF(Q_B,1);

买入:=(X1 AND X2 AND X3) AND X4 AND X5;

DRAWKLINE(H,O,L,C);

DRAWICON(买入,L,26);

K1:=(C L H)/3;

BB5:=ATAN(EMA(K1,7)-REF(EMA(K1,7),1))*3.1416*10;

EMA3:=EMA(C,3);

DRAWTEXT(FILTER(BB5>1 AND EMA(K1,7)>REF(EMA(K1,7),1),10),

LOW*0.99,'∠45'),COLORFFFFFF;

A1:=CONST(BARSCOUNT(C>O))-BARSCOUNT(C>O)<20;

箱顶:DRAWLINE(CONST(HHV(H,20))=H AND A1,CONST(HHV(H,20)),ISLASTBAR,CONST(HHV(H,20)),0),COLORRED;

底箱:DRAWLINE(CONST(LLV(L,20))=L AND A1,CONST(LLV(L,20)),ISLASTBAR,CONST(LLV(L,20)),0),COLORGREEN;

N:=10;

T1:=CONST(HHVBARS(V,N));

T0:IF(CURRBARSCOUNT=REF(MA5,1);

H1:=MAX(MAX(MA5,MA13),MA34);

L1:=MIN(MIN(MA5,MA13),MA34);

一阳穿三线:= H1

STICKLINE(一阳穿三线,O,C,2,0),COLORYELLOW;

DRAWTEXT(一阳穿三线,L-0.1, '金' ),COLORGREEN;

编写方法:Q_1:=C-REF(C,1);

Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);

Q_3:=CROSS(EMA(C,19),EMA(C,7));

Q_4:=CROSS(EMA(C,7),EMA(C,19));

Z1:=L=LLV(L,BARSLAST(Q_3)+1);

Z2:=LLV(L,BARSLAST(Q_3)+1);

Z3:=H=HHV(H,BARSLAST(Q_4)+1);

Z4:=HHV(H,BARSLAST(Q_4)+1);

Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0);

Y1:=H=HHV(H,BARSLAST(Q_4)+1);

Y2:=HHV(H,BARSLAST(Q_4)+1);

Y3:=L=LLV(L,BARSLAST(Q_3)+1);

Y4:=LLV(L,BARSLAST(Q_3)+1);

Q_B:=DRAWLINE(Y1,Y2,Y3,Y4,0);

X1:=LLV(Q_2,2)=LLV(Q_2,7) ;

X2:=COUNT(Q_2<0,2);

X3:=CROSS(Q_2,MA(Q_2,2));

X4:=REF(Q_B,1)<REF(Q_B,2);

X5:=Q_A>REF(Q_B,1);

买进:(X1 AND X2 AND X3) AND X4 AND X5;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号