广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信大旗天眼通主图指标公式

  • 牛股公式
  • 2020-09-18 18:28
  • 牛股网
广告管理-720PX*80PX

DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,'11',0);

MA10:MA(C,10);

MA60:MA(C,60);

VAR6:=(( ABS((OPEN-CLOSE))/(HIGH-LOW))*VOL);

VAR7:=(( (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN))/(HIGH-LOW))*VOL);

VAR8:=(( (IF((CLOSE>OPEN),OPEN,CLOSE)-LOW)/(HIGH-LOW))*VOL);

VAR9:=IF(((VOL/CAPITAL)>0.001),1,EXP(ABS(LOG(((VOL/CAPITAL)*100)))));

买入:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,NODRAW,COLORRED;

减持:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,NODRAW,COLORBLUE;

震仓:VAR8>VAR6 AND VAR8>VAR7,NODRAW,COLORWHITE;

高抛:VAR7>VAR6 AND VAR7>VAR8,NODRAW,COLORMAGENTA;

底部放量:VAR9>2 AND VOL<MA(VOL,5)/2,NODRAW,COLORGREEN;

DRAWKLINE(H,O,L,C);

TY:=C;

A1:=REF(TY,10)=HHV(TY,2*10 1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10 1); HD:=FILTER(C1,10);

A2:=REF(TY,10)=LLV(TY,2*10 1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10 1); LD:=FILTER(C2,10);

早期上位:REF(H,BARSLAST(HD)), COLORFF00FF,POINTDOT,LINETHICK3;

早期底位:REF(L,BARSLAST(LD)), COLORGREEN,POINTDOT,LINETHICK3;

STICKLINE(买入,O,C,1,0),COLORRED;

STICKLINE(震仓,O,C,1,0),COLORWHITE;

STICKLINE(减持,O,C,1,0),COLORBLUE;

STICKLINE(高抛,O,C,1,0),COLORMAGENTA;

STICKLINE(底部放量,O,C,1,0),COLORGREEN;

JJ:=(3*C H L O)/6;

VAR1:=(8*JJ 7*REF(JJ,1) 6*REF(JJ,2) 5*REF(JJ,3) 4*REF(JJ,4) 3*REF(JJ,5) 2*REF(JJ,6) REF(JJ,8))/36;

TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);

LJL:=FILTER(TJ1,5);

STICKLINE(CLOSE,REF(LOW,BARSLAST(LJL)),REF(LOW,BARSLAST(LJL)),1,0),COLORRED;

STICKLINE(CLOSE,REF(CLOSE,BARSLAST(LJL)),REF(CLOSE,BARSLAST(LJL)),1,0),COLORYELLOW;

STICKLINE(LJL,OPEN,CLOSE,1,0),COLORYELLOW;

DRAWTEXT_FIX(1,0.0,0.0,0,'蓝芯-主要底位深层震仓或上位交货果断'),COLORBLUE,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.06,0,'白头-主要轻微震仓'),COLORWHITE,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.12,0,'棕芯-出現了最近相对性底部放量'),COLORGREEN,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.18,0,'粉芯-主要在做波段操作或低吸高抛'),COLORFF00FF,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.24,0,'红芯-主力建仓拿货积极'),COLORRED,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.3,0,'黄芯-主力建仓拿货强而且交易量出現黄金柱'),COLORYELLOW,LINETHICK1;

DRAWTEXT_FIX(C>0,0.004,1,0,DYBLOCK),COLORYELLOW,LINETHICK2;

DRAWTEXT_FIX(C>0,0.06,1,0,HYBLOCK),COLORRED,LINETHICK2;

DRAWTEXT_FIX(C>0,0.12,1,0,EXTERNSTR(0,1)),COLORWHITE,LINETHICK2;

EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);

PL10:=ZIG(3,10);

走高2:=BARSLAST(PL10<REF(PL10,1));

ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走高2),0);

追2:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2;

追4:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3;

DRAWTEXT(追2 OR 追4,LOW*0.978,'追'),COLORYELLOW;

PL5:=ZIG(3,5);

EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);

EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);

EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);

PL20:=ZIG(3,20);

EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);

EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);

PL40:=ZIG(3,40);

走高1:=BARSLAST(PL5<REF(PL5,1));

走低1:=BARSLAST(PL5>REF(PL5,1));

走低2:=BARSLAST(PL10>REF(PL10,1));

走高3:=BARSLAST(PL20<REF(PL20,1));

走低3:=BARSLAST(PL20>REF(PL20,1));

{ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走高2),0);}

ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走高2),0);

DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走低2),0);

DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走低2),0);

ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走高3),0);

ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走高3),0);

DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走低3),0);

DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走低3),0);

DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'反跳底点'),COLORLIRED;

DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'反跳高些!'),COLORLIBLUE;

DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'底'),COLORYELLOW;

DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'减持'),COLORFFFF00;

DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'----买'),COLOR0000FF;

DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'短卖'),COLORGREEN;

DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'----短买'),COLOR0000FF;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'短卖'),COLORGREEN;

DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'Ⅰ'),COLORFF00FF;

DRAWTEXT(EX2 AND DTJD10=2,H*1.03,'Ⅱ'),COLORFF6000;

DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'Ⅲ'),COLORYELLOW;

DRAWTEXT(EX2 AND PL20>REF(P L20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK3,COLORFFFF00;

DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.96,'②'),LINETHICK3,COLORYELLOW;

DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.02,'清仓!'),LINETHICK3,COLORWHITE;

DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.96,'④'),LINETHICK3,COLORYELLOW;

DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.95,'⑷'),COLORYELLOW;

EMA13:=EMA(C,13);

EMA34:=EMA(C,34);

EMA55:=EMA(C,55);

EMA120:=EMA(C,120);

CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;

CR2:=V>MA(V,5)*0.6;

CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;

CR4:=ABS(EMA34-EMA55)/EMA55<0.03;

CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1);

CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2);

DRAWTEXT(CR6,C*0.98,'风险'),COLORWHITE;

通达信大旗天眼通主图指标公式

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号