广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信VMACD指标公式

  • 牛股公式
  • 2020-09-18 18:28
  • 牛股网
广告管理-720PX*80PX

N:=1;

DRAWGBK(DATE>900101,RGB(110,95,0),RGB(0,20,0),0,'01',0);

STICKLINE(C>0,0,0,10,0),COLORGRAY;

ZXJ:=IF((H-MAX(C,O))>((MIN(C,O)-L)) AND C>L,((H 2*L)/3 3*C 2*O)/6,

IF((H-MAX(C,O))<((MIN(C,O)-L)) AND C<H,((2*H L)/3 3*C 2*O)/6,((H L)/2 3*C 2*O)/6));

平均价:=IF(PERIOD>=6 AND PERIOD<10,AMOUNT/(VOL*100),ZXJ);

重心点:=IF(SETCODE=0,ZXJ,(ZXJ 平均价)/2);

VV:=AMOUNT/100000000;

LB:=(MA(VV,1)/HHV(VV,0) MA(VV,1)/HHV(VV,IF(N=0,0,IF(N=1,738,IF(N=2,369,184)))))/2;

XS:=2;

S:=IF((H-MAX(C,O))>ABS(C-O)AND (MIN(C,O)-L)<ABS(C-O),(H*0.118 C*0.809 IF(H=C,C,重心点)*0.073),(H*0.073 C*0.809 IF(H=C,C,重心点)*0.118));

X:=IF((MIN(C,O)-L)>ABS(C-O)AND (H-MAX(C,O))<ABS(C-O),(L*0.118 C*0.809 IF(L=C,C,重心点)*0.073),(L*0.073 C*0.809 IF(L=C,C,重心点)*0.118));

SX:=IF(C>REF(C,1)AND H>REF(H,1)AND 重心点>REF(重心点,1),S,IF(C<REF(C,1)AND L<REF(L,1)AND 重心点<REF(重心点,1),X,C));

QR:=(0.809*C 0.191*SX);

OBV:=SUM(IF(QR>REF(QR,1),VV,IF(QR<REF(QR,1),-VV,0)),180);

WOBV:=(WMA(OBV,2) WMA(OBV,4) WMA(OBV,8))/3;

SAOBV:=(WMA(WOBV,24) WMA(WOBV,6) WMA(WOBV,12))/3,COLORFAABEC;

SBOBV:=(WMA(SAOBV,24) WMA(SAOBV,6) WMA(SAOBV,12))/3;

SKOBV:=(WMA(SBOBV,24) WMA(SBOBV,6) WMA(SBOBV,12))/3;

SOOBV:=(WMA(SKOBV,24) WMA(SKOBV,6) WMA(SKOBV,12))/3;

SWOBV:=((WOBV SBOBV)/2 SAOBV)/2,LINETHICK2;

DLV21:=EMA(SWOBV,13);

DLV36:=EMA(SWOBV,34);

DLV60:=EMA(SWOBV,55);

ROBY:=DMA(SWOBV,LB/XS);

SOBV:=DMA(SWOBV,LB/XS/XS);

YOBV:=DMA(SWOBV,LB/XS/XS/XS);

SSOBC:=DMA(SWOBV,LB/XS/XS/XS/XS),COLORFAABEC,COLORRED,LINETHICK2;

LOBV:=DMA(SWOBV,LB/XS/XS/XS/XS/XS),COLOR00BB00;

QROBV:(((SOBV-SSOBC)/2 (YOBV-SSOBC))/2 (((WOBV-SBOBV)/2 SAOBV-SBOBV)/2 (SWOBV-DLV21) ((DLV21-DLV60)/2 DLV36-DLV60)/2))/4,COLOR00CCCC;

MQR:MA(QROBV,8),COLORGRAY;

{飞狐}

{FILLRGN(QROBV>=MQR,QROBV,MQR),COLORBROWN;}

{FILLRGN(QROBV<MQR,QROBV,MQR),COLOR00BB00,COLORBLUE;}

{通达信}

DRAWBAND(QROBV,RGB(213,43,43),MQR,RGB(14,1,254));

OBC:((SOBV-SSOBC ROBY-YOBV)/2 (WOBV-SBOBV (WOBV-SOOBV)/2 SAOBV-SKOBV)/3 DLV21-DLV60)/3,COLOR7F00FF,LINETHICK2;

MOBV:MA(OBC,4),COLORCYAN;

{PARTLINE(OBC<MOBV,OBC),COLOR00BB00,LINETHICK2;}

KOBV:=2*(OBC-MOBV);

DOBV:2*(QROBV-MQR),COLORSTICK;

MACDOBV:(KOBV DOBV)/2,COLORSTICK,COLORRED;

STICKLINE(MACDOBV>=0,0,MACDOBV,5,1),COLORRED;

STICKLINE(MACDOBV<0,0,MACDOBV,5,1),COLOR00BB00;

STICKLINE(DOBV>=0,0,DOBV,0,0),COLOR00CCCC;

STICKLINE(DOBV<0,0,DOBV,0,0),COLORCYAN;

OBVH1:=REF(MACDOBV/2,BARSLAST(MACDOBV=HHV(MACDOBV,34))),COLOR0099FF,LINETHICK1;

OBVH2:REF(MACDOBV/2,BARSLAST(MACDOBV=HHV(MACDOBV,72))),COLORWHITE,LINETHICK1;

OBVL1:=REF(MACDOBV/2,BARSLAST(MACDOBV=LLV(MACDOBV,34))),COLORGRAY,LINETHICK2;

OBVL2:=REF(MACDOBV/2,BARSLAST(MACDOBV=LLV(MACDOBV,144))),COLOR0099FF,LINETHICK2;

大市场行情:=NOT(REF(OBVH1,1)=REF(OBVH2,1)) AND OBVH1=OBVH2;

DRAWTEXT(MACDOBV>OBVH1,OBVL2*2,'*'),COLORWHITE;

DRAWTEXT(大市场行情,OBVH2*4,'★'),COLORRED;

QGOBV:=REF(HHV(MOBV,9),1),COLORFAABEC;

QDOBV:=REF(LLV(MOBV,9),1),COLORAAAA00;

资产粘:=(MAX(OBC,MAX(MOBV,QROBV))-MIN(OBC,MIN(MOBV,QROBV)))/ABS(MIN(OBC,MIN(MOBV,QROBV)))*10;

ZJGL:=(((OBC-MOBV)/ABS(MOBV) (QROBV-MQR)/ABS(MQR) ((OBC-QROBV)/ABS(QROBV) (MOBV-MQR)/ABS(MQR))/2)/3)*10;

DSGL:=(((OBC-MOBV)/ABS(MOBV) (OBC-QGOBV)/ABS(QGOBV) (MOBV-QDOBV)/ABS(QDOBV))/3)*10;

SGL:=(ZJGL DSGL)/2;

DRAWTEXT(CROSS(ZJGL,0)AND OBC>REF(OBC,1),QROBV*0.8,'★'),COLORYELLOW;

DRAWTEXT(CROSS(DSGL,0)AND OBC>REF(OBC,1) AND OBC>QROBV,QROBV*1.25,'★'),COLORWHITE;

通达信VMACD指标公式

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号