广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信全自动发展趋势画线主图指标公式

  • 牛股公式
  • 2020-09-18 18:28
  • 牛股网
广告管理-720PX*80PX

HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0;

AAB:=REF(H,HIGHN)=HHV(H,2*HIGHN 1);

QY:=BACKSET(AAB,HIGHN 1);

CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN 1);

DRAWICON(CC,H*1.02,2);

DDD:=BARSLAST(CC);

GDTS:=IF(CC,CURRBARSCOUNT,0);

DINGBU:=IF(DDD,REF(H,DDD),H);

DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS);

DINGBU1:=REF(DINGBU,DDD 1);

GDCS1:=CONST(DINGBUTS);

DINGBUTS1:=REF(DINGBUTS,DDD 1);

GDCS2:=CONST(DINGBUTS1);

DINGBU2:=REF(DINGBU1,DDD 1);

MMM:=IF(CURRBARSCOUNT>GDCS2,0,1);

高些工作压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,DOTLINE;

工作压力A:DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,DOTLINE;

工作压力B:DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,DOTLINE;

AA1:=REF(L,LOWN)=LLV(L,2*LOWN 1);

QY1:=BACKSET(AA1,LOWN 1);

CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN 1);

DD1:=BARSLAST(CC1);

DDTS:=IF(CC1,CURRBARSCOUNT,0);

YDB:=IF(DD1,REF(L,DD1),L);

DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS);

DDCS1:=CONST(DDTS1);

ZDB:=REF(YDB,DD1 1);

DDTS2:=REF(DDTS1,DD1 1);

DDCS2:=CONST(DDTS2);

底点支撑点:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,DOTLINE;

ZGSTAR:=(高些工作压力 底点支撑点)/2;

ZGEND:=CONST((高些工作压力 底点支撑点)/2);

STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);

中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),POINTDOT,COLORFFBBFF,LINETHICK1;

TTT:=6;

A1:=REF(HIGH,6)=HHV(HIGH,2*TTT 1); B1:=FILTER(A1,TTT); C1:=BACKSET(B1,TTT 1); D1:=FILTER(C1,TTT);

A2:=REF(LOW,TTT)=LLV(LOW,2*TTT 1); B2:=FILTER(A2,TTT); C2:=BACKSET(B2,TTT 1); D2:=FILTER(C2,TTT);

E1:=(REF(LLV(LOW,2*TTT),1) REF(HHV(HIGH,2*TTT),1))/2; E2:=(HIGH LOW)/2;

H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS OR BARSCOUNT(CLOSE)=1;

L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);

X1:=REF(BARSLAST(H1),1) 1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));

G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);

L2:=LD OR BARSTATUS OR BARSCOUNT(CLOSE)=1;

X2:=REF(BARSLAST(L2),1) 1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));

G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);

UU:=BACKSET(BARSTATUS,BARSLAST(LD) 1);

VV:=UU>REF(UU,1);

WW:=BACKSET(VV,REF(BARSLAST(LD),1) 2);

XX:=WW>REF(WW,1);

UU2:=BACKSET(BARSTATUS,BARSLAST(HD) 1);

VV2:=UU2>REF(UU2,1);

WW2:=BACKSET(VV2,REF(BARSLAST(HD),1) 2);

XX2:=WW2>REF(WW2,1);

近低A:REF(L,BARSLAST(VV)),COLORWHITE,LINETHICK1,DOTLINE;

近低B:REF(L,BARSLAST(XX)),COLORMAGENTA,DOTLINE;

DRAWTEXT(CURRBARSCOUNT=2,高些工作压力,STRCAT('工作压力拓宽:',CON2STR(高些工作压力,2))),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=2,底点支撑点,STRCAT('支撑点拓宽:',CON2STR(底点支撑点,2))),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=2,中轨,STRCAT('中轨:',CON2STR(中轨,2))),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=2,工作压力A,STRCAT('工作压力A:',CON2STR(工作压力A,2))),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=2,工作压力B,STRCAT('工作压力B:',CON2STR(工作压力B,2))),COLORYELLOW;

DRAWTEXT(CURRBARSCOUNT=2,近低A,STRCAT('←近低A:',CON2STR(近低A,2))),COLORWHITE;

DRAWTEXT(CURRBARSCOUNT=2,近低B,STRCAT('←近低B:',CON2STR(近低B,2))),COLORMAGENTA;

通达信自动趋势画线主图指标公式

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号