广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信大机构MACD指标公式

  • 牛股公式
  • 2020-09-18 18:27
  • 牛股网
广告管理-720PX*80PX

MACD2:=2*("MACD.DIF"-"MACD.DEA");

(CLOSE<0 AND CROSS("MACD.DIF",0),H*1.3),COLOR000080,NODRAW;

(CLOSE<0 AND CROSS(MACD2,0),H*1.3),COLOR000080,NODRAW;

(CLOSE<0 AND CROSS(0,"MACD.DIF"),H*1.3),COLOR808080,NODRAW;

(CLOSE<0 AND CROSS(0,MACD2),H*1.3),COLOR808080,NODRAW;

DU0:=CROSS("MACD.DIF",0);

UD0:=CROSS(0,"MACD.DIF");

TDU0:=BARSLAST(DU0);

TUD0:=BARSLAST(UD0);

DU3:=REF(DU0,1);

UD3:=REF(UD0,1);

TDU3:=BARSLAST(DU3);

TUD3:=BARSLAST(UD3);

UDGLINE:=IF(TDU3<TUD3,REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));

JDU0:=REF(CLOSE,1)<=REF(UDGLINE,1) AND CLOSE>UDGLINE AND TDU0<TUD0;

JUD0:=REF(CLOSE,1)>=REF(UDGLINE,1) AND CLOSE<UDGLINE AND TUD0<TDU0;

JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;

JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;

JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);

JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);

JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);

JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);

BSLINE:=IF(BARSLAST(JDU2)<BARSLAST(JUD2),IF(REF(CROSS(0,MACD2),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS(0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));

STICKLINE(MACD2>=0,0,MACD2,2,1),COLORRED;{0上红中空MACD柱}

STICKLINE(MACD2>=0 AND MACD2<REF(MACD2,1),0,MACD2,2,0),COLORLIRED;{0上粉色实芯柱}

STICKLINE(MACD2<0,0,MACD2,2,0),COLORCYAN;{0下亮蓝实芯柱}

STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,2,1),COLORFF8000;{0下蓝中空MACD柱}

{--------------标志}

DEFUT:=BARSLAST(CROSS(MACD2,0));

DEFDT:=BARSLAST(CROSS(0,MACD2));

DEFUL:=IF(MACD2>=0,HHV(MACD2,DEFUT 1),REF(HHV(MACD2,DEFUT 1),DEFDT 1));

DEFDL:=IF(MACD2<0,LLV(MACD2,DEFDT 1),REF(LLV(MACD2,DEFDT 1),DEFUT 1));

DEFU2L:=REF(DEFUL,DEFUT 1);

DEFD2L:=REF(DEFDL,DEFDT 1);

DRAWICON(LLV(MACD2,4)>0 AND MACD2<REF(MACD2,1) AND REF(MACD2,1)>REF(MACD2,2) AND REF(MACD2,2)>REF(MACD2,3),MACD2,2);

DRAWICON(HHV(MACD2,4)<0 AND MACD2>REF(MACD2,1) AND REF(MACD2,1)<REF(MACD2,2) AND REF(MACD2,2)<REF(MACD2,3),MACD2,1);

DRAWICON((JUD1 OR BARSLAST(JDU1)>BARSLAST(JUD1)) AND MACD2>=0 AND REF(MACD2,1)<REF(DEFU2L,1) AND MACD2>DEFU2L,MACD2,5);

DRAWICON((JDU1 OR BARSLAST(JDU1)<BARSLAST(JUD1)) AND MACD2<0 AND REF(MACD2,1)>REF(DEFD2L,1) AND MACD2<DEFD2L,MACD2,3);

VAR111:=JDU1 OR BARSLAST(JDU1)<BARSLAST(JUD1);

VAR112:=HHV(MACD2,4)<0 AND MACD2>REF(MACD2,1) AND REF(MACD2,1)<REF(MACD2,2) AND REF(MACD2,2)<REF(MACD2,3);

{DIF和DEA线}

SHORT:=12;LONG:=26;MID:=9;

VA:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);

OBV1:=SUM(IF(CLOSE=REF(CLOSE,1),0,VA),0);

OBV2:=EMA(OBV1,3)-MA(OBV1,9);

OBV3:=EMA(IF(OBV2>0,OBV2,0),3);

MAC3:=MA(C,3);

DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG)COLORYELLOW,LINETHICK2;{双黄线}

DEA:EMA(DIF,MID)COLORBLUE;{绿线}

DIF1:IF(DIF>REF(DIF,1),DIF,DRAWNULL),COLOR8000FF,LINETHICK2;{玫红杠}

DIF2:IF(DIF<REF(DIF,1),DIF,DRAWNULL),COLORFF0080,LINETHICK2;{紫线}

{macd金叉和背驰的标志}

底位macd金叉:=CROSS(DIF,DEA) AND DIF<-0.1;

DRAWTEXT(底位macd金叉,-0.5,'★底位macd金叉'),COLORWHITE;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次macd金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

DRAWICON(二次macd金叉,DEA*0.9,1) ;

DRAWTEXT(二次macd金叉,0.5,'★二次macd金叉'),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1 1)>CLOSE AND DIF>REF(DIF,A1 1) AND CROSS(DIF,DEA);

DRAWTEXT(底背离,-1,'▲底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2 1)<CLOSE AND REF(DIF,A2 1)>DIF AND CROSS(DEA,DIF);

DRAWTEXT(顶背离,1,'●顶背离'),COLORGREEN;

DRAWTEXT(底位macd金叉 AND 二次macd金叉 AND 底背离,0,'★三项全能型'),COLORYELLOW;

通达信大机构MACD指标公式

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号