广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信成仙得道主图指标公式

  • 牛股公式
  • 2020-09-18 18:25
  • 牛股网
广告管理-720PX*80PX

N:=3;

KKK:=SMA(H,11,1);

CX:=IF(KKK>REF(KKK,1),KKK,HHV(KKK,63));

GGG:=SMA(L,11,1);

DD:=IF(GGG<REF(GGG,1),GGG,LLV(GGG,63));

成仙淡黄色线增涨:IF(C>=CX,CX,DRAWNULL),LINETHICK2,COLORYELLOW;

得道:DD,COLORLIBLUE;

TY:=C;

A1:=REF(TY,10)=HHV(TY,2*10 1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10 1); HD:=FILTER(C1,10);

A2:=REF(TY,10)=LLV(TY,2*10 1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10 1); LD:=FILTER(C2,10);

A:=REF(C,BARSLAST(HD)); B:=REF(C,BARSLAST(LD));

T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;

T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);

波峰焊:IF(N>=1 AND T1,A,DRAWNULL),COLORYELLOW,POINTDOT,LINETHICK4;

STICKLINE(T1,A,A,9,0),COLORFF00FF;

波谷:IF(N>=1 AND T2,B,DRAWNULL),COLORLIGREEN,POINTDOT,LINETHICK4;

R:=MA(CLOSE,17) MA(CLOSE,17)-REF(MA(CLOSE,17),1);

XQ:=IF(MA(CLOSE,17)<R,R,MA(CLOSE,17));

下就上:XQ-(EMA(CLOSE,3)-XQ),COLORFF8080,LINETHICK2;

MX:=EMA(C,2);

XM:=EMA(SLOPE(C,21)*20 C,42);

BU:=CROSS(MX,XM);

SEL:=CROSS(XM,MX);

DRAWICON(BU,0.96*L,7);{

DRAWICON(SEL,1.03*H,2);}

{顶端}

DFQS:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1);

TX:=78.89;

{DRAWICON(CROSS(TX,DFQS),1.02*H,6);}

STICKLINE(CROSS(TX,DFQS),H*1.02,H*1.00,3,0),COLOR00FF00;

DRAWTEXT(FILTER(CROSS(TX,DFQS),10),H*1.04,'抄底逃顶'),COLORFF6699;

{风险性护栏}

ZLKZ:=N;

A0:=LLV(INDEXC,24)*1.056;

X:=REF(CLOSE,1)<REF(CLOSE,2) AND REF(VOL,1)>MAX(REF(MA(VOL,5),1),MAX(REF(MA(VOL,10),1),REF(MA(VOL,20),1))) AND REF(VOL,1)>REF(MA(VOL,20),1)*1.1;

Y:=IF(X,MIN(REF(LOW,1),LOW),0);

Z1:=REF(Y,BARSLAST(X)),LINETHICK2,COLORFFFF00;

上护栏:IF(ZLKZ=3,Z1,DRAWNULL),COLORFFFF00,LINETHICK2;

X1:=REF(CLOSE,1)<REF(OPEN,1) AND REF(VOL,1)>MAX(REF(MA(VOL,5),1),MAX(REF(MA(VOL,10),1),REF(MA(VOL,20),1))) AND REF(AMOUNT,1)=REF(HHV(AMOUNT,20),1) OR REF(CLOSE,1)<REF(OPEN,1) AND REF(AMOUNT,1)=REF(HHV(AMOUNT,20),1);

MID:=(3*CLOSE LOW OPEN HIGH)/6;

{自定平均价,多空线}

DKX:=(20*MID 19*REF(MID,1) 18*REF(MID,2) 17*REF(MID,3) 16*REF(MID,4) 15*REF(MID,5) 14*REF(MID,6) 13*REF(MID,7) 12*REF(MID,8) 11*REF(MID,9) 10*REF(MID,10) 9*REF(MID,11) 8*REF(MID,12) 7*REF(MID,13) 6*REF(MID,14) 5*REF(MID,15) 4*REF(MID,16) 3*REF(MID,17) 2*REF(MID,18) REF(MID,20))/210;

ZL1:=MA(DKX,3);

ZL2:=MA(DKX,5);

ZL3:=MA(DKX,21);

ZL4:=MA(DKX,34);

Y1:=IF(X1,REF(CLOSE,1),0);

Z2:=REF(Y1,BARSLAST(X1)),COLORRED,LINETHICK2;

下护栏:IF(ZLKZ=3,Z2,DRAWNULL),COLORRED,LINETHICK2;

STICKLINE(N>=2 AND CLOSE>0 AND (MAX(Z1,Z2)-MIN(Z1,Z2))/MIN(Z1,Z2)*100<3

AND MAX(ZL1,ZL2)>MIN(ZL3,ZL4),Z1,Z2,5,0),COLORGREEN;

通达信成仙得道主图指标公式

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号