广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信公式五弧形淘宝主图及选股指标公式计算

  • 牛股公式
  • 2020-09-18 18:24
  • 牛股网
广告管理-720PX*80PX

A:=CURRBARSCOUNT;

HA:=IF(BETWEEN(DATE,1150601,1150630),H,-999);

T:=HHVBARS(HA,0);

TT:=BARSLAST(L=LLV(L,T 1));

T1:=BARSLAST(A=CONST(TT) 1);

T2:=BARSLAST(A=CONST(T) 1);

GT:=CONST(T2) 1;

DT:=CONST(T1) 1;

AA:=DRAWLINE(A=GT,H,A=DT,L,0);

DRAWBAND(AA,RGB(69,139,0),AA,RGB(69,139,0));

HH:=CONST(REF(L,BARSLAST(A=DT 1)));

LL:=CONST(REF(H,BARSLAST(A=GT 1)));

JJ:=HH-LL;

TJ:=ABS(GT-DT);

PT:=TJ/2 MIN(GT,DT);

PJ:=(HH LL)/2;

LJ:=HH*LL;

BT:=2*LJ/TJ;

BJ:=LJ/JJ;

TJA:=IF(A<PT,PT-A,A-PT)*BT;

TJB:=IF(TJA<LJ,SQRT(LJ*LJ-TJA*TJA),0)/BJ;

XH:IF(DT<GT,PJ TJB,PJ-TJB),COLORMAGENTA;

SH:IF(DT<GT,PJ-TJB,PJ TJB),COLORMAGENTA;

XG1:=COUNT(CROSS(C,SH),T1 1)=1 AND CROSS(C,SH) AND A<DT;

TB:=A=ROUND((GT DT)/2);

ZF:=(REF(C,T1)-REF(C,T2 1))/REF(C,T2 1)*100;

DRAWTEXT(TB,AA,VARCAT(VARCAT('下滑:',VAR2STR(CONST(ZF),2)),'%')),COLORGREEN;

DRAWTEXT(A=DT-1,SH*1.02,VARCAT(VARCAT('提升价:',VAR2STR(SH,2)),'元')),COLORYELLOW;

STICKLINE(XG1,L,H,0,0),COLOR0088EE;

STICKLINE(XG1,CLOSE,OPEN,3,0),COLOR0055AA;

STICKLINE(XG1,CLOSE,OPEN,2.8,0),COLOR0066BB;

STICKLINE(XG1,CLOSE,OPEN,2.5,0),COLOR0077CC;

STICKLINE(XG1,CLOSE,OPEN,2.2,0),COLOR0088DD;

STICKLINE(XG1,CLOSE,OPEN,1.7,0),COLOR0099EE;

STICKLINE(XG1,CLOSE,OPEN,1.2,0),COLOR00AAFF;

STICKLINE(XG1,CLOSE,OPEN,0.7,0),COLOR00CCFF;

STICKLINE(XG1,CLOSE,OPEN,0.2,0),COLOR00FFFF;

{

选股公式:

A:=CURRBARSCOUNT;

HA:=IF(BETWEEN(DATE,1150601,1150630),H,-999);

T:=HHVBARS(HA,0);

TT:=BARSLAST(L=LLV(L,T 1));

T1:=BARSLAST(A=CONST(TT) 1);

T2:=BARSLAST(A=CONST(T) 1);

GT:=CONST(T2) 1;

DT:=CONST(T1) 1;

AA:=DRAWLINE(A=GT,H,A=DT,L,0);

HH:=CONST(REF(L,BARSLAST(A=DT 1)));

LL:=CONST(REF(H,BARSLAST(A=GT 1)));

JJ:=HH-LL;

TJ:=ABS(GT-DT);

PT:=TJ/2 MIN(GT,DT);

PJ:=(HH LL)/2;

LJ:=HH*LL;

BT:=2*LJ/TJ;

BJ:=LJ/JJ;

TJA:=IF(A<PT,PT-A,A-PT)*BT;

TJB:=IF(TJA<LJ,SQRT(LJ*LJ-TJA*TJA),0)/BJ;

SH:=IF(DT<GT,PJ-TJB,PJ TJB);

XG:COUNT(CROSS(C,SH),T1 1)=1 AND CROSS(C,SH) AND A<DT;

}

通达信五圆弧主图及选股指标公式

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号