广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信积背离指标公式

  • 牛股公式
  • 2020-09-18 18:15
  • 牛股网
广告管理-720PX*80PX

SHORT:=12;

LONG:=26;

MID:=9;

M:=3;

DIFF : EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

DEA : EMA(DIFF,M);

MACD : 2*(DIFF-DEA), COLORSTICK;

JC := DEA-DIFF;

绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);

绿柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);

此次最低价位:=LLV(L,BARSLAST(JC<0));

此次最高成交价:=HHV(H,BARSLAST(JC>0));

X1:=IF (MACD<0,BARSLAST(CROSS(DIFF,DEA)),0);

上次绿柱面积:=REF(绿柱面积,X1 1);

上次最低价位:=REF(此次最低价位,X1 1);

Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(上次绿柱面积)

AND 此次最低价位<上次最低价位 ),1,0);

RS1:= MACD<0 AND REF(MACD,1)<0 AND C<上次最低价位

AND ABS(绿柱面积)<ABS(上次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

底背驰:= IF (CROSS(DIFF,DEA),REF(Y1,1),0);

DRAWTEXT(底背驰,0.3,'积底背'),COLOR00FFFF;

STICKLINE(底背驰,0,0.3,4,0),COLOR0000FF;

DRAWICON(底背驰,0,23),COLORYELLOW;

DRAWBAND(DIFF,RGB(200,50,55),DEA,RGB(50,100,10));

遵:IF(DIFF>=DEA,DIFF,DRAWNULL),COLORRED;

守:IF(DEA>=DIFF,DEA,DRAWNULL),COLORFF9900;

纪:IF(DIFF>=DEA,DEA,DRAWNULL),COLOR00FFFF;

律:IF(DEA>=DIFF,DIFF,DRAWNULL),COLOR00FF00;

X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIFF)),0);

上次绿柱面积:=REF(绿柱面积,X2 1);

上次最高成交价:=REF(此次最高成交价,X2 1);

Y2:=IF((绿柱面积>0 AND 绿柱面积<上次绿柱面积 AND 此次最高成交价>上次最高成交价 ),1,0);

RS2:= MACD>0 AND REF(MACD,1)>0 AND C>上次最高成交价 AND ABS(绿柱面积)<ABS(上次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

顶背驰:= IF (CROSS(DEA,DIFF),REF(Y2,1),0);

DRAWICON(顶背驰,0,19),COLOR00FF00;

STICKLINE(顶背驰,0,-0.3,4,0),COLOR00FF00;

DRAWTEXT(顶背驰,-0.3,'积顶背'),COLORFF0000;

通达信积背离指标公式

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号