广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信公式基本信息淘宝主图指标公式

  • 牛股公式
  • 2020-09-18 18:09
  • 牛股网
广告管理-720PX*80PX

{基本信息}

品种种类:=FINANCE(3);

隶属板块:=HYBLOCK;

发售日数:=FINANCE(42);

股总的市值:=ROUND(FINANCE(41)/100000000);

流通股本:=ROUND(FINANCE(40)/100000000);

每股收益:=FINANCE(8);

平均持仓:=ROUND(FINANCE(7)/FINANCE(8));

{}

DRAWTEXT_FIX(1,0.008,0.01,0,'基本信息:'),COLORFFCC99;

DRAWTEXT_FIX(1,0.008,0.05,0,'品种种类:'),COLOR99CCFF;

DRAWTEXT_FIX(1,0.008,0.09,0,'领域板块:'),COLOR99CCFF;

DRAWTEXT_FIX(1,0.008,0.13,0,'发售日数:'),COLOR99CCFF;

DRAWTEXT_FIX(1,0.008,0.17,0,'每股收益:'),COLOR99CCFF;

DRAWTEXT_FIX(1,0.008,0.21,0,'平均持仓:'),COLOR99CCFF;

{}

DRAWTEXT_FIX(品种种类=1,0.055,0.05,0,'沪 深 A 股'),COLORYELLOW;

DRAWTEXT_FIX(品种种类=2,0.055,0.05,0,' 中 小 板'),COLORYELLOW;

DRAWTEXT_FIX(品种种类=3,0.055,0.05,0,' 创 业 板'),COLORYELLOW;

DRAWTEXT_FIX(1,0.055,0.09,0,HYBLOCK),COLORYELLOW;{领域板块}

{标值}

DRAWNUMBER_FIX(1,0.050,0.13,0,发售日数),COLORGREEN;

DRAWNUMBER_FIX(1,0.050,0.17,0,每股收益),COLORGREEN;

DRAWNUMBER_FIX(1,0.050,0.21,0,平均持仓),COLORGREEN;

{企业}

DRAWTEXT_FIX(1,0.08,0.13,0,'天'),COLORWHITE;

DRAWTEXT_FIX(1,0.08,0.17,0,'人'),COLORWHITE;

DRAWTEXT_FIX(1,0.08,0.21,0,'股'),COLORWHITE;

{隶属板块}

DRAWTEXT_FIX(1,0.008,0.25,0,'地域板块:')COLOR99CCFF;

DRAWTEXT_FIX(1,0.048,0.25,0,DYBLOCK)COLORGREEN;

DRAWTEXT_FIX(1,0.088,0.25,0,'定义板块:')COLOR99CCFF;

DRAWTEXT_FIX(1,0.128,0.25,0,GNBLOCK)COLORGREEN;

DRAWTEXT_FIX(1,0.008,0.29,0,'设计风格板块:')COLOR99CCFF;

DRAWTEXT_FIX(1,0.048,0.29,0,FGBLOCK)COLORGREEN;

盈利主力资金:IF(WINNER(CLOSE),WINNER(CLOSE)*100,0),NODRAW,COLOR0080FF;

净资产:FINANCE(34),NODRAW,COLORRED;

个人公积金:FINANCE(18),NODRAW,COLORGREEN;

未分盈利:FINANCE(32),NODRAW,COLORMAGENTA;

净资回报率:=STRCAT('净资回报率: ',CON2STR(FINANCE(29)/FINANCE(19)*100,2));

每股净资产:=STRCAT(' 每股净资产: ',CON2STR(FINANCE(38),2));

主营业务毛利率:=STRCAT(' 主营业务毛利率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));

当今销售业绩:=STRCAT(' ',STRCAT(STRCAT(净资回报率,每股净资产),主营业务毛利率));

DRAWTEXT_FIX(ISLASTBAR,0.62,1.2,0,当今销售业绩),COLORRED;{淘宝主图显示信息}

盈利提高:FINANCE(43),COLORYELLOW,NODRAW;开幅:100*(O/REF(C,1)-1),COLORYELLOW,NODRAW;

箱顶:HHV(MA((LOW HIGH CLOSE O)/4,5),58),DOTLINE,COLORCYAN,LINETHICK1;

N3:=60;

B3:=EMA(C,3);

B4:=SMA(SMA(B3,2,1),2,1);

LLV(EMA(B4,1),N3),DOTLINE,COLORCYAN,LINETHICK1;

F:EMA(CLOSE,21),COLORRED,LINETHICK2;

IF(F>REF(F,1),F,DRAWNULL),LINETHICK2,COLORRED;

IF(F<REF(F,1),F,DRAWNULL),LINETHICK2,COLORGREEN;

网13:EXPMA(CLOSE,13),COLORGRAY,LINETHICK1;

{黄金分割点}

M:=13;

顶1:=REFDATE(HHV(H,M),DATE);

底1:=REFDATE(LLV(L,M),DATE);

H1:=顶1-(顶1-底1)*0.191;

H2:=顶1-(顶1-底1)*0.382;

H3:=顶1-(顶1-底1)*0.5;

H4:=顶1-(顶1-底1)*0.618;

H5:=顶1-(顶1-底1)*0.809;

顶端:REFDATE(顶1,DATE),COLOR666666;

.8:REFDATE(H1,DATE),COLOR666666;

8.2:REFDATE(H2,DATE),COLOR666666;

P:REFDATE(H3,DATE),COLOR666666;

a.8:REFDATE(H4,DATE),COLOR666666;

?.9:REFDATE(H5,DATE),COLOR666666;

底端:REFDATE(底1,DATE),COLOR666666;

DRAWTEXT(ISLASTBAR,顶端,' 顶端'),COLORGREEN;

DRAWTEXT(ISLASTBAR,.8,' 19.8%'),COLORMAGENTA;

DRAWTEXT(ISLASTBAR,8.2,' 38.2%'),COLORYELLOW;

DRAWTEXT(ISLASTBAR,P,' 50%'),COLORWHITE;

DRAWTEXT(ISLASTBAR,a.8,' 61.8%'),COLORYELLOW;

DRAWTEXT(ISLASTBAR,?.9,' 80.9%'),COLORMAGENTA;

DRAWTEXT(ISLASTBAR,底端,' 底端'),COLORRED;

{BS标示}

DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))

AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,7);

DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2))

AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.02,8);

{壳体}

{

箱顶:PEAK(CLOSE,N,1)*0.98,POINTDOT,LINETHICK3,COLORYELLOW;

底箱:TROUGH(CLOSE,N,1)*1.02,POINTDOT,LINETHICK3,COLORFFFF00;

箱高:100*(箱顶-底箱)/底箱,NODRAW;

};

总金额:=AMOUNT;

买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));

买%:=买/AMOUNT*100;

注入:=AMOUNT*买%/10000000000;

排出:=AMOUNT/100000000-注入;

净流:=(注入-排出);

总金额3:=SUM(AMOUNT,3);

注入3:=SUM(注入,3);

排出3:=SUM(排出,3);

净流3:=SUM(注入-排出,3);

总金额5:=SUM(AMOUNT,5);

注入5:=SUM(注入,5);

排出5:=SUM(排出,5);

净流5:=SUM(注入-排出,5);

总金额10:=SUM(AMOUNT,10);

注入10:=SUM(注入,10);

排出10:=SUM(排出,10);

净流10:=SUM(注入-排出,10);

画:=CONST(FINDHIGH(总金额10,0,190,1));

DRAWTEXT_FIX(1,0.71,0.07,0,'净流(亿):'),COLORMAGENTA,LINETHICK1;

DRAWTEXT_FIX(1,0.78,0.05,0,'2日'),COLORMAGENTA,LINETHICK1;

DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLORMAGENTA,LINETHICK1;

DRAWTEXT_FIX(1,0.88,0.05,0,'五日'),COLORMAGENTA,LINETHICK1;

DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLORMAGENTA,LINETHICK1;

DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;

DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELL OW;

DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;

DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);MA5:=MA(C,5);MA10:=MA(C,10);MA30:=MA(C,30);

FA:=BARSLAST(CROSS(MA10,MA5))

AND CROSS(MA5,MA10);

FB:=FA AND MA5>MA30 AND MA10>MA30 AND

MA10>REF(MA10,1);

{过左峰提示粉色}

VAR121:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

VAR141:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

VAR161:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

VAR181:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

卖:=(VAR121+VAR141+VAR161+VAR181),LINETHICK2;SQ:DRAWLINE(卖,H,BARSLAST(卖)>=1,REF(H,BARSLAST(卖)),1),COLORWHITE,LINETHICK2;

过峰:=C>SQ AND REF(C,1)<SQ;

VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;

预量:=VVOL/REF(V,1)>1.8;

现量:=V/REF(V,1)>1.5;

过峰1:STICKLINE( 过峰,C,O,5,0)COLORFF00FF;

预量1:DRAWICON(过峰 AND 预量, H*1.01,14);

现量1:DRAWICON(过峰 AND 现量,(O+C)/2,23);

前次低点:LLV(L*1,250)POINTDOT,COLORFF00FF,LINETHICK4;

通达信基本资料主图指标公式

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号