广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信公式MACD运用淘宝主图指标公式

  • 牛股公式
  • 2020-09-18 18:01
  • 牛股网
广告管理-720PX*80PX

看顶端:=0;

超短线:=0;

看红柱高矮:=0;

红色主升:=1;

基础数据信息:=0;

DRAWTEXT_FIX(1,0.00,0.10,0,'调节主要参数看顶端');

超大1:=EMA(CLOSE,300)-EMA(CLOSE,650);

红色1:=EMA(超大1,225);

白超过红:BARSLAST(超大1<REF(红色1,1)),COLORWHITE,NODRAW;

{---------主升区:关键选股指标,有一个就可以了-----};

中2:=EMA(CLOSE,50)-EMA(CLOSE,130),COLORBROWN;

DYO:=IF(中2>0,0.3,DRAWNULL);{显示信息}

主升:BARSLAST(DYO=DRAWNULL),COLORLIRED,NODRAW;

红周期时间:BARSLAST(红色1<REF(红色1,1)),COLORRED,NODRAW;

{-----之上为了更好地排列指标值在前面显示信息---------下列显示信息指标值线-----------------------};

超大型线:EMA(CLOSE,300)-EMA(CLOSE,650),COLORWHITE,LINETHICK2;

红色线:EMA(超大型线,225),COLORRED,LINETHICK2;

S1:=EMA(CLOSE,150)-EMA(CLOSE,320);

深蓝色:EMA(S1,90),COLORBLUE,LINETHICK1;

初级:EMA(CLOSE,50)-EMA(CLOSE,130),COLORBROWN;

翠绿色:EMA(初级,45),COLORGREEN;

{=====================================================================}

VARA1:=IF(红色线<0,超大型线<红色线,DRAWNULL);

间距:IF(BARSLAST(VARA1)>0,0-红色线,0),COLORYELLOW,LINETHICK1;{仅作赏析}

VART2:=(EMA(CLOSE,6)-EMA(CLOSE,13));

稍短:IF(VART2<-0.8,-0.8,VART2)*超短线,COLORLICYAN;

{日均线 MACD指标值 快手}

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:看红柱高矮*IF((DIF-DEA)*2>0,(DIF-DEA)*2,0),COLORSTICK;

MACD快手:IF(DIF<-1,-1,DIF)*看顶端,COLOR854C82;

极小值:=MIN(超大型线,MIN(红色线,MIN(深蓝色,MIN(初级,翠绿色))));

{中心线区:IF((VAR1>0)/直线,REF(极小值,VAR1),DRAWNULL),COLORLIRED,LINETHICK2;}

主升区:IF(主升/红色主升,REF(红色线,主升),DRAWNULL),COLORLIRED,LINETHICK4;

{OOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO};

{下列数据信息通达信公式早已认证}

{发售时间:REF(DATE,BARSSINCE(C)),NODRAW;{指标值栏显示信息}

{买卖日数:BARSSINCE(C) 1,NODRAW;{指标值栏显示信息, 追随电脑鼠标变化}

{指定对话框部位显示信息[发售时间],[工作日]日数,[股票交易时间]日数 }

A1Q:=FINANCE(42);

A2Q:=DATETODAY(CONST(DATE));

A3Q:=A2Q-A1Q;

A4Q:=DAYTODATE(A3Q) 19000000,NODRAW;{求发售时间}

发售的时间:=STRCAT(CON2STR(HHV((BARSCOUNT(C)=0)*(DATE 19000000),0),0),STRCAT(' 发售时间: ',CON2STR(A4Q,0)));

发售日数:=STRCAT(STRCAT(' 工作日: ',CON2STR(FINANCE(42),0)),'天');

股票交易时间:=STRCAT(STRCAT('[买卖日数]: ',CON2STR(BARSSINCE(C),0)),'天 收拢K线准');

显示信息:=STRCAT(STRCAT(发售的时间,发售日数),股票交易时间);

DRAWTEXT_FIX(基础数据信息*C>0,0.00,0.00,0,显示信息),COLORLIGRAY;

{发售时间前后左右数据信息有时候有一些偏差, 工作日数据信息精确,股票交易时间日数大周期时间收拢K线精确}

{----------------------------------------------------------------------------}

{通达信指标中显示信息时间日期指标公式 显示信息股票交易时间最终一根K线的时间日期礼拜数据信息}

N8:=STRCAT(CON2STR(YEAR,0),' 年 ');

Y8:=STRCAT(CON2STR(MONTH,0),' 月 ');

R8:=STRCAT(CON2STR(DAY,0),' 日 ');

R9:=STRCAT(CON2STR(WEEKDAY,0),' ');

RA:=STRCAT(STRCAT('【',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日'))))))),'】');

SJ9:=STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(N8,Y8),R8),' 礼拜 '),R9),RA);

DRAWTEXT_FIX(基础数据信息*C>0,0.425,0.00,0,SJ9),COLORGREEN;

通达信MACD应用主图指标公式

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号