广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信公式牛气操盘淘宝主图指标公式

  • 牛股公式
  • 2020-09-18 17:57
  • 牛股网
广告管理-720PX*80PX

{红绿带}

快线:=EMA(EMA(EMA(EMA(CLOSE,2),2),2),2),LINETHICK2,COLOR0000FF;

慢线:=EMA(REF(快线,1),2),LINETHICK2,COLOR00FFFF;

DRAWBAND(快线,RGB(500,280,180),慢线,RGB(256,200,0));

套牢盘%:=100*(1-WINNER(C));

获利比例%:=100*WINNER(C);

成本90%:=COST(90);

成本70%:=COST(70);

销售市场成本:=COST(50);

主要成本:=COST(10);

短期内工作压力:=HHV(H,15);

短期内支撑点:=LLV(L,20);

DRAWTEXT_FIX(C>0,0.005 ,0.22,0,'【获利比例%】:'),COLORRED;

DRAWTEXT_FIX(C>0,0.105,0.22,0,'【套牢盘%】:'),COLOR00FF00;

DRAWTEXT_FIX(C>0,0.21,0.22,0,'【销售市场成本】:'),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.315,0.22,0,'【主要成本】:'),COLOR008FFF;

DRAWTEXT_FIX(C>0,0.005,0.27,0,'【90%成本】:'),COLORFFFFBF;

DRAWTEXT_FIX(C>0,0.105,0.27,0,'【70%成本】:'),COLORF0F000;

DRAWTEXT_FIX(C>0,0.21,0.27,0,'【 换 手 】:'),COLORLIRED;

DRAWTEXT_FIX(C>0,0.315,0.27,0,'【 量 比 】:'),COLORYELLOW;

DRAWTEXT_FIX(C>0,0.005,0.32,0,'【短期内工作压力】:'),COLORWHITE;

DRAWTEXT_FIX(C>0,0.105,0.32,0,'【短期内支撑点】:'),COLORYELLOW;

DRAWNUMBER_FIX(C>0,0.075,0.22,0,CONST(获利比例%)),COLORRED;

DRAWNUMBER_FIX(C>0,0.175,0.22,0,CONST(套牢盘%)),COLOR00FF00;

DRAWNUMBER_FIX(C>0,0.28,0.22,0,CONST(销售市场成本)),COLORYELLOW;

DRAWNUMBER_FIX(C>0,0.385,0.22,0,CONST(主要成本)),COLOR008FFF;

DRAWNUMBER_FIX(C>0,0.075,0.27,0,CONST(成本90%)),COLORFFFFBF;

DRAWNUMBER_FIX(C>0,0.175,0.27,0,CONST(成本70%)),COLORF0F000;

DRAWNUMBER_FIX(C>0,0.28,0.27,0,CONST(DYNAINFO(37)*100)),COLORLIRED;

DRAWNUMBER_FIX(C>0,0.385,0.27,0,CONST(DYNAINFO(17))),COLORYELLOW;

DRAWNUMBER_FIX(C>0,0.075,0.32,0,CONST(短期内工作压力)),COLORWHITE;

DRAWNUMBER_FIX(C>0,0.175,0.32,0,CONST(短期内支撑点)),COLORYELLOW;

X11:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;

X12:=(FINANCE(31) FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积替代};

X13:=FINANCE(23)/FINANCE(10)*3.3;

X14:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}

X15:=FINANCE(20)/FINANCE(15)*0.999;

Z值:=X11 X12 X13 X14 X15;

DRAWTEXT_FIX(Z值<1.2,0.65,0,1,' 【●会计重警●】'),COLORLIRED;

DRAWTEXT_FIX( BETWEEN(Z值,1.2,2.6),0.65,0,1,' 【○会计轻警○】'),COLOR0099FF;

DRAWTEXT_FIX(Z值>2.6,0.65,0,1,' 【◎会计无警◎】'),COLORLIGREEN;

{平均价}

M5:MA(C,5),COLORYELLOW,LINETHICK2;

M10:MA(C,10),NODRAW;

M20:MA(C,20),COLORWHITE,LINETHICK2;

M60:MA(C,60),NODRAW;

M240:MA(C,60),COLORLIBLUE,CIRCLEDOT;

{跌涨停价钱}

警告:=NAMEINCLUDE('S');

股票涨停价:ZTPRICE(REF(C,1),IF(警告,0.05,0.1)),NODRAW,COLORYELLOW;

跌停价:DTPRICE(REF(C,1),IF(警告,0.05,0.1)),NODRAW,COLORGREEN;

明股票涨停:IF(警告=1,ZTPRICE(C,0.05),ZTPRICE(C,0.1)),NODRAW,COLORYELLOW;

明股票跌停:IF(警告=1,DTPRICE(C,0.05),DTPRICE(C,0.1)),NODRAW,COLORGREEN;

{画线}

VAR1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);

VAR2:=CROSS(VAR1,0.9) AND CURRBARSCOUNT<=10;

VAR3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);

VAR4:=CROSS(VAR3,0.9) AND CURRBARSCOUNT<=10;

STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2)),REF(HIGH,BARSLAST(VAR2)),2,1),COLORGREEN,LINETHICK1;

STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4)),REF(LOW,BARSLAST(VAR4)),2,1),COLORRED,LINETHICK4;

T:=HHVBARS(H,4);

TT:=IF(T=0,REF(T,T 1) T 1,T);

TA:=LLVBARS(L,3);

TTA:=IF(TA=0,REF(TA,TA 1) TA 1,TA);

T1:=HHVBARS(H,10);

TT1:=IF(T1=0,REF(T1,T1 1) T1 1,T1);

HX1:=CURRBARSCOUNT=CONST(TTA 1),NODRAW;

三日支撑点:DRAWLINE(HX1,L,ISLASTBAR,CONST(REF(L,TTA)),0),COLORYELLOW,DOTLINE,LINETHICK1;

TA1:=LLVBARS(L,10);

TTA1:=IF(TA1=0,REF(TA1,TA1 1) TA1 1,TA1);

十日支撑点:DRAWLINE(CURRBARSCOUNT=CONST(TTA1 1),L,ISLASTBAR,CONST(REF(L,TTA1)),0),COLORYELLOW,DOTLINE,LINETHICK1;

十日工作压力:DRAWLINE(CURRBARSCOUNT=CONST(TT 1),H,ISLASTBAR,CONST(REF(H,TT)),0),COLORGREEN,DOTLINE,LINETHICK1;

QA:=REF(H,10)=HHV(H,2*10 1);

QB:=BACKSET(QA,10 1);

QC:=FILTER(QB,10) AND H=HHV(H,10 1);

QD:=BARSLAST(QC);

QE:=IF(QC,CURRBARSCOUNT,0);

QF:=IF(QD,REF(QE,QD),QE);

QG:=CONST(QF);

QH:=REF(QF,QD 1);

QW:=CONST(QH);

区段工作压力:DRAWLINE(CURRBARSCOUNT=QG,H,ISLASTBAR,REF(H,QG-1),1),COLORGREEN,DOTLINE,LINETHICK1;

QA1:=REF(L,8)=LLV(L,2*8 1);

QB1:=BACKSET(QA1,8 1);

QC1:=FILTER(QB1,8) AND L=LLV(L,8 1);

QD1:=BARSLAST(QC1);

QE1:=IF(QC1,CURRBARSCOUNT,0);

QF1:=IF(QD1,REF(L,QD1),L);

QG1:=IF(QD1,REF(QE1,QD1),QE1);

QH1:=CONST(QG1);

QW1:=REF(QF1,QD1 1);

QM1:=REF(QG1,QD1 1);

QR1:=CONST(QM1);

股票短线支撑点:DRAWLINE(CURRBARSCOUNT=QH1,L,ISLASTBAR,REF(L,QH1-1),1),COLORRED,DOTLINE,LINETHICK1;

服务平台支撑点:DRAWLINE(CURRBARSCOUNT=QR1,L,ISLASTBAR,REF(L,QR1-1),1),COLORRED,DOTLINE,LINETHICK1;

{破走线}

EMA(EMA(C,5),5),COLORGREEN;

EMA(EMA(EMA(C,5),5),5),COLORGREEN;

EMA(EMA(EMA(EMA(C,5),5),5),5),COLORGREEN;

EMA(EMA(EMA(EMA(EMA(C,5),5),5),5),5),COLORGREEN;

IF(EMA(EMA(C,5),5)>REF(EMA(EMA(C,5),5),1),EMA(EMA(C,5),5),DRAWNULL),COLORRED;{ X}

IF(EMA(EMA(EMA(C,5),5),5)>REF(EMA(EMA(EMA(C,5),5),5),1),EMA(EMA(EMA(C,5),5),5),DRAWNULL),COLORRED;

IF(EMA(EMA(EMA(EMA(C,5),5),5),5)>REF(EMA(EMA(EMA(EMA(C,5),5),5),5),1),EMA(EMA(EMA(EMA(C,5),5),5),5),DRAWNULL),COLORRED;

IF(EMA(EMA(EMA(EMA(EMA(C,5),5),5),5),5)>REF(EMA(EMA(EMA(EMA(EMA(C,5),5),5),5),5),1),EMA(EMA(EMA(EMA(EMA(C,5),5),5),5),5),DRAWNULL),COLORRED;

{蓝}

STICKLINE(OPEN>CLOSE,CLOSE,OPEN,3,0),COLORFF7700;

STICKLINE(OPEN>CLOSE,CLOSE,OPEN,2.2,0),COLORFF9900;

STICKLINE(OPEN>CLOSE,CLOSE,OPEN,1.5,0),COLORFFBB00;

{红}

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR000099;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.2,0),COLOR0000CC;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.5,0),COLOR0000FF;

{十字星}

STICKLINE(CLOSE=OPEN,CLOSE,OPEN,3,0),COLORWHITE;

STICKLINE(CLOSE=OPEN,CLOSE,OPEN,2.2,0),COLORWHITE;

STICKLINE(CLOSE=OPEN,CLOSE,OPEN,1.5,0),COLORWHITE;

STICKLINE(CLOSE=OPEN,CLOSE,OPEN,0.5,0),COLORWHITE;

{大阳}

大阳:=C/REF(C,1)>=1.05 AND NOT(C>=INTPART(REF(C,1)*(1.1)*100)/100) AND C>O;

STICKLINE(大阳,CLOSE,OPEN,4,-1),COLORLIRED;

STICKLINE(大阳,CLOSE,OPEN,3,-1),COLORYELLOW;

STICKLINE(大阳,OPEN,CLOSE,2.5,0),COLORRED;

STICKLINE(大阳,OPEN,CLOSE,1,0),COLORMAGENTA;

{大阴}

大阴:=REF(C,1)/C<=1.099 AND REF(C,1)/C>=1.05 AND C<O;

STICKLINE(大阴,CLOSE,OPEN,4,-1),COLORGREEN;

STICKLINE(大阴,CLOSE,OPEN,3,-1),COLORFF9900;

STICKLINE(大阴,OPEN,CLOSE,2.5,0),COLORFFBB00;

STICKLINE(大阴,OPEN,CLOSE,1,0),COLORCYAN;

STG:=NAMELIKE('S') OR NAMELIKE('*');

{涨停}

涨停:=(C/REF(C,1)>=1.095 AND C=H) OR (C/REF(C,1)>=1.09 AND C=O AND O=L AND H=L) OR (C/REF(C,1)>=1.048 AND STG=1 AND C=H) OR (C/REF(C,1)>=1.045 AND C=O AND O=L AND H=L AND STG=1);

STICKLINE(涨停,CLOSE,OPEN,4,-1),COLORYELLOW;

STICKLINE(涨停,OPEN,CLOSE,3.5,0),COLORRED;

STICKLINE(涨停,O,C,2.5,1),COLOR007FFF;

STICKLINE(涨停,OPEN,CLOSE,1,0),COLORYELLOW;

{跌停}

跌停:=(REF(C,1)/C>=1.095 AND C=L) OR (REF(C,1)/C>=1.09 AND C=O AND O=L AND H=L) OR (REF(C,1)/C>=1.048 AND STG=1 AND C=L) OR (REF(C,1)/C>=1.045 AND C=O AND O=L AND H=L AND STG=1);

STICKLINE(跌停,CLOSE,OPEN,4,-1),COLORGREEN;

STICKLINE(跌停,OPEN,CLOSE,3.5,0),COLORBLUE;

STICKLINE(跌停,O,C,2.5,1),COLORLICYAN;

STICKLINE(跌停,OPEN,CLOSE,1,0),COLORGREEN;

STICKLINE(CLOSE>OPEN AND H/C>=1.03,H,C,0,0),COLORBROWN,LINETHICK2;

STICKLINE(CLOSE>OPEN AND O/L>=1.03,O,L,0,0),COLORYELLOW,LINETHICK2;

STICKLINE(CLOSE<OPEN AND H/O>=1.03,H,O,0,0),COLORBROWN,LINETHICK2;

STICKLINE(CLOSE<OPEN AND C/L>=1.03,C,L,0,0),COLORYELLOW,LINETHICK2;

{SKDJ}

LOWV:=LLV(LOW,90);

HIGHV:=HHV(HIGH,90);

RSV:=EMA((CLOSE-LOWV)/(HIGHV-LOWV)*100,3);

K:=EMA(RSV,3);

D:=MA(K,3);

DRAWICON(CROSS(K,D),L*0.98,7);

DRAWICON(CROSS(D,K),H*1.02,8);

{主升}

DRAWTEXT("KDJ.J"-REF("KDJ.J",1)>30 AND C/REF(C,1)>1.043

AND EXPMA(C,12)>EXPMA(C,50),L*0.95,'主升'),COLORYELLOW;

通达信牛气看盘主图指标公式

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号