广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

做下K线全自动画线公式

  • 牛股公式
  • 2020-09-15 08:47
  • 牛股网
广告管理-720PX*80PX

撰写标准:

撰写方式:网民寻求帮助:

请教师做下K线画线公式,谢谢!!自己公式小白确实没法写成。

公式标准:

日K线:

1.某一日上涨幅度超过N%;

2.以N的收盘价、收盘价-5%,各画一条水平线A、B,水平线不断5日;

3.如5日内的K线,若有K线最低价位跌破B线,则该K线为空心绿线;若有K线最高成交价提升A线,则该K线为空心红杠;

4.假如5日内一根K线既跌破B又提升A,则为空心紫线;

之上标准4假如不太好搞,可以不解决;

解释以下:

N:=7;

ZD:=C/REF(C,1)*100-100;

T:=BARSLAST(ZD>=N);

A:=COUNT(L<REF(C,T)*0.95,T 1)>=1 AND T>=1 AND T<=5;{绿线}

B:=COUNT(H>REF(C,T),T 1)>=1 AND T>=1 AND T<=5;{红杠}

D:=A=0 AND B=0 AND T>=1 AND T<=5;{紫线}

STICKLINE(C>0 AND T<=5,REF(C,T),REF(C,T),3,0),COLORWHITE;

STICKLINE(A,REF(C,T),REF(C,T),3,0),COLORBLUE;

STICKLINE(B,REF(C,T),REF(C,T),3,0),COLORRED;

STICKLINE(D,REF(C,T),REF(C,T),3,0),COLORMAGENTA;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号