广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

全自动测算邻近几段的下挫幅度之比

  • 牛股公式
  • 2020-09-18 11:23
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式:网民求助:

编码:

INPUT:室内空间周期时间(226,0,9999999),底顶精准定位(9,0,100);

精确测量時间:=DATACOUNT-SYSPARAM(1) 1,LINETHICK0;

DRAWTEXTEX(DATACOUNT<>SYSPARAM(1),1,10,160,'精确测量時间:' NUMTOSTR(精确测量時间,0)),Coloryellow;

AA:=ZIG(4,底顶精准定位);

PARTLINE(AA ,AA),,LINEdot,color888888;

tj:=AA>REF(AA,1) and AA>REFX(AA,1);

tj1:=AA<REF(AA,1) and AA<REFX(AA,1);

高些值:=PEAK(4,底顶精准定位,1);

底点值:=TROUGH(4,底顶精准定位,1);

MM0:=(高些值-底点值);

MM1:=(高些值-底点值);

xzz:=BARSLAST(datacount-BARPOS=室内空间周期时间);

DRAWNUMBER(TJ AND xzz>=0,高些值*1.003,MM0,2),ALIGN1,pxup16,coloryellow;

DRAWNUMBER(TJ1 AND xzz>=0,底点值*0.997,MM1,2),ALIGN1,pxdn8,color00ffcc;

1、请教师帮助健全一下编程代码,完成全自动测算;

2、如果能立即做下选股公式,考虑:图上几段下挫幅度之比在0.618——0.667,更强。

 

解释以下:

邻近几段的下挫务必后底比前底低,前底也是最低

别的标准你自己改

INPUT:室内空间周期时间(226,0,9999999),底顶精准定位(9,0,100);

精确测量時间:=DATACOUNT-SYSPARAM(1) 1,LINETHICK0;

DRAWTEXTEX(DATACOUNT<>SYSPARAM(1),1,10,160,'精确测量時间:' NUMTOSTR(精确测量時间,0)),Coloryellow;

AA:=ZIG(4,底顶精准定位);

PARTLINE(AA ,AA),,LINEdot,color888888;

tj:=AA>REF(AA,1) and AA>REFX(AA,1);

tj1:=AA<REF(AA,1) and AA<REFX(AA,1);

高些值:=PEAK(4,底顶精准定位,1);

底点值:=TROUGH(4,底顶精准定位,1);

MM0:=(高些值-底点值);

MM1:=(高些值-底点值);

FD:MM0/MM1,linethick0;

xzz:=BARSLAST(datacount-BARPOS=室内空间周期时间);

DRAWNUMBER(TJ AND xzz>=0,高些值*1.003,MM0,2),ALIGN1,pxup16,coloryellow;

DRAWNUMBER(TJ1 AND xzz>=0,底点值*0.997,MM1,2),ALIGN1,pxdn8,color00ffcc;

D0:=BARSLAST(底点值<>REF(底点值,1));

D1:=REF(底点值-REF(底点值,1),D0);

D2:=REF(D1,D0 1);

D3:=D0=0 AND D2<0 AND D1<0;{}

D4:=REF(MM0,D0);

下挫幅度比:D3*D4/REF(D4,1),LINETHICK0;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号