广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

将新MACD改成大智慧能用超跌选股

  • 牛股公式
  • 2020-09-15 08:15
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式:网民求助:

{由MACD精准定位顶底}

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

KX:=BARSSINCE(CLOSE);{←初次开盘价格距金的日数}

HHN:=CONST(HHV(DIFF,KX));

HLN:=CONST(LLV(DEA,KX));

RC1:=CONST((HHN HLN)/2);

SS:=((HHN-HLN)/200);

MACD底端:=(-100*SS RC1) -(-100*SS RC1),COLOR669999;

MACD顶端:=(100*SS RC1) -(-100*SS RC1),COLORFF0033;

MACD后轴:=0 -(-100*SS RC1);

DIFF调整 :=DIFF -(-100*SS RC1),COLOR008080;

DEA调整 :=DEA -(-100*SS RC1),COLOR00FF00;

MACD调整 :=2*(DIFF调整 -DEA调整 ) MACD后轴,COLOR0000BB,NODRAW;

MACD超跌:=CONST(LLV(MACD调整 ,KX));

MACD超跌线:=IF(MACD超跌<MACD底端,MACD超跌,MACD底端);

{运用MACD发展趋势开展精准顶底分辨}

顶端:=MACD顶端 -MACD超跌线;

长空:=顶端*0.809;

后轴:=MACD后轴 -MACD超跌线;

海平面:=顶端*0.191;

底端:=MACD底端;

{MACD多头空头量比分辨}

MACD双头:DIFF调整 -MACD超跌线,COLOR339999;

什么是空头:DEA调整 -MACD超跌线,COLOR00FF00;

量比柱:2*(MACD双头-什么是空头) 后轴,COLOR0000BB,NODRAW;

超前的DEA:=(EMA(MACD双头,7));

超前的MACD:=2*(MACD双头-超前的DEA) 后轴;

{聚集成本费提升指标值筹码峰划线}

MACD多头空头发展趋势:DRAWBAND(MACD双头,RGB(204,51,51),什么是空头,RGB(0,179,0));

MACD双头重绘:DRAWBAND(MACD双头,RGB(153,153,51),MACD双头,RGB(153,153,51));

MACD什么是空头重绘:DRAWBAND(什么是空头,RGB(0,204,0),什么是空头,RGB(0,204,0));

{中心线重绘及顶端线,城市天际线,海平面线,底端线,多空线文字描述}

中心线:DRAWBAND(后轴,RGB(128,128,255),后轴,RGB(128,128,255));

顶端线文本:DRAWTEXT(CURRBARSCOUNT=1,顶端*0.98,' 顶端线'),COLORFF0033;

城市天际线文本:DRAWTEXT(CURRBARSCOUNT=1,长空*0.98,' 城市天际线'),COLOR404080;

海平面线文本:DRAWTEXT(CURRBARSCOUNT=1,海平面,' 海平面线'),COLOR999900;

底端线文本:DRAWTEXT(CURRBARSCOUNT=1,底端,' 底端线'),COLOR669999;

中心线文本:DRAWTEXT(CURRBARSCOUNT=1,后轴,' 多空线'),COLORFF8080;

解释以下:

{由MACD精准定位顶底}

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

KX:=BARSSINCE(CLOSE);{←初次开盘价格距金的日数}

HHN:=(HHV(DIFF,KX));

HLN:=(LLV(DEA,KX));

RC1:=((HHN HLN)/2);

SS:=((HHN-HLN)/200);

MACD底端:(-100*SS RC1) -(-100*SS RC1),COLOR669999;

MACD顶端:(100*SS RC1) -(-100*SS RC1),COLORFF0033;

MACD后轴:0 -(-100*SS RC1);

DIFF调整 :DIFF -(-100*SS RC1),COLOR008080;

DEA调整 :DEA -(-100*SS RC1),COLOR00FF00;

MACD调整 :2*(DIFF调整 -DEA调整 ) MACD后轴,COLOR0000BB,LINETHICK0;

MACD超跌:(LLV(MACD调整 ,KX));

MACD超跌线:=IF(MACD超跌<MACD底端,MACD超跌,MACD底端);

{运用MACD发展趋势开展精准顶底分辨}

顶端:=MACD顶端 -MACD超跌线;

长空:=顶端*0.809;

后轴:=MACD后轴 -MACD超跌线;

海平面:=顶端*0.191;

底端:=MACD底端;

{MACD多头空头量比分辨}

MACD双头:DIFF调整 -MACD超跌线,COLOR339999;

什么是空头:DEA调整 -MACD超跌线,COLOR00FF00;

量比柱:2*(MACD双头-什么是空头) 后轴,COLOR0000BB,LINETHICK0;

超前的DEA:=(EMA(MACD双头,7));

超前的MACD:=2*(MACD双头-超前的DEA) 后轴;

FILLRGN(MACD双头,什么是空头,MACD双头>什么是空头,RGB(204,51,51),MACD双头<什么是空头,RGB(0,179,0));

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号