广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

来自大庆市老杨老师(看大做小)股票相匹配指数值难题

  • 牛股公式
  • 2020-09-18 11:23
  • 牛股网
广告管理-720PX*80PX

撰写标准:

撰写方式:网民寻求帮助:

最先谢谢大庆市老徐 教师的甘于奉献,传出(看大做小)指标源码:

趋势高低:MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20,COLORSTICK;

股票趋势:3*SMA((C-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100,20,1)-2*SMA(SMA((C-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100,20,1),15,1);

股票大盘趋势:3*SMA((INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34))*100,20,1)-2*SMA(SMA((INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34))*100,20,1),15,1);

股票大盘风险:FILLRGN(股票大盘趋势>80,股票大盘趋势,80);

股票风险:FILLRGN(股票趋势>80,股票趋势,80);

持币:PARTLINE(股票趋势<ref(股票趋势,1),股票趋势),LINETHICK2,colorffff00;

持仓:PARTLINE(股票趋势>ref(股票趋势,1)and 股票大盘趋势>ref(股票大盘趋势,1),股票趋势),LINETHICK2,colorred;

预警信息:STICKLINE(CROSS(股票大盘趋势,股票趋势)and 股票趋势<3 or LONGCROSS(股票趋势,0,3),0,20,6,0),COLORRED;

木地板价:IF(COUNT(股票趋势<0,3)=3 AND 股票趋势>ref(股票趋势,1),10,0),COLORFF0000,LINETHICK2;

应用所述指标值时,我发现了中小板股票和创业板股票的指数值,INDEX都用了深证的指数值,显示信息的并并不是创业板股票和中小板股票的真正指数值,以至指标值数据信号有误。

我搜了些材料,发觉上证指数,深证,中小板股票,创业板股票等指数值,应当用以下的语句表达较为恰当。

上盘:3*SMA(("1A0001$CLOSE"-LLV("1A0001$LOW",34))/(HHV("1A0001$HIGH",34)-LLV("1A0001$LOW",34))*100,20,1)-2*SMA(SMA(("1A0001$CLOSE"-LLV("1A0001$LOW",34))/(HHV("1A0001$HIGH",34)-LLV("1A0001$LOW",34))*100,20,1),15,1);

深盘:3*SMA(("399001$CLOSE"-LLV("399001$LOW",34))/(HHV("399001$HIGH",34)-LLV("399001$LOW",34))*100,20,1)-2*SMA(SMA(("399001$CLOSE"-LLV("399001$LOW",34))/(HHV("399001$HIGH",34)-LLV("399001$LOW",34))*100,20,1),15,1);

中局:3*SMA(("399005$CLOSE"-LLV("399005$LOW",34))/(HHV("399005$HIGH",34)-LLV("399005$LOW",34))*100,20,1)-2*SMA(SMA(("399005$CLOSE"-LLV("399005$LOW",34))/(HHV("399005$HIGH",34)-LLV("399005$LOW",34))*100,20,1),15,1);

创盘:3*SMA(("399006$CLOSE"-LLV("399006$LOW",34))/(HHV("399006$HIGH",34)-LLV("399006$LOW",34))*100,20,1)-2*SMA(SMA(("399006$CLOSE"-LLV("399006$LOW",34))/(HHV("399006$HIGH",34)-LLV("399006$LOW",34))*100,20,1),15,1);

 

解释以下:

B:=IF(STKTYPE=1,INTPART(STRTONUM(STKLABEL)/1000),-1);

A1:=STKINDI('1A0001','KDJ.J(34,20,15)',0,-1);

A2:=STKINDI('399001','KDJ.J(34,20,15)',0,-1);

A3:=STKINDI('399005','KDJ.J(34,20,15)',0,-1);

A4:=STKINDI('399005','KDJ.J(34,20,15)',0,-1);

AA:=IF(B=300,A4,IF(B=2,A3,IF(B=0 OR B=1,A2,IF(B=600 OR B=601,A1,0))));

趋势高低:MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20,COLORSTICK;

股票趋势:3*SMA((C-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100,20,1)-2*SMA(SMA((C-LLV(L,34))/(HHV(H,34)-LLV(L,34))*100,20,1),15,1);

股票大盘趋势:AA;

股票大盘风险:FILLRGN(股票大盘趋势>80,股票大盘趋势,80);

股票风险:FILLRGN(股票趋势>80,股票趋势,80);

持币:PARTLINE(股票趋势<ref(股票趋势,1),股票趋势),LINETHICK2,colorffff00;

持仓:PARTLINE(股票趋势>ref(股票趋势,1)and 股票大盘趋势>ref(股票大盘趋势,1),股票趋势),LINETHICK2,colorred;

预警信息:STICKLINE(CROSS(股票大盘趋势,股票趋势)and 股票趋势<3 or LONGCROSS(股票趋势,0,3),0,20,6,0),COLORRED;

木地板价:IF(COUNT(股票趋势<0,3)=3 AND 股票趋势>ref(股票趋势,1),10,0),COLORFF0000,LINETHICK2;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号