广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

“金叉MACD”改成大智慧的预警公式

  • 牛股公式
  • 2020-09-18 09:25
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式:网民求助:

依据下边的公式,在出現“低金”时,立即开展盘里的预警,那样的预警公式怎么写啊!

金叉MACD

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;

STICKLINE(MACD<0,MACD,0,4,1),COLORWHITE;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,4,0 ),COLOR00AAFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,3.3,0 ),COLOR00BBFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),COLOR00CCFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.65,0 ),COLOR00DDFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1.1,0 ),COLOR00EEFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.55,0 ),COLOR00FFFF;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,4 ,0 ),COLOR0000AA;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3.3 ,0 ),COLOR0011BB;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),COLOR0022CC;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.65 ,0 ),COLOR0033DD;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1 ,0 ),COLOR0044EE;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.55 ,0 ),COLOR0055FF;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORAA00BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3.3 ,0 ),COLORBB11BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),COLORCC22BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.65,0 ),COLORDD33BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLOREE44BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.55 ,0 ),COLORFF55BB;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,4,0 ),COLORFFAA00;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3.3 ,0 ),COLORFFBB11;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2.2,0 ),COLORFFCC22;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.65 ,0 ),COLORFFDD33;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1.1 ,0 ),COLORFFEE44;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.55 ,0 ),COLORFFFF55;

IF(DIFF<0,DIFF,0),COLORRED,LINETHICK1;

IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK1;

IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;

IF(DIFF>DEA,DEA,DEA),COLORWHITE,LINETHICK1;

↑底位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

STICKLINE(↑底位金叉,0,-0.5,2,0),COLORYELLOW;

DRAWTEXT(↑底位金叉,-0.4,' ↑底位金叉'),COLORYELLOW;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

↑二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(↑二次金叉,0,-0.2,5,0),COLORFF00FF;

DRAWICON(↑二次金叉,DEA*1.2,11) ;

DRAWTEXT(↑二次金叉,-0.2,' ↑二次金叉'),COLORFF00FF;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

↑底背离:=REF(CLOSE,A1 1)>CLOSE AND DIFF>REF(DIFF,A1 1) AND CROSS(DIFF,DEA);

STICKLINE(↑底背离,0,0.2,3,0),COLOR00FF00;

DRAWLINE(A1=0,DEA,↑底背离,DEA,0),COLORRED,LINETHICK2;

DRAWTEXT(↑底背离,0.2,' ↑底背离'),COLOR00FF00;

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

↑顶背离:=REF(CLOSE,A2 1)<CLOSE AND REF(DIFF,A2 1)>DIFF AND CROSS(DEA,DIFF);

 

 

解释以下:

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

底位金叉:CROSS(DIFF,DEA) AND DIFF<-0.1;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号