广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把唐奇安通道做成大智慧的

  • 牛股公式
  • 2020-09-05 17:00
  • 牛股网
广告管理-720PX*80PX

编写标准:请教师把唐奇安通道做成大智慧的,感谢

{唐奇安通道}

{N:=20;T:=10;}

M1:MA(C,N);

HPB:=REF(HHV(H,N),1);

LPB:=REF(LLV(L,T),1);

{双头交易}

BUYIN:=H>HPB AND C>M1;

BUYEXIT:=L

SINGAL:=IF(BUYIN,1,IF(BUYEXIT,-1,0));

CURRSIGN:=REF(SINGAL,BARSLAST(SINGAL));

UPTREND:=CURRSIGN= 1;

DWTREND:=CURRSIGN=-1;

{追踪股票止损}

空平:IF(DWTREND,HPB,DRAWNULL),COLORBLUE,LINETHICK2;

多止:IF(UPTREND,LPB,DRAWNULL),COLORRED,LINETHICK2;

数据信号不断:IF(DWTREND,BARSLAST(UPTREND),BARSLAST(DWTREND)),NODRAW,COLORMAGENTA;

DRAWICON(BARSLAST(DWTREND)=1,多止,7);

DRAWICON(BARSLAST(UPTREND)=1,空平,8);

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

编写方式:{唐奇安通道}

N:=20;T:=10;

M1:MA(C,N);

HPB:=REF(HHV(H,N),1);

LPB:=REF(LLV(L,T),1);

{双头交易}

BUYIN:=H>HPB AND C>M1;

BUYEXIT:=L<LPB;

SINGAL:=IF(BUYIN,1,IF(BUYEXIT,-1,0));

CURRSIGN:=REF(SINGAL,BARSLAST(SINGAL));

UPTREND:=CURRSIGN=1;

DWTREND:=CURRSIGN=-1;

{追踪股票止损};

空平:IF(DWTREND,HPB,0),COLORBLUE,LINETHICK0;

多止:IF(UPTREND,LPB,0),COLORRED,LINETHICK0;

PARTLINE(HPB,DWTREND),COLORBLUE,LINETHICK2;

PARTLINE(LPB,UPTREND),COLORRED,LINETHICK2;

DRAWTEXT(BARSLAST(DWTREND)=1,多止,'B'),COLORRED;

DRAWTEXT(BARSLAST(UPTREND)=1,空平*1.03,'S'),COLORGREEN;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号