广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

改动发展趋势转变指标值为通达信能用的

  • 牛股公式
  • 2020-09-14 08:39
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式:网民寻求帮助:

诸位好,请教师给改成通达信能用的

源代码:八荒线 AA:1 10 5 BB:1 100 15 M2:1 100 3 M22:1 100 8}

MID:=MA(CLOSE,20);

UPPER:=MID 2*STD(CLOSE,20);

LOWER:=MID-2*STD(CLOSE,20);

V1:=(CLOSE-LOWER)/(UPPER-LOWER)*100;

V2:=V1-EMA(V1,5);

K1:=SUM(LLV(V2,4),4)/4;

V3:=EMA(V2,64)*10;

V4:=EMA(0.4*V2*(-1),3);

V5:=-1*EMA(V2,39)*10;

A:=V3>10;

B:=V2>V4;

D:=V5>10;

E:=V3<=10 OR V2<=V4 OR V5<=10;

KS:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);

RKS:=REF(KS,1);

MLS:=RKS/KS>1.23 AND RKS>13 AND CLOSE/REF(CLOSE,1)>1.03;

开:=OPEN;

高:=HIGH;

低:=LOW;

收:=CLOSE;

STICKLINE(收>=开 AND E,高,低,0,0),COLORRED;

STICKLINE(收>=开 AND E,收,开,4,0),COLORRED;

STICKLINE(收< 开 AND E,高,低,0,0),COLOR00FF00;

STICKLINE(收< 开 AND E,收,开,4,0),COLOR00FF00;

STICKLINE(开> 收 AND A,低,高,0,0),COLORYELLOW;

STICKLINE(开> 收 AND A,收,开,4,0),COLORYELLOW;

STICKLINE(开<=收 AND A,低,高,0,0),COLORYELLOW;

STICKLINE(开<=收 AND A,收,开,4,1),COLORYELLOW;

STICKLINE(开> 收 AND B,低,高,0,0),COLORRED;

STICKLINE(开> 收 AND B,收,开,4,0),COLORRED;

STICKLINE(开<=收 AND B,低,高,0,0),COLORRED;

STICKLINE(开<=收 AND B,收,开,4,1),COLORRED;

STICKLINE(开> 收 AND D,低,高,0,0),COLORFFCC66;

STICKLINE(开> 收 AND D,收,开,4,0),COLORFFCC66;

STICKLINE(开<=收 AND D,低,高,0,0),COLORFFCC66;

STICKLINE(开<=收 AND D,收,开,4,1),COLORFFCC66;

超跌股:IF(KS>13,低,高),COLORWHITE,POINTDOT;

STICKLINE(KS>13,高,低,0,1),colorwhite,linethick2;

反跳:IF(MLS=1,高,低),COLORFF00FF,POINTDOT;

STICKLINE(MLS=1,高,低,0,1),colorff00ff,linethick2;

STICKLINE(KS>13,开,收,4,1),colorwhite,linethick2;

STICKLINE(MLS=1,开,收,4,1),colorff00ff,linethick2;

tj1:=SLOPE(EMA(CLOSE,2),aa)*bb CLOSE ;

s:=EMA(SLOPE(CLOSE,5)/REF(CLOSE,14),3)*302 ;

t1:=BARSLAST(CROSS(CLOSE,KS));

t2:=BARSLAST(CROSS(KS,CLOSE));

红跟入:IF(CLOSE>KS ,REF(CLOSE,t1),REF(CLOSE,t1)),COLORRED,POINTDOT;

STICKLINE(CLOSE>KS ,REF(CLOSE,t1),REF(CLOSE,t1),1,0),linethick6,colorred;

黄震仓:IF(CLOSE>KS and CLOSE<REF(CLOSE,t1),REF(CLOSE,t1),REF(CLOSE,t1)),COLORYELLOW,POINTDOT;

STICKLINE(CLOSE>KS and CLOSE<REF(CLOSE,t1),REF(CLOSE,t1),REF(CLOSE,t1),1,0),linethick6,coloryellow;

灰下挫:IF(CLOSE<KS,REF(CLOSE,t2),REF(CLOSE,t2)),COLORFFCC66,POINTDOT;

STICKLINE(CLOSE<KS,REF(CLOSE,t2),REF(CLOSE,t2),1,0),linethick6,COLORFFCC66;

鄂:REF(CLOSE,t1),linethick1,colorblue;

圆形:REF(CLOSE,t2),linethick1,colorwhite;()

解释以下:

AA:=5; BB:= 15; M2:= 3; M22:= 8;

MID:=MA(CLOSE,20);

UPPER:=MID 2*STD(CLOSE,20);

LOWER:=MID-2*STD(CLOSE,20);

V1:=(CLOSE-LOWER)/(UPPER-LOWER)*100;

V2:=V1-EMA(V1,5);

K1:=SUM(LLV(V2,4),4)/4;

V3:=EMA(V2,64)*10;

V4:=EMA(0.4*V2*(-1),3);

V5:=-1*EMA(V2,39)*10;

A:=V3>10;

B:=V2>V4;

D:=V5>10;

E:=V3<=10 OR V2<=V4 OR V5<=10;

KS:=(CLOSE-SMA(CLOSE,13,1))/SMA(CLOSE,13,1)*(-100);

RKS:=REF(KS,1);

MLS:=RKS/KS>1.23 AND RKS>13 AND CLOSE/REF(CLOSE,1)>1.03;

开:=OPEN;

高:=HIGH;

低:=LOW;

收:=CLOSE;

STICKLINE(收>=开 AND E,高,低,0,0),COLORRED;

STICKLINE(收>=开 AND E,收,开,4,0),COLORRED;

STICKLINE(收< 开 AND E,高,低,0,0),COLOR00FF00;

STICKLINE(收< 开 AND E,收,开,4,0),COLOR00FF00;

STICKLINE(开> 收 AND A,低,高,0,0),COLORYELLOW;

STICKLINE(开> 收 AND A,收,开,4,0),COLORYELLOW;

STICKLINE(开<=收 AND A,低,高,0,0),COLORYELLOW;

STICKLINE(开<=收 AND A,收,开,4,1),COLORYELLOW;

STICKLINE(开> 收 AND B,低,高,0,0),COLORRED;

STICKLINE(开> 收 AND B,收,开,4,0),COLORRED;

STICKLINE(开<=收 AND B,低,高,0,0),COLORRED;

STICKLINE(开<=收 AND B,收,开,4,1),COLORRED;

STICKLINE(开> 收 AND D,低,高,0,0),COLORFFCC66;

STICKLINE(开> 收 AND D,收,开,4,0),COLORFFCC66;

STICKLINE(开<=收 AND D,低,高,0,0),COLORFFCC66;

STICKLINE(开<=收 AND D,收,开,4,1),COLORFFCC66;

超跌股:IF(KS>13,低,高),COLORWHITE,POINTDOT;

STICKLINE(KS>13,高,低,0,1),COLORWHITE,LINETHICK2;

反跳:IF(MLS=1,高,低),COLORFF00FF,POINTDOT;

STICKLINE(MLS=1,高,低,0,1),COLORFF00FF,LINETHICK2;

STICKLINE(KS>13,开,收,4,1),COLORWHITE,LINETHICK2;

STICKLINE(MLS=1,开,收,4,1),COLORFF00FF,LINETHICK2;

TJ1:=SLOPE(EMA(CLOSE,2),AA)*BB CLOSE ;

S:=EMA(SLOPE(CLOSE,5)/REF(CLOSE,14),3)*302 ;

T1:=BARSLAST(CROSS(CLOSE,KS));

T2:=BARSLAST(CROSS(KS,CLOSE));

红跟入:IF(CLOSE>KS ,REF(CLOSE,T1),REF(CLOSE,T1)),COLORRED,POINTDOT;

STICKLINE(CLOSE>KS ,REF(CLOSE,T1),REF(CLOSE,T1),1,0),LINETHICK6,COLORRED;

黄震仓:IF(CLOSE>KS AND CLOSE<REF(CLOSE,T1),REF( CLOSE,T1),REF(CLOSE,T1)),COLORYELLOW,POINTDOT;

STICKLINE(CLOSE>KS AND CLOSE<REF(CLOSE,T1),REF(CLOSE,T1),REF(CLOSE,T1),1,0),LINETHICK6,COLORYELLOW;

灰下跌:IF(CLOSE<KS,REF(CLOSE,T2),REF(CLOSE,T2)),COLORFFCC66,POINTDOT;

STICKLINE(CLOSE<KS,REF(CLOSE,T2),REF(CLOSE,T2),1,0),LINETHICK6,COLORFFCC66;

鄂:REF(CLOSE,T1),LINETHICK1,COLORBLUE;

圆圈:REF(CLOSE,T2),LINETHICK1,COLORWHITE;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号