广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把这个涨停主图改为通达信公式的

  • 牛股公式
  • 2020-09-14 08:16
  • 牛股网
广告管理-720PX*80PX

撰写标准:这一主图通达信公式不过关,不便教师帮助修改。。。

源代码:

MA7:EMA(CLOSE,7);

M7:EMA(CLOSE,7);

MID:MA(CLOSE,20);

上轨:MID 2*STD(CLOSE,20),DOTLINE;

下轨:MID-2*STD(CLOSE,20),DOTLINE;

g1:=BARSLAST(CLOSE/REF(CLOSE,1)>=1.099);

g2:=ref(c,g1);

g3:=ref(o,g1);

HORILINE(g2 and g1<13,g2,20),LINETHICK2,COLORYELLOW;

HORILINE(g3 and g1<13,g3,20),LINETHICK2,COLORYELLOW;

涨停:=IF(REF(C,1)*1.1-C=1,1);

STICKLINE(涨停 AND COUNT(涨停,13)>=1,c,o,4.5,0),COLORYELLOW;

DRAWTEXT(涨停 AND COUNT(涨停,13)>=1,h*1.015,'涨'),COLORYELLOW,LINETHICK2;

DRAWTEXT(涨停 AND COUNT(涨停,13)>=1,h*1.028,'停'),COLORYELLOW;

V1:=v/ma(ref(v,1),5);V2:=indexv/ma(ref(indexv,1),5);v0:=v1/v2;

d4:=WINNER(c)*100;

s2:=WINNER(ref(c,1))*100;

d1:=oma7 and EMA(CLOSE,17)>ref(EMA(CLOSE,17),1) and hh;

DRAWTEXT(d1>0,l*0.98,'起动'),COLORYELLOW;

f1:=(d4>s2 20 or (cross(d4,86) and ref(d4,1)0 and c>ref(g2,1),l,'强悍'),COLORYELLOW;

DIFF1:=EMA(INDEXC,12)-EMA(INDEXC,26);

DEA1 :=EMA(DIFF1,9);

MACD1:=2*(DIFF1-DEA1);

大盘:MACD1-REF(MACD1,1),LINETHICK0;

DRAWFLAGTEXT(大盘>0,l,'大盘稳进'),COLORYELLOW,LINETHICK5;

DRAWFLAGTEXT(大盘<0,l,'大盘风险性'),DOTLINE,LINETHICK5;

撰写方式:MA7:EMA(CLOSE,7);

M7:EMA(CLOSE,7);

MID:MA(CLOSE,20);

上轨:MID 2*STD(CLOSE,20),DOTLINE;

下轨:MID-2*STD(CLOSE,20),DOTLINE;

G1:=BARSLAST(CLOSE/REF(CLOSE,1)>=1.099);

G2:IF(G1<20,REF(C,G1),DRAWNULL),COLORYELLOW;

G3:IF(G1<20,REF(O,G1),DRAWNULL),COLORYELLOW;

涨停:=IF(REF(C,1)*1.1-C<0.01 ,1,0);

HH:=REF(COUNT(涨停,13)>=1,1);

STICKLINE(涨停 AND COUNT(涨停,13)>=1,C,O,4.5,0),COLORYELLOW;

DRAWTEXT(涨停 AND COUNT(涨停,13)>=1,H*1.015,'涨'),COLORYELLOW,LINETHICK2;

DRAWTEXT(涨停 AND COUNT(涨停,13)>=1,H*1.028,'停'),COLORYELLOW;

D4:=WINNER(C)*100;

S2:=WINNER(REF(C,1))*100;

D1:=O<MA7 AND C>MA7 AND EMA(CLOSE,17)>REF(EMA(CLOSE,17),1) AND HH;

DRAWTEXT(D1>0,L*0.98,'起动'),COLORYELLOW;

F1:=(D4>S2 20 OR (CROSS(D4,86) AND REF(D4,1)<80)) AND HH;

DRAWTEXT(F1>0 AND C>REF(G2,1),L,'强悍'),COLORYELLOW;

DIFF1:=EMA(INDEXC,12)-EMA(INDEXC,26);

DEA1 :=EMA(DIFF1,9);

MACD1:=2*(DIFF1-DEA1);

大盘:MACD1-REF(MACD1,1),NODRAW;

DRAWTEXT(大盘>0,L,'大盘稳进'),COLORYELLOW,LINETHICK5;

DRAWTEXT(大盘<0,L,'大盘风险性'),DOTLINE,LINETHICK5;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号