广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

将“股票市场对策”里的“笑脸”编成选股公式

  • 牛股公式
  • 2020-09-14 08:10
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式:网友求助:

源代码:

STICKLINE(C>=O,C,O,3,0),COLOR0000AA;

STICKLINE(C>=O,C,O,2.5,0),COLOR0000BB ;

STICKLINE(C>=O,C,O,1.5,0),COLOR0000CC ;

STICKLINE(C>=O,C,O,1,0),COLOR0000EE;

STICKLINE(C>=O,H,L,0,0),COLOR0000FF;

STICKLINE(C<=O,C,O,3,0),COLOR7B7B00;

STICKLINE(C<=O,C,O,2.5,0),COLOR909000;

STICKLINE(C<=O,C,O,1.5,0),COLORA8A800;

STICKLINE(C<=O,C,O,1,0),COLORCECE00;

STICKLINE(C<=O,H,L,0,0),COLORFFFF00;

ZA1:=EMA(C,25);

ZA2:=EMA(ZA1,45);

ZB1:=EMA(C,65);

ZB2:=EMA(ZB1,45);

DIFF:=(ZA1 ZB2)/2;

DEA:=(ZA2 ZB1)/2;

KA0:=(HHV(C,45)-LLV(C,45))/45;

KA1:=SMA(C,3,1);

KA2:=SMA(C-KA0*3,3,1);

KA3:=SMA(KA1-KA0*3,3,1);

SC:=100*(CLOSE-MA(CLOSE,80));

SC1:=EMA(SC,5);

SC2:=EMA(SC,21);

长期性对策:SC1>=SC2,NODRAW;

次级线圈对策:DIFF>=DEA,NODRAW;

短期内对策:KA2>=KA3,NODRAW;

短期内转折点:REF(短期内对策,1)=0 AND 短期内对策=1,NODRAW;

趋势性:ZB2,COLORYELLOW,LINETHICK3;

次级线圈发展趋势:DIFF,NODRAW;

短期内发展趋势:KA2,NODRAW;

IF(DIFF>=DEA,DIFF,DRAWNULL),LINETHICK3,COLORRED;

IF(DIFF<DEA,DIFF,DRAWNULL),LINETHICK1,COLORBLUE;

IF(KA2>=KA3,KA2,DRAWNULL)COLORMAGENTA,LINETHICK3;

IF(KA2<KA3,KA2,DRAWNULL),LINETHICK1,COLORGREEN;

CSAR:=SAR(10,2,20);

持仓:=IF(CSAR<=L,CSAR,0);

涅磐:=EMA(SLOPE(C,21)*20 C,42);

班若:=EMA(C,5);

VAR1:=(C H O L)/4;

售出:=XMA(VAR1,20)*(1 8/1000);

买进:=XMA(VAR1,32)*(1-8/1000);

菩堤:=买进 (售出-买进)*2/3;{此涵数仅做参照线,为提早发展趋势预测分析线,增涨中途往下见顶,下挫中途往上见底};

提菩:=买进 (售出-买进)*1/2;

明心见性:=IF(班若>=REF(班若,1),班若,DRAWNULL);

双曲线转为:=CROSS(L,CSAR) AND 明心见性>0 AND H<菩堤 AND 持仓>0 AND H>涅磐;

DRAWICON(双曲线转为,(L),5);{发展趋势底};

般:=XMA(CLOSE,7);

若:=MEMA(CLOSE,3);

发展趋势拓宽:=短期内转折点 AND 菩堤>H AND NOT(双曲线转为);

DRAWICON(发展趋势拓宽,L,5);

DRAWICON(LONGCROSS(若,般,3) AND H>提菩,H,19);

DRAWICON(BARSLAST(LONGCROSS(若,般,3) AND H>提菩)=1,H,2);

请高手将“股票市场对策”里的“笑脸”编成选股公式,感谢!

解释以下:

KA0:=(HHV(C,45)-LLV(C,45))/45;

KA1:=SMA(C,3,1);

KA2:=SMA(C-KA0*3,3,1);

KA3:=SMA(KA1-KA0*3,3,1);

短期内对策:=KA2>=KA3;

短期内转折点:=REF(短期内对策,1)=0 AND 短期内对策=1;

CSAR:=SAR(10,2,20);

持仓:=IF(CSAR<=L,CSAR,0);

涅磐:=EMA(SLOPE(C,21)*20 C,42);

班若:=EMA(C,5);

VAR1:=(C H O L)/4;

售出:=XMA(VAR1,20)*(1 8/1000);

买进:=XMA(VAR1,32)*(1-8/1000);

菩堤:=买进 (售出-买进)*2/3;{此涵数仅做参照线,为提早发展趋势预测分析线,增涨中途往下见顶,下挫中途往上见底};

提菩:=买进 (售出-买进)*1/2;

明心见性:=IF(班若>=REF(班若,1),班若,DRAWNULL);

双曲线转为:=CROSS(L,CSAR) AND 明心见性>0 AND H<菩堤 AND 持仓>0 AND H>涅磐;

短期内转折点 AND 菩堤>H AND NOT(双曲线转为);

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号