广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

编写MA05均变为红线时的选股公式

  • 牛股公式
  • 2020-09-14 08:09
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式:网民求助:

请教师编写MA05移动平均线由黄色转变成“鲜红色”线时,编写一个选股公式。特别感谢!

MA05:MA(C,5)LINETHICK2,COLOR00CCFF;

MA10:=MA(C,10);

MA20:=MA(C,20);

MA30:=MA(C,30);

五日乖离率:=(C-MA05)/MA05*100;

BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;

速率5:=SMA(EMA((MA05-REF(MA05,1))/REF(MA05,1),3)*100,3,1);

瞬时速度5:=EMA((速率5-REF(速率5,1)),3),NODRAW;

IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK2,COLORRED;

BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;

IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK2,COLORGREEN;

三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;

VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);

VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);

BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;

强悍阻击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);

买入:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA05>REF(MA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)

AND 瞬时速度5>REF(瞬时速度5,1) AND 速率5>REF(速率5,1) ,10) ;

清仓处理:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>MA30 OR O>MA30) AND MA05<REF(MA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);

DRAWTEXT(买入 ,LOW*0.98,'↖买入'),COLORRED;

JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;

减持:=FILTER(JC,10);

MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA05>REF(MA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;

买进:=FILTER(MR,10);

DRAWTEXT(减持,HIGH*1.02,'←风险性'),COLORCYAN;

DRAWTEXT(买进,LOW*0.98,'↖买进'),COLORYELLOW;

DRAWTEXT(清仓处理 ,HIGH*1.02,'←清仓处理'),COLORGREEN;

DRAWTEXT(强悍阻击,LOW*0.98,'↖强悍阻击'),COLORYELLOW;

解释以下:

MA05:=MA(C,5)LINETHICK2,COLOR00CCFF;

BB05:=ATAN((MA05/REF(MA05,1)-1)*100)*180/3.1416;

XG:=BB05>30 AND MA05>REF(MA05,1);

变红线选择股票:REF(XG,1)<XG;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号