广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把{乖离}改为大智慧指标

  • 牛股公式
  • 2020-09-14 08:01
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式:网民寻求帮助:

请教师把{乖离}改为大智慧指标,感谢!

BIAS1:=(C-MA(C,6))/MA(C,6)*100;

BIAS2:=(C-MA(C,12))/MA(C,12)*100;

BIAS3:=(C-MA(C,24))/MA(C,24)*100;

BIAS:=(BIAS1 2*BIAS2 3*BIAS3)/6;

乖离: MA(BIAS,3),NODRAW;

STICKLINE(乖离<-6 AND 乖离>=-12,1,0,3,0),COLOR004C00;

STICKLINE(乖离<-12 AND 乖离>=-18,2,1,3,0),COLOR0099FF;

STICKLINE(乖离<-18 AND 乖离>=-30,3,2,3,0),COLOR33CCFF;

STICKLINE(乖离<-30,4,3,3,0),COLORRED;

DRAWTEXT(乖离<-30,3, 'B'), COLORWHITE;

DRAWTEXT(乖离<-30 AND ISLASTBAR,1, '长 买'), COLORWHITE;

解释以下:

BIAS1:=(C-MA(C,6))/MA(C,6)*100;

BIAS2:=(C-MA(C,12))/MA(C,12)*100;

BIAS3:=(C-MA(C,24))/MA(C,24)*100;

BIAS:=(BIAS1 2*BIAS2 3*BIAS3)/6;

乖离: MA(BIAS,3),LINETHICK0;

FILLRGN(0.1,0,乖离<-6 AND 乖离>=-12),COLOR33ccff;

FILLRGN(0.2,0,乖离<-12 AND 乖离>=-18),COLOR3300ff;

FILLRGN(0.3,0,乖离<-18 AND 乖离>=-30),COLOR00ccff;

FILLRGN(0.4,0.3,乖离<-30),colorred;

DRAWTEXT(乖离<-30,0.3, 'B'), colorwhite;

DRAWTEXT(乖离<-30 AND DISPSTATUS=2,0.1, '长 买'), colorwhite;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号