广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

通达信指标“理财专家”选股公式

  • 牛股公式
  • 2020-09-12 17:13
  • 牛股网
广告管理-720PX*80PX

撰写标准:请在“活筹”超过100时选择股票。先感谢老师了 。源代码以下:{主要参数 D:34,90,72}

VAR1:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VAR2:=2*ABS(VAR1);

VAR3:=100-3*SMA((CLOSE-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1) 2*SMA(SMA((CLOSE-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1),15,1);

VAR4:=100-3*SMA((OPEN-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1) 2*SMA(SMA((OPEN-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1),15,1);

VAR5:=(HIGH LOW CLOSE)/3;

VAR6:=(VAR5-MA(VAR5,14))/(0.015*AVEDEV(VAR5,14));

VAR7:=(VAR5-MA(VAR5,89))/(0.015*AVEDEV(VAR5,89));

VAR8:=IF(VAR6>=150 AND VAR6=150 AND VAR7<200,10,0);

VAR9:=IF(VAR6-200 AND VAR7-200,-10,VAR8);

VARA:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VARB:=100-ABS(VARA);

VARC:=3*SMA((INDEXC-LLV(INDEXL,D))/(HHV(INDEXH,D)-LLV(INDEXL,D))*100,20,1)-2*SMA(SMA

((INDEXC-LLV(INDEXL,D))/(HHV(INDEXH,D)-LLV(INDEXL,75))*100,20,1),15,1);

VARD:=3*SMA((INDEXO-LLV(INDEXL,D))/(HHV(INDEXH,D)-LLV(INDEXL,D))*100,20,1)-2*SMA(SMA

((INDEXO-LLV(INDEXL,D))/(HHV(INDEXH,D)-LLV(INDEXL,75))*100,20,1),15,1);

VARE:=REF(LOW,1)*0.9;

VARF:=LOW*0.9;

VAR10:=(VARF*VOL VARE*(CAPITAL-VOL))/CAPITAL;

VAR11:=EMA(VAR10,30);

VAR12:=VAR11-CLOSE;

VAR13:=REF(CLOSE,1);

VAR14:=SMA(MAX(CLOSE-VAR13,0),7,1)/SMA(ABS(CLOSE-VAR13),7,1)*100;

VAR15:=SMA(MAX(CLOSE-VAR13,0),13,1)/SMA(ABS(CLOSE-VAR13),13,1)*100;

VAR16:=BARSCOUNT(CLOSE);

VAR17:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100;

VAR18:=((-100)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60)) 50)*2;

VAR19:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

VAR1A:=(SMA(VAR19,4,1)-50)*2;

VAR1B:=SMA(VAR1A,3,1);

VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;

VAR1D:=SMA(VAR1C,4,1);

VAR1E:=SMA(VAR1D,3,1);

VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;

VAR20:=IF(VAR17<=25 AND VAR1820 AND VAR1B<-30 AND VAR1E=-0.25 AND VAR14<22 AND VAR1550,80,0);

活筹OAMV: VAR3,COLORFF00FF;

OX: IF(VARB0,VAR1,0);

核能发电: IF(VAR1=200 AND VAR6>=150,15,IF(VAR7<=-200 AND VAR60,1000*VAR26/VAR24,0),COLORRED,LINETHICK2;

STICKLINE(VAR3>=REF(VAR4,1),VAR3,VAR4,8,1),COLORRED;

STICKLINE(VAR3MA(CLOSE,20) AND MA(CLOSE,20)>=REF(MA(CLOSE,20),1);

VAR28:=CLOSE60 AND OX=100;

VAR2A:=VAR21>48 AND 预警信息>60 AND OX38 AND 预警信息50 AND OX<90;

VAR3D:=VAR3REF(VOL,1) AND CLOSE>REF(CLOSE,1);

VAR2E:=VAR3>=REF(VAR4,1) AND CLOSE=REF(核能发电,1) AND VARC

DRAWTEXT(VAR27 AND COUNT(VAR27,30)=1,90,'持仓待涨'),COLORFF00FF;

DRAWTEXT(VAR28 AND COUNT(VAR28,30)=1,10,'被淘汰为宜'),COLOR00FF00;

DRAWTEXT(VAR29 AND COUNT(VAR29,30)=1,70,'增涨过急,必须调节'),COLORWHITE;

DRAWTEXT(VAR2A AND COUNT(VAR2A,30)=1,80,'拉涨之际狂牛!'),COLORYELLOW;

DRAWTEXT(VAR2B AND COUNT(VAR2B,30)=1,20,'无须急跌有反跳 '),COLORWHITE;

DRAWTEXT(VAR2C AND COUNT(VAR2C,30)=1,30,'角斗士,环节底端 '),COLORYELLOW;

DRAWTEXT(VAR3D AND COUNT(VAR3D,30)=1,60,'大资产入场'),COLOR0099FF;

DRAWTEXT(VAR2E AND COUNT(VAR2E,30)=1,40,'高些下降'),COLORFFCC66;

撰写方式 :D:=72;

VAR3:100-3*SMA((CLOSE-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1) 2*SMA(SMA((CLOSE-LLV(LOW,D))/(HHV(HIGH,D)-LLV(LOW,D))*100,20,1),15,1)>100;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号