广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

(MACD改编)公式计算

  • 牛股公式
  • 2020-09-12 16:51
  • 牛股网
广告管理-720PX*80PX

编写标准:这是一个MACD的改编,可是显示信息不出柱型条,请高手改动

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA), COLORSTICK;

STICKLINE(MACD0,0,MACD,1,0),COLORGREEN;

STICKLINE(MACD

STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,1,0),COLORMAGENTA;

高低交界:0,COLORBLUE,LINETHICK2;

VAR11:=(2*CLOSE HIGH LOW)/4;

VAR22:=EMA(EMA(EMA(VAR11,4),4),4);

J:=(VAR22-REF(VAR22,1))/REF(VAR22,1)*5000;

D:=MA(J,3);

K:=MA(J,1);

J1:=J;

Z:D;

X:K;

编写方式 :DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA), COLORSTICK;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,1,0),COLORGREEN;

STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,1,0),COLORFFCC33;

STICKLINE(MACD>REF(MACD,1)AND MACD,0,MACD,1,0),COLORYELLOW;

STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,1,0),COLORMAGENTA;

高低交界:0,COLORBLUE,LINETHICK2;

VAR11:=(2*CLOSE HIGH LOW)/4;

VAR22:=EMA(EMA(EMA(VAR11,4),4),4);

J:=(VAR22-REF(VAR22,1))/REF(VAR22,1)*5000;

D:MA(J,3),NODRAW;

K:MA(J,1),NODRAW;

J1:=J;

Z:D/100;

X:K/100;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号