广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

KDJ RSI MACD指标值组成的副图源码

  • 牛股公式
  • 2020-09-12 08:41
  • 牛股网
广告管理-720PX*80PX

编写标准:最先感谢诸位高手教师的辛勤工作,你们辛苦了 。

近期见到有关KDJ RSI MACD指标值组成的文章内容,觉得非常好,便是沒有寻找源码,诸位高手教师如果有得话,不便给发一个,谢谢啦

编写方式:VAR2:=SMA(MAX(CLOSE-VAR1,0),7,1)/SMA(ABS(CLOSE-VAR1),7,1)*100;

尤其准:STICKLINE(FILTER(REF(VAR2,1)<20 AND VAR2>REF(VAR2,1),5),3,14,5,0),LINETHICK4,COLORRED;

有点儿准:STICKLINE(FILTER(REF(VAR2,1)<20 AND VAR2>REF(VAR2,1),5),14,27,3,0),LINETHICK3,COLORMAGENTA;

BIAS1:=(C-MA(C,6))/MA(C,6)*100;

BIAS2:=(C-MA(C,12))/MA(C,12)*100;

BIAS3:=(C-MA(C,24))/MA(C,24)*100;

BIAS:=(BIAS1 2*BIAS2 3*BIAS3)/6;

乖离:=MA(BIAS,3);

绿柱股票抄底:STICKLINE(CROSS(BIAS,乖离) AND 乖离<-9.5,27,40,1,0),COLOR00FFFF;

DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);

DEA:=EMA(DIFF,9),COLORFFFF00;

MACD:=(DIFF-DEA)*2;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

MACD底背离:STICKLINE(REF(CLOSE,A1 1)>CLOSE AND DIFF>REF(DIFF,A1 1) AND CROSS(DIFF,DEA),40,50,1,0),COLOR00FF00;

VAR6:=LLV(LOW,10);

VAR8:=HHV(HIGH,25);

减持线:=3.2 ;

售出线:=3.5;

驱动力线:=EMA((CLOSE-VAR6)/(VAR8-VAR6)*4,4);

清仓处理线:=EMA((CLOSE-VAR6)/(VAR8-VAR6)*5,5);

DRAWICON(CROSS(驱动力线,减持线),85,2);

DRAWTEXT(CROSS(驱动力线,减持线),85,'减持'),COLORBLUE;

DRAWICON(CROSS(售出线,驱动力线),90,35);

DRAWTEXT(CROSS(售出线,驱动力线),95,'减持'),COLORRED;

DRAWTEXT(CROSS(售出线,清仓处理线),100,'清仓处理'),COLOR00FF00;

VAR3:=PEAKBARS(3,15,1)<10;

VAR5:=IF(VAR3=1,2,0);

顶:= IF(VAR5=2,2,0);

顶A:IF(顶>REF(顶,1),50,0),COLORGREEN,LINETHICK3;

DRAWTEXT(顶A=50,60,'快'),COLORMAGENTA;

DRAWTEXT(顶A=50,50,'逃'),COLORRED;

DRAWTEXT(顶A=50,40,'顶'),COLORMAGENTA;

LC:=REF(CLOSE,1);

RSI6:SMA(MAX(CLOSE-LC,0),N,1)/SMA(ABS(CLOSE-LC),N,1)*100,COLORRED,LINETHICK1;

DRAWTEXT(RSI6>82,85,'减')COLOR00FF00;

DRAWTEXT(RSI6<12.8,6,'补')COLORYELLOW;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号