广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

给“牛熊背离”编写选股公式

  • 牛股公式
  • 2020-09-12 08:40
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式:网民求助:

牛熊背离指标源码:

N1:=5;

N2:=10;

N3:=21;

N4:=60;

牛熊:EMA(CLOSE,N4),COLORGREEN,LINETHICK3;

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIFF,8);

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

B1:=REF(C,A1 1)>C AND REF(DIFF,A1 1)<DIFF AND CROSS(DIFF,DEA);

DRAWTEXT(IF(B1>0,1,0),L-0.1,'MACD底背'),COLORGREEN;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

A2:=BARSLAST(REF(CROSS(K,D),1));

B2:=REF(C,A2 1)>C AND REF(K,A2 1)<K AND CROSS(K,D);

DRAWTEXT(IF(B2>0,1,0),L-0.25,'KDJ底背'),COLORYELLOW;

LC:=REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;

A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));

B3:=REF(C,A3 1)>C AND REF(RSI1,A3 1)<RSI1 AND CROSS(RSI1,RSI2);

DRAWTEXT(IF(B3>0,1,0),L-0.4,'RSI底背'),COLORBLUE;

C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));

D1:=REF(C,C1 1)<C AND REF(DIFF,C1 1)>DIFF AND CROSS(DEA,DIFF);

DRAWTEXT(IF(D1>0,1,0),H 0.1,'MACD顶背'),COLORWHITE;

C2:=BARSLAST(REF(CROSS(D,K),1));

D2:=REF(C,C2 1)<C AND REF(K,C2 1)>K AND CROSS(D,K);

DRAWTEXT(IF(D2>0,1,0),H 0.25,'KDJ顶背'),COLORWHITE;

C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));

D3:=REF(C,C3 1)<C AND REF(RSI1,C3 1)>RSI1 AND CROSS(RSI2,RSI1);

DRAWTEXT(IF(D3>0,1,0),H 0.4,'RSI顶背'),COLORYELLOW;

SG:EMA(HHV(H,1),8),COLORGRAY;

X1:EMA(CLOSE,N1),COLORYELLOW;

JJ:=(H L 3*C)/5;

请教师帮助改动成一个选股公式,标准设定:牛熊绿线在下挫发展趋势中,初次大于或等于昨日标值。而且股票价格在以前66个股票交易时间内经历高于或等于百分之二十5.18的上涨幅度的个股。

这一公式计算很有可能不便点,谢谢教师帮助了。

解释以下:

cross(ema(c,60),ref(ema(c,60),1)) and ref(count(c/ref(c,1)>=1.0518,66),1);

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号