广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把大智慧BS决策主图制成绿色版主图

  • 牛股公式
  • 2020-09-12 08:34
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式:网友求助:

源代码为:

a:="LTFunc4@FORLT2";

s1:="LTFunc4@LT_S1";

hs:="LTFunc4@LT_HS";

ls:="LTFunc4@LT_LS";

p1:="LTFunc4@LT_P1";

upp:="LTFunc4@LT_UPP";

udd:="LTFunc4@LT_UDD";

{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};

TODAY:=DYNAINFO(7)=CLOSE and DYNAINFO(10)=AMOUNT AND TIME0<55800;

AODAY:=bigorder(1,1)=0 and bigorder(2,1)=0;

VAR0:=MIN(COUNT(ORDER(2),0),P1);

ZDDR:=selfdata('股票大单买进');

ZDDC:=selfdata('股票大单售出');

ZDTR:=selfdata('超大买进');

ZDTC:=selfdata('超大售出');

SSTR:=IF(AODAY,"DDE@BIGORDER"(1,3),bigorder(1,3));

SSTC:=IF(AODAY,"DDE@BIGORDER"(2,3),bigorder(2,3));

SSDR:=IF(AODAY,("DDE@BIGORDER"(1,2)-"DDE@BIGORDER"(1,3)),(bigorder(1,2)-bigorder(1,3)));

SSDC:=IF(AODAY,("DDE@BIGORDER"(2,2)-"DDE@BIGORDER"(2,3)),(bigorder(2,2)-bigorder(2,3)));

SZDR:=IF(AODAY,ZDDR,(bigorder(1,2)-bigorder(1,3)));

SZDC:=IF(AODAY,ZDDC,(bigorder(2,2)-bigorder(2,3)));

SZTR:=IF(AODAY,ZDTR,bigorder(1,3));

SZTC:=IF(AODAY,ZDTC,bigorder(2,3));

DDLR:=IF(TODAY,IF(SSDR=0,SZDR,SSDR),SZDR);

DDLC:=IF(TODAY,IF(SSDC=0,SZDC,SSDC),SZDC);

TDLR:=IF(TODAY,IF(SSTR=0,SZTR,SSTR),SZTR);

TDLC:=IF(TODAY,IF(SSTC=0,SZTC,SSTC),SZTC);

ZLLR:=TDLR DDLR;

ZLLC:=TDLC DDLC;

ZLJL:=(ZLLR-ZLLC);

DDX:=ZLJL*vol/capital*100;

d1:=ema(abs(DDX),60);

d2:=max(DDX/d1 7.5,7.5);

d3:=min(DDX/d1,10);

fb:=if(s1=0,hs,ls);

tr0:=ifs(p1=1,'明天收盘价格<' numtostrn(udd,2) ',出現S点\ ','若明天收盘价格>' numtostrn(upp,2) ',出現B点\ ');

tr1:=ifs(s1=1,'明天收盘价格<' numtostrn(ls,2) ',股票短线售出机遇','若明天收盘价格>' numtostrn(hs,2) '股票短线买进机遇');

tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持仓'),ifs(cross(1,p1),'S点','持币'));

tr3:=ifs(s1=0,'往下,','往上,');

tr4:='3.动能级別:' numtostrn(d3,1) '级';

bs:='' datestr(date) 'macd背离决策提示信息\ ' '1.BS点:' tr2 ',' tr0 '2.股票短线:' tr3 tr1 '\ ' tr4;

drawflagtext(1,fb,bs);

STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;

STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;

STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;

STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;

STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;

STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;

STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;

STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;

STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;

STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;

STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;

drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;

drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;

drawbmp(s1=1 and ref(s1,1)=0 and (p1 ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;

drawbmp(s1=0 and ref(s1,1)=1 and (p1 ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;

zz:=(o h l)/3;

hjmd:EMA(zz,4),COLORYELLOW,LINETHICK1;

xxb:=CLOSE*VOL;

xxbym:EMA((EMA(xxb,3)/EMA(VOL,3) EMA(xxb,6)/EMA(VOL,6) EMA(xxb,12)/EMA(VOL,12) EMA(xxb,24)/EMA(VOL,24))/4,13),colorff00ff,LINETHICK0;

善心:=EMA(CLOSE,13)-EMA(CLOSE,55);

无价之宝:=EMA(善心,3);

PARTLINE(xxbym,善心>=无价之宝,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK3;

我只想要那二根线的图型,再求教师可否把粗线条为鲜红色段制成选择股票,不胜感激之者。

解释以下:

{主图}

zz:=(o h l)/3;

hjmd:EMA(zz,4),COLORYELLOW,LINETHICK1;

xxb:=CLOSE*VOL;

xxbym:EMA((EMA(xxb,3)/EMA(VOL,3) EMA(xxb,6)/EMA(VOL,6) EMA(xxb,12)/EMA(VOL,12) EMA(xxb,24)/EMA(VOL,24))/4,13),colorff00ff,LINETHICK0;

善心:=EMA(CLOSE,13)-EMA(CLOSE,55);

无价之宝:=EMA(善心,3);

PARTLINE(xxbym,善心>=无价之宝,RGB(255,0,0),1,RGB(0,255,0)),LINETHICK3;

======================

{一条线上的绿红段---便是小编的二根线吗?---只有那样猜了}

{红杠出現选择股票}

善心:=EMA(CLOSE,13)-EMA(CLOSE,55);

无价之宝:=EMA(善心,3);

CROSS(善心,无价之宝);

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号