广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

在(拉涨)二字处做一个同花顺一个小时预警信息买进公式计算

  • 牛股公式
  • 2020-09-11 16:13
  • 牛股网
广告管理-720PX*80PX

撰写标准:

撰写方式:网民寻求帮助:

附原码:

MID:=(3*CLOSE LOW OPEN HIGH)/6;

牛线:(20*MID 19*REF(MID,1) 18*REF(MID,2) 17*REF(MID,3) 16*REF(MID,4)

15*REF(MID,5) 14*REF(MID,6) 13*REF(MID,7) 12*REF(MID,8) 11*REF(MID,9)

10*REF(MID,10) 9*REF(MID,11) 8*REF(MID,12) 7*REF(MID,13) 6*REF(MID,14)

5*REF(MID,15) 4*REF(MID,16) 3*REF(MID,17)

2*REF(MID,18) REF(MID,20))/210,COLORRED;

马线:MA(牛线,6),COLORGREEN;

Var0:=SMA(MAX(CLOSE-ref(c,1),0),12,1)/SMA(ABS(CLOSE-ref(c,1)),15,1)*100;

DRAWTEXT(CROSS(82,Var0),high,'快卖'),colorwhite;

DRAWTEXTABS(10,10,STKLABEL ' ' STKNAME ' ' BKNAME),COLOR00FFFF;

s:=C-REF(C,1);

DX:=100*EMA(EMA(s,6),6)/EMA(EMA(ABS(s),6),6);

买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);

DRAWTEXT(filter(买=1,5),LOW-0.03,'拉涨'),ColorFFDE00;

da:=(EMA(C,1) EMA(C,2) EMA(C,3) EMA(C,4))/4;

db:=(EMA(C,10) EMA(C,20) EMA(C,40) EMA(C,80))/4;

DRAWTEXT(CROSS(da-db,0),L*0.95,'★B'),COLORRED;

JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;

DRAWTEXT(CROSS(84,JH),H*1.05,'☆S'),COLORGREEN;

YC:=REF(CLOSE,1);

止损价位:(YC*1.0035*97 0.2)/99.65,COLORRED,LINETHICK0;

DRAWTEXTABS(CLOSE,25,'★ ======================'),COLORRED;

DRAWTEXTABS(CLOSE,41,'操 '),COLORRED;

DRAWTEXTABS(CLOSE,57,'盘 '),COLORRED;

DRAWTEXTABS(CLOSE,73,'铁'),COLORRED;

DRAWTEXTABS(CLOSE,89,'律'),COLORRED;

DRAWTEXTABS(CLOSE,105,'★ ======================'),COLORRED;

DRAWTEXTABS(CLOSE,41,' 买进标准 E13 CCI'),colorYellow;

DRAWTEXTABS(CLOSE,57,' 买进時间 2:30之后' ),colorYellow;

DRAWTEXTABS(CLOSE,73,' 止损价位 ' NUMTOSTR(止损价位) '元'),colorYellow;

DRAWTEXTABS(CLOSE,89,' 网上:工作中 线下推广:歇息'),color00FFFF;

E:=(HIGH LOW OPEN 2*CLOSE)/5;

明天摩擦阻力:=2*E-LOW;

明天支撑点:=2*E-HIGH;

明天提升:=E (HIGH-LOW);

明天翻转:=E-(HIGH-LOW);

今天摩擦阻力:=REF(明天摩擦阻力 , 1);

今天支撑点:=REF(明天支撑点 , 1);

DRAWTEXTABS(200,25,'今天摩擦阻力=:' NUMTOSTR(今天摩擦阻力)),ColorFFFF00;

DRAWTEXTABS(200,41,'今天支撑点=:' NUMTOSTR(今天支撑点)),Colorred;

DRAWTEXTABS(200,57,'明天提升=:' NUMTOSTR(明天提升)),ColorFF00FF;

DRAWTEXTABS(200,73,'明天摩擦阻力=:' NUMTOSTR(明天摩擦阻力)),ColorFFFF00;

DRAWTEXTABS(200,89,'明天支撑点=:' NUMTOSTR(明天支撑点)),COLORRED;

DRAWTEXTABS(200,105,'明天翻转=:' NUMTOSTR(明天翻转)),COLORYellow;

A:=HHV(HIGH,13)=HIGH AND HIGH>REF(HIGH,1);A1:=FILTER(A,12);

B:=LLV(LOW,13)=LOW AND LOW<REF(LOW,1);B1:=FILTER(B,12);

TS1:=BARSLAST(A1);

箱顶:REF(HIGH,TS1) ,COLORFF00FF, LINETHICK0;

STICKLINE(1,箱顶,箱顶,7,0),COLORFF00FF;

TS2:=BARSLAST(B1);

底箱:REF(LOW,TS2) ,COLORFFbb80, LINETHICK0;

STICKLINE(1,底箱,底箱,7,0),COLORFFbb80;

箱高:100*(箱顶-底箱)/底箱,LINETHICK0;

平均价:=(3*C H L O)/6;

VAR1:=(8*平均价 7*REF(平均价,1) 6*REF(平均价,2) 5*REF(平均价,3)

4*REF(平均价,4) 3*REF(平均价,5) 2*REF(平均价,6) REF(平均价,8))/36;

VAR2:=(LLV(VAR1,2) LLV(VAR1,4) LLV(VAR1,6))/3;

SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1>VAR2 AND CLOSE>VAR1;

SZ2:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)

AND H/VAR1<1.1 AND L>VAR2 AND CLOSE>VAR1;

SZ3:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>=REF(VAR2,1) AND H/VAR1>1.1;

SZ4:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)

AND CLOSE>VAR2 AND CLOSE<VAR1;

SZ5:=(VAR1>VAR2 AND VAR2>REF(VAR2,1) AND VAR1<>REF(VAR1,1)

AND CLOSE<VAR2) OR (VAR1>VAR2 AND VAR1<REF(VAR1,1)

AND VAR2<REF(VAR2,1) AND CLOSE<VAR2);;

SZ6:=REF(VAR1,1)>REF(VAR2,1) AND VAR1=VAR2 AND CLOSE<VAR2;

XD1:=VAR1=VAR2 AND CLOSE<VAR2 OR (VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1)

AND REF(VAR1,1)=REF(VAR2,1) AND CLOSE<VAR2);

XD2:=VAR1=VAR2 AND CLOSE>VAR1;

SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));

量比对比度:=IF(SAT>1,1,SAT)*100;

IF BARSTATUS=2 AND SZ1 THEN BEGIN

DRAWTEXTABS(350,25,'调节完毕股票短线干预'),COLORRED;

END

ELSE

IF BARSTATUS=2 AND SZ2 THEN BEGIN

DRAWTEXTABS(350,25,'升高安全通道行情优良'),COLORRED;

END

ELSE

IF BARSTATUS=2 AND SZ3 THEN BEGIN

DRAWTEXTABS(350,25,'股票价格偏移留意调节'),COLORRED;

END

ELSE

IF BARSTATUS=2 AND SZ4 THEN BEGIN

DRAWTEXTABS(350,25,'升高安全通道调节震仓'),COLORGREEN;

END

ELSE

IF BARSTATUS=2 AND SZ5 THEN BEGIN

DRAWTEXTABS(350,25,'转为特点留意退场'),COLORGREEN;

END

ELSE

IF BARSTATUS=2 AND SZ6 THEN BEGIN

DRAWTEXTABS(350,25,'安全通道更改果断退场'),COLORGREEN;

END

ELSE

IF BARSTATUS=2 AND XD1 THEN BEGIN

DRAWTEXTABS(350,25,'下挫安全通道只宜犹豫'),COLORGREEN;

END

ELSE

IF BARSTATUS=2 AND XD2 THEN BEGIN

DRAWTEXTABS(350,25,'短期内底端提前准备进到'),COLORYELLOW;

END;

STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;

STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;

STICKLINE(OPEN& gt;=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;

STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff7700;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORff9900;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffbb00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffcc00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffdd00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORffee00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORffFF00;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000055;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000077;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000bb;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000dd;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000ff;

var9Q:=c= hhv(c,4)and (ref(c,1)>=ref(c,2) or ref(c,1)>=ref(c,3))

or ref(c,1)=hhv(c,4) and close>=ref(c,2) or ref(c,2)=hhv(c,4)

and ref(c,3)=llv(c,4) and c>=ref(c,1) or ref(c,3)=hhv(c,4)

and c>=ref(c,1) and c>=ref(c,2);

stickline(var9Q,c,(o+c)/2,7,0),color000055;

stickline(var9Q,c,(o+c)/2,6,0),color000066;

stickline(var9Q,c,(o+c)/2,5,0),color000077;

stickline(var9Q,c,(o+c)/2,4,0),color000099;

stickline(var9Q,c,(o+c)/2,3,0),color0000bb;

stickline(var9Q,c,(o+c)/2,2,0),color0000dd;

stickline(var9Q,c,(o+c)/2,1,0),color0000ff;

varaQ:=c=hhv(c,4) and ref(c,1)=llv(c,4);

stickline(varaQ,c,(o+c)/2,7,0),colorff11ff;

stickline(varaQ,c,(o+c)/2,6,0),colorff33ff;

stickline(varaQ,c,(o+c)/2,5,0),colorff55ff;

stickline(varaQ,c,(o+c)/2,4,0),colorff77ff;

stickline(varaQ,c,(o+c)/2,3,0),colorff99ff;

stickline(varaQ,c,(o+c)/2,2,0),colorffbbff;

stickline(varaQ,c,(o+c)/2,1,0),colorffddff;

varbQ:=c=llv(c,4) and (ref(c,1)<ref(c,2) or ref(c,1)<ref(c,3))

or ref(c,1)=llv(c,4) and c<ref(c,2) or ref(c,2)=llv(c,4)

and ref(c,1)<>hhv(c,4) and c<ref(c,1) or ref(c,3)=llv(c,4)

and c<ref(c,1) and c<ref(c,2);

stickline(varbQ,c,(o+c)/2,7,0),color333333;

stickline(varbQ,c,(o+c)/2,6,0),color555555;

stickline(varbQ,c,(o+c)/2,5,0),color777777;

stickline(varbQ,c,(o+c)/2,4,0),color999999;

stickline(varbQ,c,(o+c)/2,3,0),colorbbbbbb;

stickline(varbQ,c,(o+c)/2,2,0),colordddddd;

stickline(varbQ,c,(o+c)/2,1,0),colorffffff;

varcQ:=ref(c,1)=llv(c,4) and c>=ref(c,2) or ref(c,2)=llv(c,4)

and ref(c,1)<=ref(c,3) and ref(c,2)<ref(c,4) and c>=ref(c,1);

stickline(varcQ,o,(o+c)/2,7,0),color003300;

在(拉升)二字处做一个大智慧60分钟预警买入公式

在(拉升)二字处做一个大智慧60分钟预警买入公式

解答如下:

s:=C-REF(C,1);

DX:=100*EMA(EMA(s,6),6)/EMA(EMA(ABS(s),6),6);

买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);

filter(买=1,5);{分析周期:60分钟}

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号