广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把变色龙淘宝主图公式计算中的买制成选择股票

  • 牛股公式
  • 2020-09-11 08:28
  • 牛股网
广告管理-720PX*80PX

撰写标准:

撰写方式 :网民寻求帮助:

源代码为:

INPUT:M(10,1,30,1);

止盈止损线:(MA(CLOSE,M) * 1.15),Color0000FF;

分界点:(MA(CLOSE,M) * 1),COLORWHITE;

止损点:(MA(CLOSE,M) * 0.85),Color00FF80;

总股本:=FINANCE2(35) ;

股票市值:=FINANCE2(37);

限售A股:=FINANCE2(41);

每股收益:=FINANCE2(3);

市盈率:=DYNAINFO(39);

每股公积金:=FINANCE2(7);

隶属板块:=BKNAME;

DRAWTEXTABS(12,14, '隶属板块: ' 隶属板块),COLORYELLOW;

DRAWTEXTABS(12,27,'每股收益: ' NUMTOSTRN(每股收益,3) '元 盈利提高:' FINANCE2(10) '% 市盈率:' NUMTOSTRN(市盈率,1) '倍 ' ' 每股公积金:' NUMTOSTRN(每股公积金,2) '元'),COLORYELLOW;

DRAWTEXTABS(12,40,'总 股 本: ' NUMTOSTRN(总股本,2) '亿港元' ' 商品流通A股:' NUMTOSTRN(股票市值,2) '亿港元' ' 限售A股:' NUMTOSTRN(限售A股,2) '亿港元'),COLORYELLOW;

{17}

x9:FORCAST(c,9),Colorwhite,LINETHICK2;

llx:=llv(FORCAST(c,9),2);

DRAWGBKLAST(DYNAINFO(3)<DYNAINFO(7){OPEN},STRIP(RGB(0,150,0),RGB(150,0,0),1));

DRAWGBKLAST({CLOSE}DYNAINFO(3)>DYNAINFO(7){OPEN},STRIP(RGB(150,0,0),RGB(0,150,0),1));

DRAWTEXTREL(550,900,STKLABEL ' ' STKNAME ' ' DYNAINFO(7) '元' ' ' DYNAINFO(14)*100 '%'),LINETHICK4,COLORFFFF00;

PARTLINE(x9,x9=llx,rgb(255,205,0),x9<>llx,rgb(255,0,0)),linethick4;

{24}

{柱图}

STICKLINE(c>=o and o<>0,HIGH,LOW,0.5,0),color0000CD;

STICKLINE(c>=o and o<>0,CLOSE,OPEN,8,0),color070084;

STICKLINE(c>=o and o<>0,CLOSE,OPEN,7,0),color0000A3;

STICKLINE(c>=o and o<>0,CLOSE,OPEN,6,0),color0000B7;

STICKLINE(c>=o and o<>0,CLOSE,OPEN,5,0),color0000CD;

STICKLINE(c>=o and o<>0,CLOSE,OPEN,4,0),color0000E9;

STICKLINE(c>=o and o<>0,CLOSE,OPEN,2,0),color0754E9;

STICKLINE(c>=o and o<>0,CLOSE,OPEN,0.5,0),Color68B8FF;

STICKLINE(c<o and o<>0,HIGH,LOW,0.5,0),colorFFBE00;

STICKLINE(CLOSE<OPEN and OPEN<>0,HIGH,LOW,0.5,0),colorFFBE00;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,8,0),ColorCA6500;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,7,0),ColorE17100;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,6,0),ColorF27900;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,5,0),ColorFF850B;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,4,0),ColorFF9326;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,2,0),ColorFFA851;

STICKLINE(CLOSE<OPEN and OPEN<>0,CLOSE,OPEN,0.5,0),colorFFFF00;

{43}

DRAWGBK(c,'7' );

Var3:=LLV(H,240);

Var4:=100*(C-Var3)/Var3;

Var5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;

Var6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;

{Var7:=0;}

Var8:=MA(HHV(C-REF(C,1),0),34)/MA(ABS(C-REF(C,1)),7)*100;

Var9:=MA(HHV(C-REF(C,1),0),13)/MA(ABS(C-REF(C,1)),13)*100;

VarA:=BARSCOUNT(C);

VarB:=Var8<20 AND Var9<23 AND VarA>35;

VarC:=VarB AND COUNT(VarB,1)=1;

VarD:=EMA(C,21)-EMA(C,8);

VarE:=EMA(VarD,5);

VarF:=TROUGH(3,6,1)<4 AND CROSS(VarD,VarE);

Var10:=IF(TROUGH(3,16,1)=0 AND H>L 0.04,4,0);

Var11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

Var12:=ZIG(3,6)<REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);

Var13:=ZIG(3,22)>REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

Var14:=ZIG(3,22)<REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);

Var15:=ZIG(3,51)>REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

Var16:=ZIG(3,51)<REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2)AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);

Var17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

Var18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);

Var19:=EMA(C,2)-EMA(C,150);

Var1A:=EMA(Var19,100);

Var1B:=2*(Var19-Var1A);

Var1C:=POW(Var1B,3)*0.1 POW(Var1B,1);

Var1D:=SQRT(SQRT(L*H*O*C));

Var1E:=EMA(Var1D*0.97,3);

Var1F:=(H L C)/3;

Var20:=(Var1F-MA(Var1F,14))/(0.015*AVEDEV(Var1F,14));

Var21:=CROSS(Var1E,L);

买些1:=Var10;

买些2:=(Var11 Var13 Var15 Var17);

产品卖点1:=(Var12 Var14 Var16 Var18);

Var22:=买些1 AND VarF AND VarC AND Var21 AND Var4<0AND Var5=0 AND Var6=0 AND Var20<(-110);

DRAWTEXT(买些1>0,L-0.15,'B'),LINETHICK4,ALIGN1,colorred;{B}

DRAWTEXT(买些2>0,L-0.25,{'B'}'买'),LINETHICK4,ALIGN1,COLOR00FFFF;{B}

DRAWTEXT(产品卖点1>0,H 0.95,{'S'}'卖'),LINETHICK4,ALIGN1,COLOR33FF33;{S}

{83}

{十字鼠标光标提醒}

a:="LTFunc6@FORLT2";

s1:="LTFunc6@LT_S1";{X }

hs:="LTFunc6@LT_HS";

ls:="LTFunc6@LT_LS";

p1:="LTFunc6@LT_P1";

upp:="LTFunc6@LT_UPP";

udd:="LTFunc6@LT_UDD";

{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};

d1:=ema(abs("ddx.ddx"),60);

d2:=max("ddx.ddx"/d1+7.5,7.5);

d3:=min("ddx.ddx"/d1,10);

fb:=if(s1=0,hs,ls);

tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现“卖”点\n','若明日收盘价>'+numtostrn(upp,2)+',出现“买”点\n');{1.BS点:}

tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');{2.短线:}

tr2:=ifs(p1=1,ifs(cross(p1,0),'“买”点','持股'),ifs(cross(1,p1),'“卖”点','持币'));{1.BS点:}

tr3:=ifs(s1=0,'向下,','向上,');{2.短线:}

tr4:='3.能量级别:'+numtostrn(d3,1)+'级';{3.能量级别:}

{102}

c1:=INTPART(cyc(5)*100*0.96)/100;

p2:=intpart(ref(cyc(5),1)*100)/100;

p3:=intpart(ref(cyc(5),1)*0.96*100)/100;

vv:=intpart(min(capital*0.05,ref(ma(vol,34),1))/100);

p40:=intpart(maxcyc*100)/100;

p41:=intpart(ref(MAXCYC,1)*100)/100;

p4:=p1=0 and c>p2 or (ref(vol/100,1)<vv and c>intpart(p2*0.98*100)/100 and vol>min(capital*0.05,ref(ma(vol,34),1)));

p5:=p1=1 and c<min(p3,p41);

p1:=if(p4=1,1,if(p5=1,0,ref(p1,1)));

DRAWFLAGTEXT(p1=0 and (c1*0.98-c)/c>0.1,c,'持币');{4.}

DRAWFLAGTEXT(p1=0 and (c1*0.98-c)/c<=0.1 and ref(vol/100,1)<vv,c,'明日收盘价超过'+str(c1)+';或收盘价超过'+str(intpart(c1*0.98*100)/100)+'且成交量大于'+str(vv)+'买入');

DRAWFLAGTEXT(p1=0 and (c1*0.98-c)/c<=0.1 and ref(vol/100,1)>=vv,c,'明日收盘价超过'+str(c1)+'买入');

DRAWFLAGTEXT(p1=1 and (c-min(c1,p40))/min(c1,p40)>0.1 ,c,'持股');

DRAWFLAGTEXT(p1=1 and (c-min(c1,p40))/min(c1,p40)<=0.1 ,c,'明日收盘价跌破'+str(min(c1,p40))+'卖出');

{117}

bs:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+datestr(date)+'买卖点决策系统提示\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'1.BS点:'+tr2+','+tr0+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'2.短线:'+tr3+tr1+'\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+tr4;

drawflagtext(1,fb,bs);

MA5:=MA(C,5);

MA10:=MA(C,10);

MA20:=MA(C,20);

MA30:=MA(C,30);

MA60:=MA(C,60);

MA120:=MA(C,120);

MA250:=MA(C,250);

BIAS:=(C-MA20)/MA20*100;

SHOPEN:=OPEN;

SHHIGH:=HIGH;

SHLOW:=LOW;

SHCLOSE:=CLOSE;

SHAMOUNT:=AMOUNT;

SHVOL:=VOL;

J12:=(HIGH - ((HIGH - LOW) / 3));

J23:=(LOW + ((HIGH - LOW) / 3));

t1:=(((IF((CLOSE = OPEN),1,0) + IF((CLOSE >= J12),1,0)) + IF((CLOSE <= J23),1,0)) > 1);

t2:=((((CLOSE > J23) AND (CLOSE < J12)) AND (OPEN > J23)) AND (OPEN < J12));

t3:=((CLOSE >= J12) AND (OPEN <= J23));

t4:=(((OPEN <= J12) AND (OPEN >= J23)) AND (CLOSE > J12));

t5:=(((OPEN <= J23) AND (CLOSE <= J12)) AND (CLOSE >= J23));

t6:=((CLOSE <= J23) AND (OPEN >= J12));

t7:=(((OPEN <= J12) AND (OPEN >= J23)) AND (CLOSE < J23));

t8:=(((OPEN >= J12) AND (CLOSE <= J12)) AND (CLOSE >= J23));

t9:=(((SHAMOUNT / SHVOL) / 100) > REF(HIGH,1));

t10:=(((SHAMOUNT / SHVOL) / 100) < REF(LOW,1));

if DISPSTATUS=2 then begin;

var1000:='.';

不胜感激!!!

解答如下:

{未来函数集中营,小心使用啊}

Var10:=IF(TROUGH(3,16,1)=0 AND H>L+0.04,4,0);

Var11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);

Var13:=ZIG(3,22)>REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);

Var15:=ZIG(3,51)>REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);

Var17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);

买点1:=Var10;

买点2:=(Var11+Var13+Var15+Var17);

买点1>0 OR 买点2>0;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号