广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把第四根绿柱动态底端改成同花顺的并写个选股公式

  • 牛股公式
  • 2020-09-11 08:27
  • 牛股网
广告管理-720PX*80PX

编写标准:

编写方式 :网民求助:

第四根绿柱动态底端

源代码:

{动态底端 顸誓N=1 120 13,M=1 120 3,P=30 30<=P<50};

DIF:EMA(CLOSE,6)-EMA(CLOSE,13);

DEA:EMA(DIF,5);

MACD:(DIF-DEA)*2,COLORSTICK;

DRAWTEXT(REF(MACD,1)>0 AND MACD<0,MACD-0.01,'1');

DRAWTEXT(REF(MACD,2)>0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'2');

DRAWTEXT(REF(MACD,3)>0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'3');

DRAWTEXT(REF(MACD,4)>0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'4');

DRAWTEXT(REF(MACD,5)>0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'5');

DRAWTEXT(REF(MACD,6)>0 AND REF(MACD,5)<0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'6');

绿线天:=BARSLAST(CROSS(DEA,DIF));

红杠天:=BARSLAST(CROSS(DIF,DEA));

工作压力:REF(H,绿线天),NODRAW;

支撑点:REF(O,红杠天),NODRAW;

A2:=IF(CROSS(0,DEA),1,0);

A12:=IF(DIF>0 AND CROSS(DIF,DEA),1,0);

SS2:=IF(A2,SUM(A12,0),0);

SSB2:=HHV(SS2,0);

SSS2:=SUM(A12,0);

轴上第1次macd金叉:IF(SSS2-SSB2=1 AND SSS2>REF(SSS2,1),1,0),NODRAW;

DRAWICON(轴上第1次macd金叉,0.2,1);

破0轴: REF(DIF,1)>0 AND DIF<0,COLORGREEN,NODRAW;

DRAWICON(破0轴,0.1,2);

第四根绿柱:REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3) <=0 AND MACD<=0 AND REF(MACD,4) >=0,COLORRED,NODRAW;

DRAWICON(第四根绿柱,0,11);

好发展趋势2:=MA((3*SMA((C-LLV(L,M))/(HHV(H,M)-LLV(L,M))*100,3,1)),2)

-MA((2*SMA(SMA((C-LLV(L,M))/(HHV(H,M)-LLV(L,M))*100,3,1),3,1)),2);

动态底端2:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)

/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好发展趋势2<REF(好发展趋势2,1)

AND 好发展趋势2<50,-5,-2.5);

好发展趋势:=MA((3*SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,3,1)),2)

-MA((2*SMA(SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,3,1),3,1)),2);

动态底端:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)

/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好发展趋势<REF(好发展趋势,1)

AND 好发展趋势<50,-5,-3);

买警:=IF(好发展趋势<=-3 AND 好发展趋势<REF(好发展趋势,1),-5,

IF(好发展趋势<=0 AND 好发展趋势<REF(好发展趋势,1),-4.9,

IF(好发展趋势<=3 AND 好发展趋势<REF(好发展趋势,1),-4.8,

IF(好发展趋势<=6 AND 好发展趋势<REF(好发展趋势,1),-4.6,

IF(好发展趋势<=9 AND 好发展趋势<REF(好发展趋势,1),-4.4,

IF(好发展趋势<=12 AND 好发展趋势<REF(好发展趋势,1),-4.2,

IF(好发展趋势<=15 AND 好发展趋势<REF(好发展趋势,1),-4.0,

IF(好发展趋势<=18 AND 好发展趋势<REF(好发展趋势,1),-3.8,

IF(好发展趋势<=21 AND 好发展趋势<REF(好发展趋势,1),-3.6,

IF(好发展趋势<=24 AND 好发展趋势<REF(好发展趋势,1),-3.4,

IF(好发展趋势<=27 AND 好发展趋势<REF(好发展趋势,1),-3.2,

IF(好发展趋势<=30 AND 好发展趋势<REF(好发展趋势,1),-3.1,0))))))))))));

CROSS(动态底端,-4) AND CROSS(动态底端2,-4) AND REF(买警,1)<-P/10

AND DYNAINFO(39)>0 AND DYNAINFO(17)>0 AND C<20;

把第四根绿柱动态底部改为大智慧的并写个选股公式

图上小圆圈划到的为合理数据信号。

选股公式为

当见到DIF网上穿DEA,另外出現淡黄色标示时,股票短线能够 依据阻力位和支撑线的提醒买进。

解释以下:

{同花顺}

N:=13;M:=3;P:=30 ;

DIF:EMA(CLOSE,6)-EMA(CLOSE,13);

DEA:EMA(DIF,5);

MACD:(DIF-DEA)*2,COLORSTICK;

DRAWTEXT(REF(MACD,1)>0 AND MACD<0,MACD-0.01,'1');

DRAWTEXT(REF(MACD,2)>0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'2');

DRAWTEXT(REF(MACD,3)>0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'3');

DRAWTEXT(REF(MACD,4)>0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'4');

DRAWTEXT(REF(MACD,5)>0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'5');

DRAWTEXT(REF(MACD,6)>0 AND REF(MACD,5)<0 AND REF(MACD,4)<0 AND REF(MACD,3)<0 AND REF(MACD,2)<0 AND REF(MACD,1)<0 AND MACD<0,MACD-0.01,'6');

绿线天:=BARSLAST(CROSS(DEA,DIF));

红杠天:=BARSLAST(CROSS(DIF,DEA));

工作压力:REF(H,绿线天),LINETHICK0;

支撑点:REF(O,红杠天),LINETHICK0;

A2:=IF(CROSS(0,DEA),1,0);

A12:=IF(DIF>0 AND CROSS(DIF,DEA),1,0);

SS2:=IF(A2,SUM(A12,0),0);

SSB2:=HHV(SS2,0);

SSS2:=SUM(A12,0);

轴上第1次macd金叉:IF(SSS2-SSB2=1 AND SSS2>REF(SSS2,1),1,0),LINETHICK0;

DRAWICON(轴上第1次macd金叉,0.2,1),ALIGN1,LAYER0;

破0轴: REF(DIF,1)>0 AND DIF<0,COLORGREEN,LINETHICK0;

DRAWICON(破0轴,0.1,2),ALIGN1,LAYER0;

第四根绿柱:REF(MACD,1)<REF(MACD,2) AND REF(MACD,2)<REF(MACD,3) AND REF(MACD,3) <=0 AND MACD<=0 AND REF(MACD,4) >=0,COLORRED,LINETHICK0;

{DRAWICON(第四根绿柱,0,11)};

好发展趋势2:=MA((3*SMA((C-LLV(L,M))/(HHV(H,M)-LLV(L,M))*100,3,1)),2)

-MA((2*SMA(SMA((C-LLV(L,M))/(HHV(H,M)-LLV(L,M))*100,3,1),3,1)),2);

动态底端2:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)

/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好发展趋势2<REF(好发展趋势2,1)

AND 好发展趋势2<50,-5,-2.5);

好发展趋势:=MA((3*SMA((C-LLV(L,N))/(HHV(H,N)-LLV(L,N))*100,3,1)),2)

-MA((2*SMA(SMA((C-LLV(L,N ))/(HHV(H,N)-LLV(L,N))*100,3,1),3,1)),2);

动态底部:=IF(EMA(IF(L<=LLV(L,13),SMA(ABS(L-REF(L,1)),5,1)

/SMA(MAX(L-REF(L,1),0),5,1),0),3)*10 AND 好趋势<REF(好趋势,1)

AND 好趋势<50,-5,-3);

买警:=IF(好趋势<=-3 AND 好趋势<REF(好趋势,1),-5,

IF(好趋势<=0 AND 好趋势<REF(好趋势,1),-4.9,

IF(好趋势<=3 AND 好趋势<REF(好趋势,1),-4.8,

IF(好趋势<=6 AND 好趋势<REF(好趋势,1),-4.6,

IF(好趋势<=9 AND 好趋势<REF(好趋势,1),-4.4,

IF(好趋势<=12 AND 好趋势<REF(好趋势,1),-4.2,

IF(好趋势<=15 AND 好趋势<REF(好趋势,1),-4.0,

IF(好趋势<=18 AND 好趋势<REF(好趋势,1),-3.8,

IF(好趋势<=21 AND 好趋势<REF(好趋势,1),-3.6,

IF(好趋势<=24 AND 好趋势<REF(好趋势,1),-3.4,

IF(好趋势<=27 AND 好趋势<REF(好趋势,1),-3.2,

IF(好趋势<=30 AND 好趋势<REF(好趋势,1),-3.1,0))))))))))));

CROSS(动态底部,-4) AND CROSS(动态底部2,-4) AND REF(买警,1)<-P/10

AND DYNAINFO(39)>0 AND DYNAINFO(17)>0 AND C<20;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号