广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把“股票短线”副图改个预警选股公式

  • 牛股公式
  • 2020-09-11 08:09
  • 牛股网
广告管理-720PX*80PX

编写条件:

编写方式 :网友求助:

请教师依据“股票短线”副图源代码做一个预警选股公式,当出現深蓝色向上的箭头时开展预警。感谢老师!原码以下:

LONGGGG发家致富线:=38,COLORFF3311;

STICKLINE(C>0,38,38,1,1),COLORFF9911;

LONGGGG移动平均线:=51,COLORFF1155;

STICKLINE(C>0,51,51,1,1),COLORFF1199;

OK:=REF(CLOSE,1);

RSI1:SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORFFFFFF;

RSI2:SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORFFFFFF;

RSI3:SMA(MAX(CLOSE-OK,0),7,1)/SMA(ABS(CLOSE-OK),7,1)*100,COLORFFFFFF;

RSI4:SMA(RSI3,7,1),LINETHICK2,COLOR00CD00;

发展趋势A:=MA(((CLOSE-LLV(LOW,48))/(HHV(HIGH,48)-LLV(LOW,48))*50),17) 9,COLORFFFFFF;

发展趋势B:=MA(((CLOSE-LLV(LOW,53))/(HHV(HIGH,53)-LLV(LOW,53))*50),17) 9,COLOR3377DD;

发展趋势C:EMA(((CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*50),17) 18,COLORYELLOW,LINETHICK2;

W1:MA(发展趋势A,7)*1.372,COLORRED,LINETHICK2;

W2:=W1*1.0887;

W3:(1.5*(发展趋势B RSI4)-(W2 W1)) 12,COLOR3377FF,COLORRED,LINETHICK2,COLORFF0000;

W4:IF((CROSS(W1,发展趋势C) OR CROSS(W1,W3) AND W3<LONGGGG发家致富线 AND RSI2<LONGGGG移动平均线),48,38),COLORFFFFFF;

XG:IF((CROSS(RSI2,RSI4) OR CROSS(RSI2,W3) AND W3<LONGGGG发家致富线 AND RSI1<LONGGGG移动平均线),48,38),COLORFF6655;

解释以下:

lc:=ref(c,1);

rsi1:=sma(max(c-lc,0),7,1)/sma(abs(c-lc),7,1)*100;

rsi2:=sma(max(c-lc,0),7,1)/sma(abs(c-lc),7,1)*100;

rsi3:=sma(max(c-lc,0),7,1)/sma(abs(c-lc),7,1)*100;

rsi4:=sma(rsi3,7,1);

发展趋势a:=ma(((c-llv(l,48))/(hhv(h,48)-llv(l,48))*50),17) 9;

发展趋势b:=ma(((c-llv(l,53))/(hhv(h,53)-llv(l,53))*50),17) 9;

w1:=ma(发展趋势a,7)*1.372;

w2:=w1*1.0887;

w3:=(1.5*(发展趋势b rsi4)-(w2 w1)) 12;

cross(rsi2,rsi4) or cross(rsi2,w3) and w3<38 and rsi1<51;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号