广告管理-1170PX*80PX
广告管理-770PX*90PX
当前位置:牛股网 > 牛股公式 >

把通达信资金突破变成同花顺的

  • 牛股公式
  • 2020-09-05 08:51
  • 牛股网
广告管理-720PX*80PX

编写标准:通达信公式资金突破,求大神改变成同花顺的

买线:=EMA(C,2);

卖线:=EMA(SLOPE(C,21)*20 C,42);

BU:=CROSS(买线,卖线);

SEL:=CROSS(卖线,买线);

STICKLINE(买线>=卖线,LOW,HIGH,0.1,0),COLORRED;

STICKLINE(买线>=卖线,CLOSE,OPEN,3,0),COLORRED;

STICKLINE(买线<卖线,CLOSE,OPEN,3,0),COLORFFF000;

STICKLINE(买线=E2)) OR ISLASTBAR=1 OR BARSCOUNT(CLOSE)=1;

H2:=D1 AND NOT(D2 AND E1>=E2);

L1:=D2 AND NOT(D1 AND E1=E2);

X1:=REF(BARSLAST(H1),1) 1;

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));

G1:=F1>REF(F1,1);

I1:=BACKSET(G1,2);

LD:=I1>REF(I1,1);

L2:=LD OR ISLASTBAR=1 OR BARSCOUNT(CLOSE)=1;

X2:=REF(BARSLAST(L2),1) 1;

F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));

G2:=F2>REF(F2,1);

I2:=BACKSET(G2,2);

HD:=I2>REF(I2,1);

UU2:=BACKSET(ISLASTBAR=1,BARSLAST(HD) 1);

VV2:=UU2>REF(UU2,1);

WW2:=BACKSET(VV2,REF(BARSLAST(HD),1) 2);

XX2:=WW2>REF(WW2,1);

突破线:=REF(H,BARSLAST(VV2));

持仓线:=REF(H,BARSLAST(XX2));

TP1:=CROSS(C,突破线);

TP2:=CROSS(C,持仓线);

STICKLINE(TP1,H,L,0,0),COLORYELLOW;

STICKLINE(TP1,C,O,3,0),COLORYELLOW;

STICKLINE(TP1,C,O,3,0),COLORYELLOW;

STICKLINE(TP1,C,O,1,0),COLORYELLOW;

DRAWTEXT(TP1,LOW*0.98,'资金突破'),LINETHICK1,COLORYELLOW;

STICKLINE(TP2,H,L,0,0),COLORYELLOW;

STICKLINE(TP2,C,O,3,0),COLORYELLOW;

STICKLINE(TP2,C,O,3,0),COLORYELLOW;

STICKLINE(TP2,C,O,1,0),COLORYELLOW;

DRAWTEXT(TP2,LOW*0.98,'资金突破'),LINETHICK1,COLORYELLOW;

编写方式:买线:=EMA(C,2);

卖线:=EMA(SLOPE(C,21)*20 C,42);

BU:=CROSS(买线,卖线);

SEL:=CROSS(卖线,买线);

STICKLINE(买线>=卖线,LOW,HIGH,0.1,0),COLORRED;

STICKLINE(买线>=卖线,CLOSE,OPEN,3,0),COLORRED;

STICKLINE(买线<卖线,CLOSE,OPEN,3,0),COLORFFF000;

STICKLINE(买线<卖线,LOW,HIGH,0.1,0),COLORFFF000;

Z1:=REF(HIGH,4)=HHV(HIGH,2*4 1);

Y1:=FILTER(Z1,3);

C1:=BACKSET(Y1,3 1);

D1:=FILTER(C1,3);

A2:=REF(LOW,3)=LLV(LOW,2*3 1);

V2:=FILTER(A2,3);

C2:=BACKSET(V2,3 1);

D2:=FILTER(C2,3);

E1:=(REF(LLV(LOW,2*3),1) REF(HHV(HIGH,2*3),1))/2;

E2:=(HIGH LOW)/2;

H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

H2:=D1 AND NOT(D2 AND E1>=E2);

L1:=D2 AND NOT(D1 AND E1=E2);

X1:=REF(BARSLAST(H1),1) 1;

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));

G1:=F1>REF(F1,1);

I1:=BACKSET(G1,2);

LD:=I1>REF(I1,1);

L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1;

X2:=REF(BARSLAST(L2),1) 1;

F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));

G2:=F2>REF(F2,1);

I2:=BACKSET(G2,2);

HD:=I2>REF(I2,1);

UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD) 1);

VV2:=UU2>REF(UU2,1);

WW2:=BACKSET(VV2,REF(BARSLAST(HD),1) 2);

XX2:=WW2>REF(WW2,1);

突破线:=REF(H,BARSLAST(VV2));

持仓线:=REF(H,BARSLAST(XX2));

TP1:=CROSS(C,突破线);

TP2:=CROSS(C,持仓线);

STICKLINE(TP1,H,L,0,0),COLORYELLOW;

STICKLINE(TP1,C,O,3,0),COLORYELLOW;

STICKLINE(TP1,C,O,3,0),COLORYELLOW;

STICKLINE(TP1,C,O,1,0),COLORYELLOW;

DRAWTEXT(TP1,LOW*0.98,'资金突破'),LINETHICK1,COLORYELLOW;

STICKLINE(TP2,H,L,0,0),COLORYELLOW;

STICKLINE(TP2,C,O,3,0),COLORYELLOW;

STICKLINE(TP2,C,O,3,0),COLORYELLOW;

STICKLINE(TP2,C,O,1,0),COLORYELLOW;

DRAWTEXT(TP2,LOW*0.98,'资金突破'),LINETHICK1,COLORYELLOW;

广告管理-720PX*80PX

  • 关注微信

相关文章

微信公众号