欢迎访问牛股网

牛股网

当前位置:牛股网 >股票代码 >

股票代码

冷暖气带选股公式

发布时间:2020-09-10 13:58 作者:牛股网
编写标准:编写方式:网民求助:写一个B点选股公式,我想问一下B点是否有未来函数?公式计算以下:MA3:MA(CLOSE,5),PRECIS2;MA7:MA(CLOSE,10),PRECIS2;MA18:MA(CLOSE,18),PRECIS2;MA30:MA(CLOSE,30),PRE...

编写标准:

编写方式 :网民求助:

写一个“B”点选股公式,我想问一下B点是否有未来函数?公式计算以下:

MA3:MA(CLOSE,5),PRECIS2;

MA7:MA(CLOSE,10),PRECIS2;

MA18:MA(CLOSE,18),PRECIS2;

MA30:MA(CLOSE,30),PRECIS2;

MA55:MA(CLOSE,60),PRECIS2;

MA144:MA(CLOSE,120),PRECIS2;

{气球花}

FILLRGN(MA55,MA144,MA55>MA144,RGB(86,0,0),MA55<MA144,RGB(0,86,0)),LAYER7;

FILLRGN(MA3,MA7,MA3>MA7,RGB(128,0,128),MA3<MA7,RGB(20,92,100)),LAYER7;

{DRAWTEXTREL(0,980,'【绵绵细雨无音自购指标值】'),Color999933,linethick1;}

A:=BARSLAST(DISPSTATUS=1) 1; HH:=HHV(H,A); LL:=LLV(L,A);

增涨:BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(L=LL) 1)),COLOR3333CC,linethick0;

↑室内空间%:(C/REF(L,增涨)-1)*100,COLOR339999,linethick0;

最大%:(HHVALL(HH)/REF(L,增涨)-1)*100,COLORDD66DD,linethick0;

下挫:BARSSINCE(BACKSET(DISPSTATUS=2,BARSLAST(H=HH) 1)),COLOR008800,linethick0;

↓室内空间%:(C/REF(H,下挫)-1)*100,COLOR998888,linethick0;

最少%:(LLVALL(LL)/REF(H,下挫)-1)*100,COLORFF9900,linethick0;

DRAWTEXTABS(40,26,'流通股本:' CAPITAL/1000000 '每股公积金,盈利提高:' FINANCE2(10) '%。每股净资产:' FINANCE2(3) '元' ' 市净率:' DYNAINFO(39) '%'),ColorFFBB33,linethick1,LAYER6;

{交易标示}

Var0:=SMA(MAX(CLOSE-ref(c,1),0),12,1)/SMA(ABS(CLOSE-ref(c,1)),15,1)*100;

DRAWTEXT(CROSS(82,Var0),high,'卖'),colorwhite;

s:=C-REF(C,1);

DX:=100*EMA(EMA(s,6),6)/EMA(EMA(ABS(s),6),6);

买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);

DRAWTEXT(filter(买=1,5),LOW-0.03,'升'),ColorFFDE00;

da:=(EMA(C,1) EMA(C,2) EMA(C,3) EMA(C,4))/4;

db:=(EMA(C,10) EMA(C,20) EMA(C,40) EMA(C,80))/4;

DRAWTEXT(CROSS(da-db,0),L*0.99,'B'),ALIGN1,VALIGN0,COLOR00FFFF,linethick5;

JH:=SMA(MAX(C-REF(C,1),0),5,1)/SMA(ABS(C-REF(C,1)),5,1)*100;

DRAWTEXT(CROSS(84,JH),H*1.02,'S'),ALIGN1,VALIGN0,COLORGREEN,linethick4;

YC:=REF(CLOSE,1);

止损价位:(YC*1.0035*97 0.2)/99.65,PRECIS2,ColorFFCC33,LINETHICK0;

菜盘:CAPITAL/1000000,linethick0;

菜盘1:CAPITAL/100,linethick0;

菜盘2:FINANCE2(37),linethick0;

{空缺}

STICKLINE(L>REF(H,1),L,REF(H,1),50,1001),Color408080;

STICKLINE(REF(L,1)>H,ref(L,1),H,50,1001),Color808040;

DRAWTEXT(L>REF(H,1),REF(H,1),NUMTOSTRN(REF(H,1),2) '-' NUMTOSTRN(L,2)),Color408080;

DRAWTEXT(REF(L,1)>H,REF(L,1),NUMTOSTRN(ref(l,1),2) '-' NUMTOSTRN(h,2)),VALIGN2,Color808040;

{K线}

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0),COLOR5454FF;

STICKLINE(CLOSE<OPEN,CLOSE,OPEN,7,0),COLORFFFF00;

STICKLINE(CLOSE>OPEN,HIGH,CLOSE,0.1,0),COLOR5454FF;

STICKLINE(CLOSE>OPEN,LOW,OPEN,0.1,0),COLOR5454FF;

STICKLINE(CLOSE<OPEN,HIGH,OPEN,0.1,0),COLORFFFF00;

STICKLINE(CLOSE<OPEN,LOW,CLOSE,0.1,0),COLORFFFF00;

STICKLINE(CLOSE=OPEN AND CLOSE>REF(CLOSE,1),CLOSE,OPEN,7,0),COLOR5454FF;

STICKLINE(CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),CLOSE,OPEN,7,0),COLORFFFF00;

STICKLINE(CLOSE=OPEN AND CLOSE>REF(CLOSE,1),HIGH,LOW,0.1,0),COLOR5454FF;

STICKLINE(CLOSE=OPEN AND CLOSE<=REF(CLOSE,1),HIGH,LOW,0.1,0),COLORFFFF00;

{操作提示}

平均价:=(3*C H L O)/6;

VAR1:=(8*平均价 7*REF(平均价,1) 6*REF(平均价,2) 5*REF(平均价,3)

4*REF(平均价,4) 3*REF(平均价,5) 2*REF(平均价,6) REF(平均价,8))/36;

VAR2:=(LLV(VAR1,2) LLV(VAR1,4) LLV(VAR1,6))/3;

SZ1:=REF(VAR1,1)=REF(VAR2,1) AND VAR1>VAR2 AND CLOSE>VAR1;

SZ2:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)

AND H/VAR1<1.1 AND L>VAR2 AND CLOSE>VAR1;

SZ3:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>=REF(VAR2,1) AND H/VAR1>1.1;

SZ4:=VAR1>VAR2 AND VAR1>REF(VAR1,1) AND VAR2>REF(VAR2,1)

AND CLOSE>VAR2 AND CLOSE<VAR1;

SZ5:=(VAR1>VAR2 AND VAR2>REF(VAR2,1) AND VAR1<>REF(VAR1,1)

AND CLOSE<VAR2) OR (VAR1>VAR2 AND VAR1<REF(VAR1,1)

AND VAR2<REF(VAR2,1) AND CLOSE<VAR2);;

SZ6:=REF(VAR1,1)>REF(VAR2,1) AND VAR1=VAR2 AND CLOSE<VAR2;

XD1:=VAR1=VAR2 AND CLOSE<VAR2 OR (VAR1<REF(VAR1,1) AND VAR2<REF(VAR2,1)

AND REF(VAR1,1)=REF(VAR2,1) AND CLOSE<VAR2);

XD2:=VAR1=VAR2 AND CLOSE>VAR1;

SAT:=(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20));

量比对比度:=IF(SAT>1,1,SAT)*100;

IF BARSTATUS=2 AND SZ1 THEN BEGIN

DRAWTEXTABS(40,48,'操作提示:调节完毕股票短线干预'),COLORRED,linethick3;

END

ELSE

IF BARSTATUS=2 AND SZ2 THEN BEGIN

DRAWTEXTABS(40,48,'操作提示:升高安全通道行情优良'),COLORRED,linethick3;

END

ELSE

IF BARSTATUS=2 AND SZ3 THEN BEGIN

DRAWTEXTABS(40,48,'操作提示:股票价格偏移留意调节'),COLORRED,linethick3;

END

ELSE

IF BARSTATUS=2 AND SZ4 THEN BEGIN

DRAWTEXTABS(40,48,'操作提示:升高安全通道调节震仓'),COLORGREEN,linethick3;

END

ELSE

IF BARS TATUS=2 AND SZ5 THEN BEGIN

DRAWTEXTABS(40,48,'操作提示:转向特征注意离场'),COLORGREEN,linethick3;

END

ELSE

IF BARSTATUS=2 AND SZ6 THEN BEGIN

DRAWTEXTABS(40,48,'操作提示:通道改变坚决离场'),COLORGREEN,linethick3;

END

ELSE

IF BARSTATUS=2 AND XD1 THEN BEGIN

DRAWTEXTABS(40,48,'操作提示:下跌通道只宜观望'),COLORGREEN,linethick3;

END

ELSE

IF BARSTATUS=2 AND XD2 THEN BEGIN

DRAWTEXTABS(40,48,'操作提示:短期底部准备进入'),COLORYELLOW,linethick3;

END;

解答如下:

DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;

DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;

CROSS(DA-DB,0);

标签
广告位-