当前位置:牛股网 > 牛股宝 >

教你同花顺MACD面积公式,怎样显示小数点后俩位数据?

  • 牛股宝
  • 2020-09-10 08:36
  • 牛股网

编写标准:

编写方式:网民寻求帮助:

公式计算在同花顺中被四舍五入只显示个位数,我要显示至少小数点后二位数,

你加了 PRECIS2 ,沒有功效, *100 得话倒是能显示大量,但是并不是本意,

请教各位朋友们,

公式计算以下:

DIFF:EMA(CLOSE,S) - EMA(CLOSE,P);

DEA:EMA(DIFF,M);

MACD:2*(DIFF-DEA),COLORSTICK;

MACDHS:=IF(MACD>0 AND MACD>REF(MACD,1),MACD,0);

MACDHX:=IF(MACD>0 AND MACD<REF(MACD,1),MACD,0);

MACDLX:=IF(MACD<0 AND MACD<REF(MACD,1),MACD,0);

MACDLS:=IF(MACD<0 AND MACD>REF(MACD,1),MACD,0);

绿柱总面积:=IF(MACD>0,SUM(MACD,BARSLAST(MACD<0)),0),PRECIS2,COLOR0000FF;

绿柱总面积:=IF(MACD<0,SUM(MACD,BARSLAST(MACD>0)),0),PRECIS2,COLOR006000;;

DRAWTEXT(REF(MACD,1)>0 AND MACD<=0 ,HHV(MACD,4),'' REF(绿柱总面积,1)),colorred;

DRAWTEXT(REF(MACD,1)<0 AND MACD>=0 ,LLV(MACD,4),'' REF(ABS(绿柱总面积),1)),Color00ff00;

DRAWTEXT(ISNULL(REFX(&CLOSE,1))=1 AND MACD<0,LLV(MACD,4),'' ABS(绿柱总面积)),Color004A00;

DRAWTEXT(ISNULL(REFX(&CLOSE,1))=1 AND MACD>0,HHV(MACD,4),'' ABS(绿柱总面积)),colorred;

解释以下:

DRAWTEXT(REF(MACD,1)>0 AND MACD<=0 ,HHV(MACD,4),'' TOSTRING(REF(绿柱总面积,1),2)),colorred;

DRAWTEXT(REF(MACD,1)<0 AND MACD>=0 ,LLV(MACD,4),'' TOSTRING(REF(ABS(绿柱总面积),1),2)),Color00ff00;

DRAWTEXT(ISNULL(REFX(&CLOSE,1))=1 AND MACD<0,LLV(MACD,4),'' TOSTRING(ABS(绿柱总面积),2)),Color004A00;

DRAWTEXT(ISNULL(REFX(&CLOSE,1))=1 AND MACD>0,HHV(MACD,4),'' TOSTRING(ABS(绿柱总面积),2)),colorred;

  • 关注微信

相关文章

微信公众号