欢迎访问牛股网

牛股网

当前位置:牛股网 >股票代码 >

股票代码

把KDJ共震金叉指标值改变成选股公式

发布时间:2020-09-10 08:33 作者:牛股网
撰写标准:本月金叉,周金叉,日金叉三个数据信号中考虑随意2个数据信号另外出現,请帮助改为选股公式!!以处理,感谢休闲娱乐2010教师!!!共震金叉KDJ源代码:月K:"KDJ.K"(89,3,3),C...

撰写标准:本月金叉,周金叉,日金叉三个数据信号中考虑随意2个数据信号另外出現,请帮助改为选股公式!!以处理,感谢休闲娱乐2010教师!!!

共震金叉KDJ源代码:

月K:"KDJ.K"(89,3,3),COLOR00FF00;

月D:"KDJ.D"(89,3,3),COLOR00FF00,LINETHICK2;

周K:"KDJ.K"(27,3,3),COLORRED;

周D:"KDJ.D"(27,3,3),COLORRED,LINETHICK2;

日K:"KD.K"(5,3,3),COLORWHITE;

日D:"KD.D"(5,3,3),COLORWHITE,LINETHICK2;

日金叉:IF(CROSS(日K,日D),50,0),COLORFFFFFF;

DRAWTEXT(日金叉,50,'日叉'),COLORFFFFFF;

周金叉:IF(CROSS(周K,周D),30,0),COLORRED;

DRAWTEXT(周金叉,30,'周叉'),COLORRED;

月金叉:IF(CROSS(月K,月D),20,0),COLOR0080FF;

DRAWTEXT(月金叉,20,'月叉'),COLORYELLOW;

{KD在30下列数次金叉}

JM:=CROSS("KDJ.K"(5,3,3),"KDJ.D"(5,3,3));

JMCOUNT:=COUNT(JM,BARSLAST("KDJ.D"(5,3,3)>=30));

JMTJ:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=1,21)=1);

DRAWTEXT (JMTJ,70,'①'),COLORWHITE;

JMTJ2:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=2,21)=1);

DRAWTEXT (JMTJ2,70,'②'),COLORYELLOW;

JMTJ3:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=3,21)=1);

DRAWTEXT (JMTJ3,70,'③'),COLORYELLOW;

JMTJ4:=28*("KDJ.D"(5,3,3)<30 AND COUNT(JMCOUNT=4,21)=1);

DRAWTEXT (JMTJ4,70,'④'),COLORYELLOW;

JMTJ5:=28*("KDJ.D"(5,3,3)C AND REF(DIFF,A1 1)0,5),0,0.75,3,0),COLORGREEN;

DRAWTEXT(FILTER(B1>0,5),0.57,'MACD底背离'),COLORGREEN;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:=SMA(RSV,3,1);

D:=SMA(K,3,1);

A2:=BARSLAST(REF(CROSS(K,D),1));

B2:=REF(C,A2 1)>C AND REF(K,A2 1)0,5),0,1,3,0),COLORYELLOW;

DRAWTEXT(FILTER(B2>0,5),0.80,'KDJ底背离'),COLORYELLOW;

LC :=REF(CLOSE,1);

RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;

RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;

A3:=BARSLAST(REF(CROSS(RSI1,RSI2),1));

B3:=REF(C,A3 1)>C AND REF(RSI1,A3 1)0,5),0,0.5,3,0),COLORWHITE;

DRAWTEXT(FILTER(B3>0,5),0.25,'RSI底背离'),COLORWHITE;

2,COLORRED;

C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));

D1:=REF(C,C1 1)DIFF AND CROSS(DEA,DIFF);

MACD顶背离:STICKLINE(FILTER(D1>0,5),2,1.25,3,0),COLOR0066FF;

DRAWTEXT(FILTER(D1>0,5),1.47,'MACD顶背离'),COLOR0066FF;

C2:=BARSLAST(REF(CROSS(D,K),1));D2:=REF(C,C2 1)K AND CROSS(D,K);

KDJ顶背离:STICKLINE(FILTER(D2>0,5),2,1,3,0),COLORRED;

DRAWTEXT(FILTER(D2>0,5),1.2,'KDJ顶背离'),COLORRED;

C3:=BARSLAST(REF(CROSS(RSI2,RSI1),1));

D3:=REF(C,C3 1)RSI1 AND CROSS(RSI2,RSI1);

RSI顶背离:STICKLINE(FILTER(D3>0,5),2,1.5,3,0),COLORFF00FF;

DRAWTEXT(FILTER(D3>0,5),1.75,'RSI顶背离'),COLORFF00FF;

0,COLORFFA2AF;

20,COLORFFA2AF,POINTDOT;

50,COLORFFA2AF;

80,COLORFFA2AF,POINTDOT;

撰写方式:月K:="KDJ.K"(89,3,3);

月D:="KDJ.D"(89,3,3);

周K:="KDJ.K"(27,3,3);

周D:="KDJ.D"(27,3,3);

日K:="KD.K"(5,3,3);

日D:="KD.D"(5,3,3);

日金叉:=CROSS(日K,日D);

周金叉:=CROSS(周K,周D);

月金叉:=CROSS(月K,月D);

日金叉 周金叉 月金叉>1;

标签
广告位-