欢迎访问牛股网

牛股网

当前位置:牛股网 >股票代码 >

股票代码

把(DMI)编一个同花顺预警买入公式

发布时间:2020-09-08 09:34 作者:牛股网
编写标准:编写方式:网民寻求帮助:基本参数.3..2..在PDI从下往上穿过MDI,且另外ADX.ADXR在PDI以上,在做到之上标准下,(ADX从下往上穿过ADXR)作一预警买入公式,感谢老师解释以下:N:...

编写标准:

编写方式 :网民寻求帮助:

基本参数.3..2..在PDI从下往上穿过MDI,且另外ADX.ADXR在PDI以上,

在做到之上标准下,(ADX从下往上穿过ADXR)作一预警买入公式,感谢老师

解释以下:

N:=3;M:=2;

TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),N);

HD := HIGH-REF(HIGH,1);

LD := REF(LOW,1)-LOW;

DMP:= SUM(IF(HD>0 AND HD>LD,HD,0),N);

DMM:= SUM(IF(LD>0 AND LD>HD,LD,0),N);

PDI:=DMP*100/TR;

MDI:=DMM*100/TR;

ADX:=MA(ABS(MDI-PDI)/(MDI PDI)*100,M);

ADXR:=(ADX REF(ADX,M))/2;

CROSS(PDI,MDI) AND ADX>PDI AND ADXR>PDI AND CROSS(ADX,ADXR);

标签
广告位-