当前位置:牛股网 > 牛股宝 >

将《MACD选股》改为大智慧版

  • 牛股宝
  • 2020-09-05 17:54
  • 牛股网

编写条件:

编写方法:网友求助:

要求:将《MACD选股》改为大智慧版

{MACD选股}

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,27);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

顶背:=CROSS(COUNT(顶背离,10) AND CROSS(DIFF,DEA),0.01) AND REF(MACD<0,6) AND MACD<0;

底背:=CROSS(COUNT(二次金叉,5) AND 底背离,0.1) ;

N:=60;M:=3;N1:=-0.1;

金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=M,N)=1 AND DIFF<N1;

Q300:=IF(CODELIKE('300'),0,1);

S1:=IF(NAMELIKE('S'),0,1);

S2:=IF(NAMELIKE('*'),0,1);

ST:=S1 AND S2 AND Q300;

牛气冲天:(顶背 OR 底背 OR 金叉) AND ST;

解答如下:

应该是这样吧

{MACD选股}

DIFF:=EMA(CLOSE,12)-EMA(CLOSE,27);

DEA:=EMA(DIFF,9);

MACD:=2*(DIFF-DEA);

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

顶背:=CROSS(COUNT(顶背离,10) AND CROSS(DIFF,DEA),0.01) AND REF(MACD<0,6) AND MACD<0;

底背:=CROSS(COUNT(二次金叉,5) AND 底背离,0.1) ;

N:=60;M:=3;N1:=-0.1;

金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=M,N)=1 AND DIFF<N1;

ST:=STRFIND(stkname,'ST',1)>0;

S:=STRFIND(stkname,'S',1)>0;

停牌:=(DYNAINFO(4)=0);

K:=not(ST) and not(停牌) and not(S) AND NOT(INBLOCK('创业板'));

牛气冲天:(顶背 OR 底背 OR 金叉) AND K;

  • 关注微信

相关文章

微信公众号